Loading 3D model crashes DroneDeploy

Issue: Loading 3D model for 17.1 acres crashes DroneDeploy running on PC Lenovo Yoga 900 with 8GB RAM
Date: 4 Nov. 2017 but seen previously with a 15.2 acres model.
Drone: Phantom 4 Pro with 2.60.0 DD Android App flew mission fine taking 143 photos of the 17.1 acres area.
The 2D Map looks great, Plant Health is informative and the Elevation Map looks good. But loading the 17.1 acres 3D model caused the DD App to crash again and again until I went back and loaded the 15.1 acres model. After this “warm up”, the 17.1 acres model would load. Checking memory usage, the 15.2 acres model uses 1 GB while the 17.1 acres model uses 1.4 GB with only 38% of total memory consumed after the model loads. So it does not seem to be a memory problem.

Why does the PC DD App crash initially and then, with enough prodding, finally work?


You seem to be pushing that Lenovo to the edge of its capabilities, it can only do so much. Could you share a link to the model, I would like to see which of my laptops/tablets are happy running it.

Mark G.

Here is the link:

Most tablet processors are not powerful enough to run the 3D models.

Tried it on the PC, runs just fine, tried on the Nvidia Shield, plays well both in SD and HD, both these machines usually run my 3D stuff from DD, the real test is normally the Asus laptop and your 3D map runs ok in SD but the laptop freaks out with HD, exactly the same as any of my 3d stuff.
Conclusion, your Lenovo, like my Asus, is just not up to the job.

The 3D model is now loading fine on my Lenovo 900. Apparently it just needs a little warmup with a smaller model first. My Lenovo uses an i7 Skylake chip so its pretty capable. What chip is in your Asus laptop?

The Lenovo Yoga 900 is not a tablet. Is this what you thought Gary? It is a Windows 10 machine.