Latest app - maps won't cache for offline mapping

This was working before (e.g., plan a flight on the desktop, sync, then show up on location and fly the mission) - the app used to cache the maps so that an Internet connection was not needed in the field. Now this no longer works. The plans show up but without Internet, there are no maps.

Any ideas on how to solve this other than waiting for a bug fix?

I’m flying a Phantom 4 with the latest firmware and latest DroneDeploy app.

Same problem here and I do all of the correct setup procedures but never get a background map cached. I can see the waypoint tracks and everything works OK, just no background map. it has not worked for quite a while after more recent updates.

Hi @iflyskyhawks and @markwalters, I am sorry to hear that you are having this issue. Can the both of you please email us at Please include the version of the App that you are currently using as well as, your droneplay username so that we can look into this for you.

Support email sent - thanks !

Hii did you see any progress on this issue at all? Thanks.

The support reply was basically that caching background maps for offline survey use does not work at the moment. Hopefully this will become a feature again in the near future. I have had no issues flying without the map and just looking at the flight path during the survey. You can upload a shapefile which will provide background mapping and if you wanted this beta feature you might have to ask them to switch the option on for you

Is there any additional information about uploading a shapefile for background mapping? I to have no background maps when flying offline. Planned on desktop, synced, but no background in the field. Would really like to get this fixed.

@onetmat There is some guidance on using shapefiles here Some people have had issues if they upload complex shapes and the WGS84 projection seems to work best.

1 Like

I have gotten shp file uploads to work but that only has the area polygon. I will need to preplan a flight before going to the field then until this feature is fixed. Don’t really like the idea of flying sort of blind but I guess that’s the option right now. Thanks for the reply.

Was any progress ever made on caching maps for background use? I’ll be in an area with no data tomorrow, and through testing it appears as though this function still doesn’t work. Someone please correct me if I’m wrong.

Unfortunately, no change. There’s a new system message that “last three maps have been synced for offline use” but that was never our issue. We need the latest FLIGHT PLANS to be synced so we can then fly them out in the field with map data.

This SHOULD be the number one priority for Drone Deploy. DJI has been caching maps in their apps since day one. This shouldn’t be difficult.

As it stands, I’m having to use a small iPhone in the field when I could and want to be using a larger iPad to monitor the map creation process.


DD really need to get on top of this lack of cached background maps issue for offline use ASAP. I get fedup of seeing emails telling me about wizzy new apps and DD partnerships etc. when they should really be sorting out the fundamental issues with their own app and the quality of some of the exported files (Raw elevation data files for example). They are starting to lose sight of the basic needs of their core users.

1 Like

We can probably adjust the wording of that message. It is not referring to your maps. It is referring to your offline tiles so you can plan in the field without internet.

Interesting. That’s what we want the app to do but it’s not actually caching the maps. I get the message when I’m Internet connected but when I’m out in the field, none of my maps for planning are cached.

Are you on android or ios? They work slightly differently.

I’m on iOS. Would love to find out how to make this work!

I’m on iOS and having the ability to cache the background satellite maps is VERY IMPORTANT. I’m a bit surprised that it’s not do-able at the moment, will be watching this closely.

This works for us in all of our tests. I’m trying to figure out why it is not working for you.

Thanks for quick response. I also don’t like how the default map location is my current location. There used to be a way to navigate to my planned location. Now I’m forced to drag it 10+ mile to my planned location, since I’m always offline at my sites.

There is a search icon at the top during planning. You can always search for a location. Is that not working for you?