LAANC Authorization and Airspace (new feature)

We’ll be gradually releasing a new Airspace and LAANC authorization capability in DroneDeploy over these next few days. The benefits over existing methods are as follows:

  1. Integrated into our UI - you can check airspace and see granted authorizations inside the dronedeploy projects view, and see if your flight plan is currently valid.
  2. Automatically auditable - we record any authorization responses from Airbus UTM, so and our enterprise customers will be able to report on them.
  3. Desktop and mobile friendly - The interface is designed to work across the desktop and mobile planning UI so you can plan ahead from the comfort of your desk.

We’re rolling out slowly - so some people will see it before others. The first 10% of users will see it this week, but you may need to wait until the end of June for everyone to have access.

This project is in partnership with Airbus UTM, who are the USS on record with the FAA. The actual flight briefing data and the legal authorizations (including confirmation emails) will come from them.

To learn more about this new capability, check out our LAANC & Airspace help documentation on the subject, but feel free to post here about any issues or challenges you see with the feature.

LAANC access is free, and by the end of June we expect it will be available to all our pilots when flying in the USA. Enterprise Customers can request early access from their account manager or customer success manager.


Oh yeah. AirMap works well, but there are some features that I hope you can capture that it does not do well. the most simple of which is being able to repeat a project. I have several that I have to recreate the perimeter every time on mobile. You can duplicate them on the website, but that is not always efficient.

I’ve enabled the feature on your account @MichaelL - yes - you can re-use your perimeter every time you fly the same project. By default it makes a boundary around the outside of all the flight plan geometries in your project.

1 Like

Great, thank you. I will use it today.

Was completely unable to login this morning from IPAD. Android seemed to work though.

I get a blank screen on iOS 13.3 on an iPad Mini 5. There is not an option in the left navigation pane on My Pixel 3XL with Android 10.

It finally came through on iOS after about 5 minutes. Once you get to the page there is no place to login. Only create an account. Is this some kind of Airbus account?

I created an AirBus for DroneDeploy account and was able to see the plan for the project I was on. Unfortunately I don’t have anything to submit until probably next week because I am flying the H520.

Hi Michael - what did you mean by blank screen?

The screen was blank for close to 5 minutes while the AirBus portion loaded. May have been my connection or some other configuration problem.

Will this authorization still require the DJI unlocking schema? That is/was a real pain in the as* when DD would not recognize authorized DJI. Can’t even use DD for testing in my backyard.

@Jamespipe, AirBus failed this morning so I went back to AirMap. It did not give a reason as to why.

*Update - LAANC is down at TX-AUS and was reported by AirMap. Pretty important information I would think.

Is anyone else experiencing the LAANC system being down. I have tried two more locations (not through DD) and am getting a failure or notification that it is not available… @Jamespipe @Andrew_Fraser

AirBus a 3rd time worked on two sites. I did find out that AirMap’s headquarters in Santa Monica was burnt down during rioting… I am guessing that is the problem, but we have an office here in Austin as well with Hangar.

Hi Michael,

I checked out your account. I think there may be some conflict between the apps you have installed and the airspace request.
In particular, the Linear flight app seems to be introducing some issues for you - in the background it’s actually an area geometry - that large geometry is what we’re sending off to airbus. In addition to this, there is a delay in loading airspace as it’s being blocked by the apps making requests in the background.

I’ll take a deeper look into what’s up here, but that seems to be causing you some issues in the short term.


1 Like

I am not seeing this on my account when I login to DD and am under the Fly tab. What could be the issue?

1 Like

We’re still on the process of rolling it out. You will see it in the next two weeks!