Issues again with DroneDeploy

Having a issue with DD… I did mission today and want home and uploaded the files… the deskboard is not showing processing I contact DD and I was told I did not upload them so I try it again in safari and chrome and both are telling me the the files where upload but then as I got the desk board its not in processing status?

This happened to me last week. Uploaded the images to what was initially a ‘Live Map’ but then noticed a few moments later the map was not being processed. Did it a couple of times further but no joy.

Created a new project and uploaded the same images to that and it worked. ‘Processing’. Half an hour later however then found that both missions were being processed. Figured the original just had a delay in updating it’s status for some reason.

You might refresh the browser after uploading. That may show the shift to Processing.

This was tried by me @Gary. It was possibly an hour later it updated.

Hi @PilotSmith69,

Can you verify if you’re still experiencing this issue?


Was this solved by being patient and leaving it for an hour?

I have the same issue right now and it’s the second time it’s happened.
After using Live Map option in flight, and then uploading the proper images, the Live Map icon still shows on the dashboard for that map, it doesn’t say “Processing” and it still gives the option to upload images… Giving the impression it is not processing.

I remember when this happened originally i uploaded 2 sets of images to the same map and got no where - Not fun.

Hi @Vantage,

I’m sorry to hear you are experiencing a similar issue. Can you let me know what troubleshooting steps you’ve tried? We generally recommend the latest, stable versions of Google Chrome and Mozilla Firefox and rebooting your devices (desktop and router). Sometimes clearing the cache/cookies may help too.


In this instance I uploaded my photos and left it (even though it didn’t actually say ‘Processing’ ) and it was fine. I received an email a few hours later saying the map was complete.

It would probably be beneficial to have the ‘Live Map’ label removed and changed to ‘Processing’ upon uploading the full set of photos - It’s just peace of mind for people.


I uploaded images to a couple of maps 4 hours ago. Both currently display Live Maps but neither are showing as processing. Maybe they’re working away, maybe they’re not. Will find out in the morning.

Hi @Vantage, Hi @JamesC

Thanks for reaching back out. Usually, if the uploading images process complete before the Live Map has finished processing, the complete map will show as the Live Map. This is something that we are trying to address. In the meantime, if you are experiencing this issue we have two workarounds:

  1. Re-upload the images to a new map by using the “Upload images” button that is located in the blue + icon at the bottom of your dashboard. That way, you will have your high-resolution map in one map and the Live Map in another.

  2. You could send us the Flight ID codes (or the names of the maps in question) and we could reprocess them on our end.

I hope this information is helpful. We appreciate your patience and understanding here.

Have a wonderful day and happy mapping!


So I woke this morning to find one of the two Live Maps now Processing. Good news.

Unfortunately however, the second map still shows as ‘Live Map’ and still provides an invitation to upload the images. As with @Vantage experience, it could well be that the second is processing in the background and will know in a few hours I guess when it either remains as it looks now or if the full map appears.

Yes @Andrea, I could upload all of our images into maps manually as for me I know it works, but that’s not how the system is intended to work. Maybe I need to abandon the official system until such time that it works efficiently. The maps I produce can take over a day to produce and that’s a lot of wasted time if you think it might process but ultimately doesn’t.


So I gave it a couple of hours this morning for the second, smaller map to catch up and ‘process’ but eventually got impatient and uploaded the images again through the same Live Map. As well as that, I manually uploaded the same images into a seperate project.

Despite waking to the first map processing, I also uploaded those images again. Not sure why but thank goodness I did.

An hour later, I have the first Live Map processing, it’s manual duplicate and the second’s manual duplicate. I uploaded the second Live Map again and it started processing almost immediately.

Fast forward 8 hours. The original Live Map is still processing, 24 hours after it’s images were uploaded, the second Live Map has finally processed but only after the two manuals were completed an hour. Go figure.

This is very unlikely to a browser issue as I tried on a couple of machines in a couple of browsers. I suspect the problem is actually with DD.


Hi @JamesC,

Thanks so much for providing this information. I’m sorry to hear that the images that were uploaded to your Live Map are taking so long to process. I took a look at this set of images (1231 images with ~6 GB of data) with one of our engineers and compare them with the images that you uploaded to a new map (1020 images with ~5GB). Even though it is the same dataset of images, since the datasets are not exactly the same (one map has 200 more images than the other), we can’t really pinpoint what is causing the long processing time. However, we can stop the processing internally and restart it with different settings if you’d like us to, but please note that this does not guarantee a faster processing speed.


Thanks @Andrea.

Yes, they weren’t exactly the same but I didn’t consider those few extra images would multiply the already lengthy processing time by five. :slight_smile:

When I woke this morning, 40 hours after I set it going, the original 40m Live map had processed. Now having the four maps, I’m deperstely trying to work out why I have four very different results with four very different elevational values. The two 20m maps, Live and Manual were produced using the identical set of images taken at 20m.

The two 40m maps again used the same images taken at 40m but
with the Live map having the benefit of the additional 20m images (vertical and obliques) to help with the 3D aspect of things. I did think twice about adding the 20m verticals but figured it couldn’t hurt. Was this wrong?

Having spent a few hours today at home looking through, I honestly can’t work out what is going on. I know I could/should use GCPs for more accurate z values, but these results are plain inconsistent and completely unreliable. I uploaded approximately 100 oblique images for the 20m and 200 for the 40m map not only to help with the 3D but more so to help with the z values as previously advised (without horizon). I did consider the rising ground to the south on the result of the 40m manual map might be due to the DJI drone dropping slowly over its length run, only there were 3 battery changes required and surely that would reset the sagging effect after each change? And for the record, the site does not have a mountain running north-south through its centre as shown on the 20m Live Map.

I’ll run the process again on Monday morning when I next have access to the original images to upload but I’d appreciate a helpful explanation as to what’s going on in the meantime please.

Using a Mavic, I have to perform the manual focus trick in Go4 before switching to DD after each battery change. When I did this, I flew up to 40m, manually focused vertically and whilst still in the air switched to DD. In the past, the take off spot in Go4 has always been ‘zero’, yet the z value of the take off pad in the processed maps are -69m in one map and approximately -40m in two of the other maps. Is this coincidence or did zero start at ‘start mission height’ in the air on those two maps. DD has always previously realised I started up in the air and the ground pad I took off from has always been zero.

I have since calibrated the same spot on each of the four maps to ‘zero’ because the z-value of the same take off pad was wildly different on each of the maps.

Honestly, just when I thought I had learnt to tame the beast and understood how it worked it threw me this curve ball. @Andrea, please can you get one of your engineers to take a look at it and if necessary start a new thread for this rather than me hijacking this one?

Ta, J.

20m Live Map below:-


20m Manual map: below-


40m Live Map below:-


40m Manual map below:-


Can you clarify what you mean by “elevation values”? If you are talking about the Elevation Map view coloring there are several reasons, but if you are talking about absolute elevation values at specific spots across the 2 maps that is something entirely different. The 20m maps aren’t even the same area so the elevation ranges are going to be different and the fact that you inserted obliques into one of the 40m maps voids any reasoning of how those two can relate to each other.

GPS accuracy no better than 1m and .4m rounding on where you anticipated you were starting from is allot of room for error. Switching between the two programs is something else.

I am going to run the exact same set of images 3 times and will report my findings.

@MichaelL, I think you’ve misunderstood.

The colours are arbitrary as you say. I’m talking about the the actual z values given by DD having placed a marker down, although as I said before, it should be relatively obvious that the z-values of the fictional mountain range displayed in the 20m Live Map are going to be several metres from where they need to be and indeed they are. And why half f a 2-storey house with a perfectly horizontal ridge is 5m higher on the right half than the left half is a mystery. Believe me, the z values on the map are 10m in places from where they should be. The difference between the two 40m maps is something like 5m different.

The 20m maps are indeed the same area. The two 20m maps used identical images. Absolutely identical. The Live Map has the automatically squared off edges and the rounded off edges is the manual. They are the same images. The same map.

The 40m maps simply cover a wider area but do also cover the same 20m plot within it. You will note I have placed markers down to highlight this.

All maps include oblique images although the 40m ‘live’ also contains all images taken during the 20m flight, not just the oblique ones but the vertical ones too.

I hope this clarifies things.

Yes, that does make sense now and the mountain map is obviously a glitch. Can you share the maps? Also, if you want, message me your email and I will send you a Sharefile request to upload your photos to our site and I will see how they process on our account.
My test batch completed and while there are differences between the three maps they are negligible.