IPad connectivity issues

Hi All, hoping someone can help me.

I’ve just purchased an Ipad 9.7 128GB tablet from Apple. I have set this up as a brand new machine.

I have loaded DJI GO onto it - however when I connect the cable to it and power on the RC and then the drone, the DJI GO app doesnt acknowledge that there is a connection. I can hear a DING when I plug the cable from the RC into the tablet, and there is a charging symbol which suggests connectivity but it simply wont recognise the bird.

I then loaded up DD and Litchi - and same result.

Does apple block external devices in some way ? Much like the “Trust / Dont Trust” your computer setting and if so how do I bypass it ? Or is it something simpler than that ?

Thanks
Sean

Hi @syamaphantom,

Have you tried using a different cable? This might help. At the very least, it’ll let me narrow down the possible cause of issue.

Cheers,
Christina

Yep, it made no difference :frowning:

Some feedback - it looks like the upgrade to iOS 11.0.3 is the root cause for this issue. DJI report that it affects a SMALL number of people. I’m on of them it seems.

Hi @syamaphantom,

I’m sorry to hear that you’re one of the few who are affected by this issue - what a pain! Although, I’m glad that it’s been addressed as a known issue. Hopefully an update will roll out soon to resolve this.

Cheers,
Christina

Word of advice… NEVER update any software including DD, Apple, Android etc until at least a month after it has been released! I have been having problems with DD since about March! Still can’t get an answer as to what the problem is but yet my payment gets taken every month without hesitation!

Hi @HawkEye_Imaging,

I’m sorry to hear you’re still having issues. Do you mind sharing specific details about your issue?

Keep me posted,
Christina

Hi @HawkEye_Imaging i took a look back at your old posts and I believe that the majority of your reported issues have been resolved in DroneDeploy. Please share any issues you face with the latest version as Christina mentioned.

Hi, I want to ask if the current iPad models has such connectivity problem? Cause my iPad Pro can’t work well too.

Here is the list of currently supported devices.

Could you please be a little more descriptive of your issue?

There are several users are facing these kinds of issues as they may not handle the iPad in an appropriate manner. They can take any advice suggested by error connecting to apple id server that will be beneficial for them to overcome their issues.