iOS App Version 4.7 Reports

I’ve flown several missions with 4.7 using a 1gen Phantom 4 Pro and 6gen iPad. I have not had any of the issues described so far, but I did have occasional initialization fails in the previous version. So far, biggest disappointment is offline mode no longer works. What I mean is, I used to be able to sync at the office and then take the device to the field and fly without a data connection. If I take the tablet to the field now and open DD, all of my synced projects and flights are missing as it tries to connect to the servers. If I’m lucky enough to have cell signal in my location, this is frustrating, but if I have no signal, this is project ending because after it cannot connect I have no projects. I work in remote areas almost exclusively, so it is critical to me that DD can operate without a data connection. I’ve looked through all the app and device settings for cache limits or something of that sort, but there’s nothing like that. Does anyone know a fix?

So its it still happening in 4.7?

I’m assuming that you are connected to WiFi in the office when it syncs?

I cannot confirm the initialization fail is happening in 4.7 with my setup. It was happening to me in 4.5, but in the current version I have flown 16 multi battery missions without that incident.

Connected to WiFi in the office, yes. Also when I sync again in the field via cell tower the same loss is experienced after moving to new site and the app auto refreshes due to inactivity I presume. It feels like a full re-sync each time because of how long it takes to download all the flight plans.

1 Like

I have flown around 20 projects with 4.7 and only had the initialzation completely fail once. I thought it might be related to connectivity, but if you often don’t have any and are not experiencing it then I guess not. At the beginning it was taking 5 seconds now it takes 15. I also wonder if it is the uploading of waypoints and may correspond to the size of the project. That one time it did fail is was a 120ac subdivision.

I totally agree on the dashboard refreshes. The new UI as a whole uses more resources and even though I have 4G LTE on my iPad if the signal is not excellent then neither is the refresh.

Correct I often don’t have any connectivity at the launch point. I think you are right that the initialization time corresponds to the size of the mission. Short flights always spool up quicker.

I’ve also seen elsewhere comments about longer flight plans appearing to be truncated on the initial launch and reappear after flying part and swapping batteries. This has always been my experience ever since the “initializing” feature was added. I always figured that was just representing the limit of how much data was sent to the drone. It was always more than enough flight plan for any one battery. In my opinion, if my interpretations are correct, that is a good safety and efficiency feature that allows the drone to operate autonomously even if signal is lost, which happens to me occasionally in forested hill country.

1 Like

Yep, this is what I reported on the first 4.7 mission. We still haven’t gotten verification of what all is exactly going on during this period @Jamespipe @Andrew_Fraser , but I too think they are related, due to additional instructions be communicated and the additional telemetry that is being reported. It always had the capability to complete a mission regardless of radio in the past, but I think it was less data and basically just the waypoints. Now we have precise point return, queued plans, a full screen FPV and additional telemetry. I know there are a few more things, but it starts adding up quickly on what the devices are expected to do.

Same issue with me, sync in remote locations doesn’t happen or the app just spins. This is a major problem.

On multi battery flights I’ve had issues with the resume mission. All looks good just the bird doesn’t take off. Had to go to DJI and recalibrate compass. Not sure that was the problem but it required me to restart DD and reload the mission.

Same initialization issue?

Seems to be. I’ll do more research to be sure.

You will see those words at the bottom of the screen as soon as you tap the arrow. If so can you please note the amount of time it takes with different size projects?

Hi Nate, because this thread seems to reference two issues, I need to clarify the above point as this appears to be extremely frustrating: does the following correctly describe the symptoms you are experiencing?

  1. Plan a flight in good signal /wifi in a project on your iPad / iPhone.
  2. Travel to an area of low signal strength
  3. Open the app
  4. In these situations, the app will seem to reset your projects and have to reload them over cell. If the cell service is slow - this can take an extremely long time, or never complete.
1 Like

…and I think maybe non-existent and it does not happen at all. Is there supposed to be caching to the device going on?

1 Like

Yes, exactly! Thank you

Thanks for the confirmation Nate. I will take this back to our team.

1 Like

Ok we have dug in and found the root causes of the behaviour. Unfortunately it’s not a quick fix, but I will keep the community updated with progress.

1 Like

When i restart a mission after a battery change the Altitude, Distance, HS VS and G all read 0. Unless i restart the app during flight

This happens consistently

1 Like

I am not sure if my issues are related to everyone else’s or not. I just attempted my first flight after completing the trial version. With a client standing next to me ready to view a grain elevator I could not get off the ground. Everything checked out in DJI Go, all checks passed in DD, but once sending the Mavic 2 Pro up I got a message about a bad connection and it would not take off. Running new generation Ipad 10.2 and Mavic 2 Pro. All are new within last two months. The area was fairly remote however I still got cell signal to run off of my cell phone hotspot. Also looking at Version on the Ipad apparently I am running Version 4.8.

1 Like

I too was having problems with mission resume. I seemed to have solved it by waiting a while longer before hitting the resume button.

1 Like

Another thing that I wait for is the GPS (satellite acquisition). Once everything is recognized I give it another 15 seconds or so before I resume. It used to fail completely if you jumped back in too quick, but now it seems to be pushing through even if it hadn’t completed the GPS lock by the time I had tried to go.

1 Like