iOS App Version 4.7 Reports

Seems to be. I’ll do more research to be sure.

You will see those words at the bottom of the screen as soon as you tap the arrow. If so can you please note the amount of time it takes with different size projects?

Hi Nate, because this thread seems to reference two issues, I need to clarify the above point as this appears to be extremely frustrating: does the following correctly describe the symptoms you are experiencing?

  1. Plan a flight in good signal /wifi in a project on your iPad / iPhone.
  2. Travel to an area of low signal strength
  3. Open the app
  4. In these situations, the app will seem to reset your projects and have to reload them over cell. If the cell service is slow - this can take an extremely long time, or never complete.
1 Like

…and I think maybe non-existent and it does not happen at all. Is there supposed to be caching to the device going on?

1 Like

Yes, exactly! Thank you

Thanks for the confirmation Nate. I will take this back to our team.

1 Like

Ok we have dug in and found the root causes of the behaviour. Unfortunately it’s not a quick fix, but I will keep the community updated with progress.

1 Like

When i restart a mission after a battery change the Altitude, Distance, HS VS and G all read 0. Unless i restart the app during flight

This happens consistently

1 Like

I am not sure if my issues are related to everyone else’s or not. I just attempted my first flight after completing the trial version. With a client standing next to me ready to view a grain elevator I could not get off the ground. Everything checked out in DJI Go, all checks passed in DD, but once sending the Mavic 2 Pro up I got a message about a bad connection and it would not take off. Running new generation Ipad 10.2 and Mavic 2 Pro. All are new within last two months. The area was fairly remote however I still got cell signal to run off of my cell phone hotspot. Also looking at Version on the Ipad apparently I am running Version 4.8.

1 Like

I too was having problems with mission resume. I seemed to have solved it by waiting a while longer before hitting the resume button.

1 Like

Another thing that I wait for is the GPS (satellite acquisition). Once everything is recognized I give it another 15 seconds or so before I resume. It used to fail completely if you jumped back in too quick, but now it seems to be pushing through even if it hadn’t completed the GPS lock by the time I had tried to go.

1 Like

Hi everybody. I had some very annoying problems with DD, and that in presence of the clients. These problems apeared 2 weeks ago. Fore more than a year everything worked perfect with DD.

Problem 1: The flightplan doesn´t load when I am in the field. The display keeps froozen.

Problem 2: During the flight the dron permanently disconnects. But it keeps flying and saving all the pictures. But it is very uncomfortable to fly like this.

I don´t have any problem with DJI go 4.
I am using an I phone 6 and 8. Both with the same problem.

What could be the reason?

  • Perhaps the old system. My phones work with iOS 12.47?
  • The fact that I use the free version of drondeploy?

I need some advice, because if I continue like this, I will loose my clients.

Thanks a lot.


1 Like

Hey Holger, a few things.

There is only one flight app, the free one. There are different tiers of processing and various back office options.

The new version of the app has been having various high processor use problems which have begun to see some resolution based upon feedback in the forum.

But there are reported bugs with live feed disconnect and flight plan loading in the field. It seems to be that the app is querying DD’s servers, or trying to, in the field. The app is still supposed to work without a data connection. But there is definitely something going on that wasn’t in v. 3

DD is focused on pushing the app beyond just flight control. They will beta test with the user base and then work on solutions. If you want to continue using the DD app you best be prepared to use the newest, fastest devices, and put up with some blips when they write-in new “improvements”. I personally think if they should keep a light, bulletproof flight app and develope another “Drone Deploy Cloud interface” app if that’s what they want. But I don’t get a vote !

I would suggest that you look into a couple of the other flight apps to fill out your tool kit. It’s a good idea even when things are working well because the next update, it may not. That kind of goes for all of the apps, but it is certainly true of DD Flight.

I would suggest Map Pilot (Paid) and Pix4d Capture (Free)


Hi Dave. Thank you very much for your answer. Now I have a clearer idea of the reasons of the issues.

Now the question is, what can I do?

  • Waiting for the next DD update, and hoping that it works better.
  • Buy a faster device. Could you recommend one? But I read that even with new devices it´s not guaranteed, that flight plans load.
  • Use another flight app. I took a look on Pix4 d capture but the base map has a bad resolution.
  • Download a former version of DD. I don´t know if it´s posible.

What are your suggestions?

I thank you in advance


None of us have a crystal ball, so the next update is anyone’s guess.

I think any of the current apple smart devices or newer android devices should be powerful enough. But I’m not willing to say that would solve all the problems, unfortunately. @MichaelL may have more detailed experience with newer apple devices on v.4

I use Map Pilot Business and sometimes v3 of Drone Deploy. I know some folks use DJI GS Pro too. I have never used it so I don’t have an opinion or comment.

You may be able to find a v.3 apk on the android side. But, getting an older version of an ios app is not really worth the trouble, if even possible.

I’m sorry, that’s all I can tell you. It is what it is and we deal with it the best we can for our given situation. :neutral_face:

I just wanted to add that my main device is a ipad 9.7 6 gen and it works flawless with either MP or DD (v3). In addition, I have not had any issues on my backup ipad air2 on either. Both are also still on ios 12.x

that’s the answer. not sure how the latest ios update works on ipad, but it totally wrecked up my iphone…

1 Like

That is also what we found and DroneDeploy concluded. It seems that iOS 13 supposedly changed some multi-tasking protocol, but also network recognition tasks. Some seem to think that this is causing more apps to continue running in the background than before and the network recognition is basically causing the device to constantly search for WiFi and Bluetooth signals. I always turn off my WiFi when flying and very rarely have a need for Bluetooth unless I want to use it for a meeting or am trying to transfer some files. The are quite a few reports of devices starting to overheat after the update, but I would expect that something like that would have gotten fixed after 5 maintenance updates. All I can say from experience is that leaving off WiFi and Bluetooth and getting a cooling cases for the iPad Mini 5 has greatly decreased the number of problems I was having.

1 Like

Current version on ios is 4.9.0 If any problems carry over, pleas start a new thread.

1 Like