iOS App Version 4.6 Bugs

I am using a DJI Phantom 3 Advanced. It has worked just fine with DD for two years. Now, every time it checks all pre-flight checklist items, I click the green button for take off, then I get the message “Drone is initializing…”. The drone doesn’t ever take off or start the mission. As I said in the topic subject, DD Version 4.6.0, iOS 13.4.1. Please don’t suggest updating iOS as I have already tried that. Yes, there is a new iOS available for download and I’m updating now but it will not change anything. This issue with DD has been the case for two iOS versions in a row. Please help.

I am interested in what is actually happening while it is “initializing”… I experience it consistently for about 5 seconds and have never had a failure to take-off, but it seems like the pre-flight checks that have always been in place have worked fine. I do suspect it might have something to do with your older drone. @Jamespipe @Andrew_Fraser

@MichaelL The only reason I would disagree is that I have been using the P3 Advanced with this software for around 2 years. I guess they could be phasing out old hardware such as the P3, but I can get the P3 to successfully take off/fly a mission on a previous version of DD on an Android Tablet. That being said, it just isn’t consistent and I run into other issues on that version and that tablet. I should also specify that I am trying to use an iPhone 7, which is specifically listed under DD’s supported devices.

Exactly my point. This is an eventuality.

I’m having the same ‘initialization’ issue with version 4.6.0 as Wilson. I’m flying the Phantom 4 Pro with an iPad (Model Mp2F2LL/A), iOS version 13.5.1. I had the same issue with version 4.5.0 and 4.5.1.

Flight plan is loading, the flight checklist runs, you click the ‘Start flight’ button, the message appears saying ‘drone is initializing’ and nothing happens. I’ve turned off the drone, controller, and restarted the app multiple times but the drone will not start.

I flew two missions on 3 June without an issue (not sure which version of the app) but I’m back at the same point with the drone not starting as I had with version 4.5.0.

Here are the flight records:

Here is a link to the mission where the drone will not start:

Looking for a solution…

Just a thought, but are you initiating the mission having already taken off in Go4 or from scratch on the ground?

Fortunately I’ve not yet updated beyond V4.4.2, but I have noticed a few heart-stopping seconds whilst it ‘initialises’. I always take off in Go4 however.

I initially start the Go4 app to adjust the camera settings, close out of the Go4 and then open DD app.

Might not help at all, but try taking off before closing out of Go4.

@Jamespipe @Andrew_Fraser, can you tell us exactly what is happening during initializing? Something different than what was happening before?

They are rolling out their LAANC integration. I wonder if that has anything to do with it?

For those having initializing issues, are you off-line or connected to data? For LAANC, obviously you need to be online. I wonder if the app is waiting for a connection? I hope not. That would be another nail in the coffin.

1 Like

I do sign in to the DD app using the hot spot on my phone, so I’d say that I’m connected to data but I applied for an authorization using AirMap on my phone, not the iPad that was running DD.

No nothing different than the flight plan loads, you click ‘start’ button, the checklist completes, and the small window in the lower left part of the screen shows the camera view, and then after clicking the ‘fly’ button, the advisory shows drone is initializing but it never starts.

I did just discover something I find unique. The version of the DD app on the iPad is 4.6.0.
I flew two successful missions on 3 June and the flight log shows the version of DD to be 4.5.0.
I tried to fly a mission today that failed and the flight log shows the version of DD to be 4.4.2.

How can there be a difference in the version of the app in the flight log than what I have loaded on my device? Makes no sense…

Hit the pause button on the controller when this happens and see if it starts the mission. I have found that if I am taking off near an object with obstacle avoidance on it will go up to about 5 feet and just sit there. As soon as I hit the “Pause” button on the transmitter (next to the camera button) the drone will resume. Don’t know if this will work in your case but worth a try.

1 Like

Good morning from Texas! I changed the title of this thread to encompass other issues occurring with this latest version.

I experienced 3 crashes of the app yesterday while just browsing projects. Different than my other post about the black screen and possible iPad overheating these crashes occurred while I was in my truck in the air conditioning.

@Jamespipe @Andrew_Fraser

I just updated to 4.7 and will create a new thread if needed or if someone else needs to please do so.

I’m too afraid to move off 4.4!

1 Like

This issue has carried over to 4.7 as well. Happens to me with battery change. 1st mission flys fine, change battery and it just sits there after preflight completes and flight started.