iOS App Version 4.13.0

It doesn’t appear anyone mentioned this in this thread…Drone Deploy iOs ver 4.13 came out late last week…at least after the 9th of August…

This solved nonfunctioning MultiBattery flight plans in a DJI Blue Authorization Zone.

I did however see the black screen…and the toggle worked to bring back proper view. Thursday I flew 180 acre and 100 acre maps in DJI Warning Zone with no issue on 4.12…Went back into a DJI Blue Authorization Zone and the MultiBattery did no work…Then found that there’s yet another update…and that solved my MultiBattery issues.
Aerial Traffic
Randy Wynant

1 Like

Thanks for this. I split your post off to start the new thread.

My v4.13.0 experience has been good so far. Many flights next week so I will report back. I still need to hear why the DroneDeploy app behaves differently in the App Store…

That’s good stuff right there!

I have a Job near March ARB in SoCal coming up after the GPS Interference testing is done on the 23rd…and it’s 2 multibattery DD flight plans flying in and out of DJI Blue Authorization Zone…About 200 acres total…I didn’t want to ask the client to split into single battery missions, as they insist on using their maps. I’m here to help!!



Two of three flights went perfect today and guess what the third flight was in an area with virtually no cell coverage… I tried the tablet only, tablet with phone and phone only. I kept getting prompted with a message stating slow connection. I went back to tablet only and albeit slow it worked. It took about a minute and a half for the back ground map tiles to finally resolve. Trick you can use if they are not resolving is to zoom far out and the program will start loading the lesser resolution large tiles then slowly zoom in and it will start loading higher-resolution smaller tiles of the immediate vicinity. All in all I’m happy with the direction that we are going, but there is obviously still some work to be done on connectivity.

1 Like

You haven’t convinced me to move from V4.4 yet. :wink:

Flew v4.13 today and everything went well except for the continued flight plan blackout post battery swap. Toggling to FPV and back still fixed it. I did notice that a problem I was having with the flight timer did not happen this time. Previously it showed a seemingly random number on the left side that was usually higher than the calculated number on the right. The actual number never changed during the flight. Today it counted correctly.

I’ve started mapping again to check for…standing corn… as well as debris that we will need to watch for come harvest. This versions seems about the same for me as 4.12 did. I can’t for the life of me get the app to behave when it has internet connection, about 10 sec after loading it basically freezes until I turn off wifi and restart app. This also means I still need to manually upload then edit the boundaries every time. I am making it work, but my fear is at some point I will need to reload a mission and will have trouble with it freezing again. I find it very strange that some people have poor experience with no connection, while it grinds to a complete halt if I do have one.

Are you settings maps to offline?

Flew my monthly zones consisting 1500 acres over the weekend (large solar farm installation) and the app and drone performed very well for the most part. Except. On several, if not most, occasions, after each successful mission (2-3 battery swaps), DD wanted to continue the mission. Very annoying. I had to reset the mission just to get back to a place where I could select the next flight plan. Sometimes I needed to shut down the app and restart as it was stuck in the “continue mission” mode.

Latest DJI firmware, iOS, iPad mini 5.


What was your finishing protocol after the last picture?

The usual (auto). It finishes the mapping. Comes home, lands. App asks to upload photos or do it later (I choose later). I turn off the drone battery. I close the app, I turn off controller. I move to the next flight zone to beginning another mission. Turn on drone battery, turn on controller (or vice versa), open DD app and navigate to project. This is when it asks me to continue (previous) mission. This hasn’t happened before this version of the app.

1 Like

The last time I did a map, I believe was actually end of January beginning of February, on a large construction site that required 2 batteries. When it got to the point in the map when I was down to about 30% battery it stopped mapping and came home for the battery swap. After swapping the battery, and going through the checklist I hit go for the flight and it said it was restarting the mission…not resuming!! I immediately canceled and reset everything and kept getting the same thing…Restarting Mission! So I decided to just let it do its thing. It then actually went to the point of the map where it left off with the first battery and started from there instead of the first waypoint and starting over. It finished the rest of the map as normal and returned home but then it said something about the mission not completing successfully! Don’t know why it did that but I was able to get all the pics that was needed for a successful map! Haven’t had to do a map since so I’m not sure if it’s going to work correctly or not with the newest software versions!

I have had no issues with multi-battery missions since v4.8.