iOS App Version 4.12.0

I was able to test fly a couple farms a few minutes ago using an iPad Pro 9.7 and an iPad Pro 2017. In offline mode (wifi turned on, but not connected) the ui of the app was snappy and lag free. The drones were able to lift off in a matter of seconds (as opposed to not sure if the battery would run out before I could get the dang thing in the air). Everything seemed to work fine and landed just fine with me taking control to land them in the bed of my truck, something that has been kind of dicey in the last few versions. It seems that whatever was taking so many cpu cycles and practically overheating the ipads and causing things to error out has been resolved…

I ran home to grab some more batteries and upload my images. My issue now is that when connected to wifi I am experiencing some of the same slowdowns as before, and am having trouble getting the ipads to sync back up and register the new flights with the website. The ui of the app is totally unresponsive. I have the ipads plugged in and screen at minimum brightness, they are getting quite warm again and not gaining any charge.

Thank you so much for your hard work getting offline seemingly working again and I look forward to getting things back to normal. Perhaps there is still something fishy going on while trying to access the main servers that is forcing the ipad to crunch the cpu and not allowing the sync to happen properly?


I just finished two projects with v4.12 and will say that it is so much better!

I had the opposite experience as @Aaron_S as far as cellular vs wifi is concerned. My app was sluggish with cellular only, but it was a little better than before. Especially due to the speedy preflight check and lack of errors. I had to hotspot for my phone to get really good performance. Mapping, the new UI, manual flight with videos and panoramas are switched over as expected.

One other problem that I did noticed that has existed since v4.5 is that when continuing a multi-battery flight the map screen was black. I was able to get it back by toggling to the camera view and back.

Thanks for your hard work!


Third and fourth flights on this version and today has not been good. Once again I have had to use Wi-Fi from my phone in order to get anything to happen in a timely manner. I even tried turning off the cellular on the tablet and running wifi-only. I have restarted at least 6 times between the three flights that I am doing and two of them completely failed the PreFlight checklist but I was able to skip through it and fly normally. One of the flights had a camera failure and did not give me the option to continue.

Black screen after a multi battery swap still existand the icon on the interface is lagging again anywhere from five to 10 seconds. It actually just shot 6 pictures before the icon ever moved.

I would switch to pix4d, but these are fairly complicated shaped sites with one of them being linear and I do not have time to replan. I will definitely run the next flight today on Pix4D.

Have you tried disabling/yanking out the sim card and having no wifi before you even load the app? It might help. From what I’ve experienced the app works well until its had a taste for data, then its bogged down. Maybe give it a shot. Either way it has been a super frustrating summer (for a whole host of reasons). Today I was out flying corn and soybeans trying to play catch up getting data to try and help diagnose issues with planting/growing anomalies out in the fields when a storm rolled up here in Iowa. We got what some reported as 100+ mph wind (lost power and my weather station went down so can’t verify), everything is a hot mess that I document, so in reality I’m probably done for the rest of the season.


I thought about giving this a try, but didn’t want to do it yesterday because I did not have any of the plans offline, but should have done it anyway because I ended up flying the last project with Pix4D. I’m going to try the app with the different methods again today, but already have my flight plans copied in Pix4D so fingers crossed.

Flat-lander, I feel for you man. We get similar when we get on the east side of our area. It goes from hill country to farm land and boy does it get windy out there! Good luck!

That’s what I suggested in another thread but no one tested it. Put the device in Airplane mode, all radios off. Then connect the drone and fire up the app. Maybe it will see no chance for data and move on. If radios are active, it keeps trying.

James P could tell us if there is a loop active looking for a connection if he wanted to. If there is, they could put in a switch to turn it off. Again, if they wanted to.

I might need to retract my previous report. Something strange happened yesterday as I was getting my iPad ready for today. I was under the impression that updating last week was complete, but I don’t think it actually updated to 4.12. You can normally tell because it asks you to login upon the next use and it didn’t do that until last night.

That said I did the first mission with Pix4D because it was a big job that I could not afford to have any issues. It went so well that I hit the next site early and gave DroneDeploy a shot. It worked flawlessly as one of my last reports on v4.11 so it is strange whatever happened in between.

I must have missed that post. Airplane mode was a no-go, but that is different than just turning of cellular.

v. 3 looks for data too, but it doesn’t degrade performance when a connection is not found. In v. 4 it certainly seems to.

I think we were more speaking of the SIM and the cellular data. Pulling a SIM, “turning off” cellular and airplane mode all appear to do the same thing except for how the app sees the connection and the state of the power. It seems like the same outcome, but it’s not and each device will treat the condition differently.

Either cellular or wifi, if the app thinks it has a chance to call home, it seems to keep trying. How does the app perform if it sees no chance, i.e. radios are not available. How the radios achieve “not available” is probably less important.

We had obviously already tried both on and no WiFi as that is what I had been running for the last 2 years which is why we were on the cell side, but I think the app is looking regardless of connection states and obviously cares nothing about metrics. I don’t think Apple’s metric for which connection takes precedence is even clear. You would think it would be WiFi if on, but we have tested several apps that had functionality fail if WiFi is on and Cell is off. They worked better if cell was on even if it had 0-1 bars. That said, the power state does have something to do with the metrics so if the software and hardware are correctly configured then an off state is different than a disabled state.

A post was split to a new topic: iOS App Version 4.13.0