iOS App Version 4.11.0

Flew over 1,500 acres the past two days using DD ver. 4.11.0. Mainly mapping (NADIR), which went mostly well. On a few occasions where I had a lack of cell coverage, the app took forever to start up and I tried restarting several times before it kicked in. Once upon take off it just hovered at 4 feet AGL, but restarted mission and it took off normally.

All in all a good experience, 21 TO/L, and keeping my missions simple since it is a lot of ground to cover.

iPad Mini 5.

Thank you for the update! I had to manually search for DroneDeploy in the app store for it to recognize there was an update so thanks for the trigger. I hope v4.11 solves some of the major issues users have been experiencing.

If DD added a switch “Is data available” and you select “no” and then the app skips all it’s attempts to phone home, probably a lot of this could be sorted. Rather than an ugly switch, the devs want a cool under the hood solution. That’s great, except it’s not working like envisioned I suspect.

Something maybe one of you could try. Actually turn off wifi on the tablet before starting DD. If the wifi radio is on, the app tries to connect. If the connection is iffy, then it probably gets worse as it keeps trying. If the radio is off, maybe is will check that and move on more quickly. Maybe it will make no difference but it’s easy to try.

That use to be my default and has become much worse. The best performance I have been able to acheive as of late is to have WiFi on and connected to my phone hotspot. I have not tried turning off cellular…

During hot weather I had turned WiFi and Bluetooth off thinking it would help with the iPad overheating. And it may have. Tuning WiFi back on seems to improve connectivity with the DD app, or perhaps just a coincidence?

I usually have to update DD manually.


I am moving my testing to 4.12.0.

If you are on ios DD v. 4.11, it is suggested to move on to 4.12.