iOS App v4.38 Freezing

Sounds good. Let me know and I’ll make sure to stay north.

Hi @anejojoe - A couple (hopefully) helpful clarifications.

  1. Disabling obstacle avoidance is meant to help with the DJI drone thinking that the sun is an obstacle and accidentally pausing during the mission. Usually this is not necessary, and would be a different issue to seeing incorrect telemetry.

  2. If the app is locking and the telemetry is delayed, the likely cause is that the iOS device’s processor is not keeping up. Killing unused apps, clearing more storage capacity, or rebooting the device can help a slower device perform better, but are not required for use of DroneDeploy. You’ll also want to ensure you are running the latest versions of iOS and DroneDeploy as we have made key performance improvements over the last year.

Thank you for being part of the DroneDeploy community and if you didn’t get the answers you needed from our support team feel free to reach back out and I’m certain someone would be happy to help.


I can understand the the obstacle avoidance solution, really not big a deal for me as I fly above 200ft away…unless I hit a bird then oh well.
The 8th gen iPad I use is running latest iOS 14.42 with a 112 GB of free space DD app is 4.42, I had a ticket open for this issue where the resolution for the app freezing is to reboot the iPad prior to every flight. Nothing else runs on this while I’m flying a mission, it’s dedicated just for this.
I’ll reboot it for now since that seemed to work for the last flight, no battery change required, but if it continues going forward I will re-open the ticket, in general I don’t find rebooting an acceptable resolution but that might be just me, I worked in the computer industry for 25 year doing pretty much everything. If I tell a customer reboot you computer every time prior to running our software they’d laugh me out the door…just my perspective
I do appreciate the response.

1 Like

The issue is the app. DroneDeploy needs to stop making excuses and pay someone to fix it. We have all had these issues. The app is down right dangerous. No one is taking responsibility. Its sad that I was afraid to speak up about all these issues with fear that I would get blacklisted from DroneDeploy paid missions but it is just so unsafe and I’ve been offering feedback for a while now with no solutions.
I have been calling and emailing after almost every flight. Documenting issues because the app cleverly doesn’t record logs when the mission turns erroneous. Over a year for an android update that is not safe to use is insulting. And now the iOS has similar issues.
Ive called Kaitlin. I’ve called Ian. What does it take to speak to an app engineer? The app should be taken down from Google play.


Keep at it! Issues need to become a priority over new features.

1 Like

The sun issue is frustrating but I’ve started to plan my battery swap RTH so that when the aircraft goes full speed to resume mission, its not facing the sun, because it just goes 30 to 0 to 30 to 0 and it doesnt look professional.
Funny, itll fly 30mph to the resume point, and then go sub 6mph for 4 minutes to move to the next photo location. Thought they promised to fix that?

When you say resume point and next photo location is this during mapping or another flight mode? There use to be an unnecessary slowdown between home to waypoint positions but that has been gone for a while.

We never run OA so now I am glad we don’t!

I think i uploaded an image.
So a Crosshatch flight but this also happens with lawn mower non perpendicular plans.
In a rectangular building, bottom right was starting point for horizontal lines, ending top left. Well, in this plan, vertical lines start at top right, so with DD logic, the horizontal ends top left and returns to first point, diagonally across the entire building and slowly. Then moves straight up to top right, again slowly, and then starts the vertical line photo capture, going over the vertical travel line it just took without capture. Very battery consuming.
I make an effort to avoid any non perpendicular lines because even though it was promised a while back that these non capture travel lines would start to fly faster, they still always fly very slowly.
The worst is if you rth for battery swap just as it finishes the horizontal, so it takes off fresh battery, goes to last point which would be top left in this example, and then slowly drains battery until it gets to top right to start photo capture at like 80%

Sorry if that was hard to follow but if you look at any rectangular building from above, it will make perfect sense.

It’s because it’s still in mission flight and not traversing. I would suggest playing with altitudes, overlaps and directions by percentages to dial that in. Usually direction does it but sometimes we have too adjust the overlap by a percent or to in order to get the flight lines exactly where we want them. If you rotate the path pay attention to the time estimate and you will see it drop at some point. Then just tidy it up.

That doesn’t help to slow travel for the second half of a crosshatch though. It doesn’t show you the transition flight path which is interesting. Its very difficult to coordinate the lines to not hit a vertical flag pole on a 75/75 Crosshatch roof and then surprise line shows up mid mission.
We should be able to add a avoid waypoint or a single waypoint with altitude.

So the second half of your crosshatch run is slower than the first?

Transition flight path? The line of travel from ending the first direction to start to 90deg offset?

I hope you’re running RTK… I would never let my pilots get that close to something on purpose in an autonomous mission.

Yeah this has been on the request board for a while. Not just a point but an exclusion zone that is reactive to whatever kind or configuration of flight plan you put down. Sort of a per project no-fly zone.

Flew an mission today that required a battery change. Seemed like it was gonna go ok after the battery change right up until the DD App restarted after take off a couple of points into the resumed flight. Brought the drone back to home point rebooted the App again then was able to finish the flight.
This needs to be fixed

So the app crashed to the home screen with no notification? Then restarted itself?

Yes, after I changed the battery, on it’s way back out to continue the flight the app just restarted. I didn’t want to take any chances so I brought it back to the home point then restarted the mission from that last point.

Smart man! I have NEVER seen an iOS app restart itself. Usually they just crash.

Unless it happened so fast I didn’t see it…it just restarted. My new plan is to restart the app every time I have to do a battery change. Turning off OA seems to have fixed the getting stuck at some points in the flight. My backup plan is to use the Measure Ground Control app for flight planning.

1 Like

Flew again today with a battery change. This time I restarted the app after changing the battery but before continuing the flight, got the flight in the air and the app restarted again…this is getting old. I opened another ticket.

That just doesn’t make any sense to me. I would really hope to get other people responding with the same thing happening because I have never seen anything like it before. Have you tried a factory restore of the iPad through iTunes? Not the settings menu… I’m just reaching but there is definitely something up with the install.

No I haven’t. Personally I think they have a memory leak in their app.

If it were a true memory leak with the app there would be a ton of people affected by it. Memory leaks are more common on Android devices but I have seen it on iOS with brand new apps we were trying to get developed. It should be pretty easy for them to test but without the specific environment in hand I don’t know how they could reliably reproduce it. Does the interface get super slow for a period of time and then crash or does it just do it all of the sudden?