IOS 3.2.1 on iPad Air2... Misleading notifications

Have you experienced the same thing from manual RTH?

Not for me and I always Manual RTH, sometimes 3 or 4 times for battery changes between waypoints. I only get the message when switching to sport mode.

1 Like

Hi guys! I just wanted to reach out to let you know the flight engineering team is on this and investigating. Thanks for the reports.

Great news! This issue was already identified by one of our test engineers, but your outreach has helped us to prioritize it. The messaging improvement is being slotted for a fix in the near future. The functionality has been stable, but we will remove this bad notification. Ya’ll rock!


Thanks Adam, @Dave @SergeKouper @JamesC.

^ What he said. :). Thank you.

Thanks for following through with this, Adam. Group fist bump!

Since this is still an issue, even in a slightly different format and this is the first major post associated I am bringing DroneDeploy back in. @Adam_Carp @Erika_Houseman @Kaitlin @Lindsey_Huffman

We are still getting odd pilot required/GPS lost messages when getting out of P-mode. Similar is now also occurring when pausing missions on the new interface. It needs to be restated or portrayed in a less threatening more relevant way if it is to stay. It could conflict with actual GPS-loss notifications that should be present.



It is obvious the engineer took a shortcut and is triggering what they think is an appropriate generic warning when control is taken away from the app. When in fact it is an inappropriate warning for the circumstance which could lead to unnecessary evasive maneuvers.
Little engineering bugs happen and that’s to be expected. However, it is really not acceptable for bugs that would probably take an hour to be fixed languishing for months and months. This just sends the message of uncaring. (My opionion)
For example, I know for certain that the Litchi team would have stomped on it as soon as it was identified.

1 Like

Is anyone still looking at this from DD? I have been getting this very frequently in the past couple of months- to the point of DD being almost unusable. This morning 1 of 2 flights worked. Last week I tried to fly a simple mission and it only worked on the last out of 5 attempts.

1 Like

For direct status update please email The only updates you will get here are the fixes and post-testing.

Hey @Adam_Carp, Do you have any updates?

Any word on a fix for this.
It’s making flying a full mission in one go virtually impossible for me.

Current device, OS and DroneDeploy versions?

I have:
DD v4.2.1
iOS 12.1.4
iPad Air 2 Wi-Fi + Cellular
P4P pro latest firmware

1 Like

Good, you haven’t upgraded to iOS 13 yet. I would hold off for just a little bit longer. I was experiencing the same issues stated before, but i don’t understanding how it is making DroneDeploy unusable. Could you walk us through it a little? The thread has been dead for a while so probably good to rehash if needed.

No problem.
For example- i did 4 flights today. First one worked fine, no issues.
Second one I got the “Pilot required- GPS error” message just after take off- when it had not yet reached mission height. (status of GPS within DD seemed to be fine- 10+ sats)
Returned to home- took off again and this time it worked ok.
3rd flight worked fine.
4th flight failed almost straight after take off. Tried again…completed about 1/8 of mission and got “pilot required - GPS error”, returned home.
Tried again and it continued mission fine (although when I got back to office I found it had missed almost a whole line- which I had to re-do)

Could it be I have a GPS module that is playing up? although the GPS status doesn’t seem to suggest this.

1 Like

That’s a little different than what we had been reporting. Ours was a deliberate switch from P-Mode to S-Mode to get out of autonomous flight and it would throw that notification. It wasn’t happening by itself. Seems like something else may be wrong.