IOS 3.2.1 on iPad Air2... Misleading notifications

Thanks Adam, @Dave @SergeKouper @JamesC.

^ What he said. :). Thank you.

Thanks for following through with this, Adam. Group fist bump!

Since this is still an issue, even in a slightly different format and this is the first major post associated I am bringing DroneDeploy back in. @Adam_Carp @Erika_Houseman @Kaitlin @Lindsey_Huffman

We are still getting odd pilot required/GPS lost messages when getting out of P-mode. Similar is now also occurring when pausing missions on the new interface. It needs to be restated or portrayed in a less threatening more relevant way if it is to stay. It could conflict with actual GPS-loss notifications that should be present.



It is obvious the engineer took a shortcut and is triggering what they think is an appropriate generic warning when control is taken away from the app. When in fact it is an inappropriate warning for the circumstance which could lead to unnecessary evasive maneuvers.
Little engineering bugs happen and that’s to be expected. However, it is really not acceptable for bugs that would probably take an hour to be fixed languishing for months and months. This just sends the message of uncaring. (My opionion)
For example, I know for certain that the Litchi team would have stomped on it as soon as it was identified.

1 Like

Is anyone still looking at this from DD? I have been getting this very frequently in the past couple of months- to the point of DD being almost unusable. This morning 1 of 2 flights worked. Last week I tried to fly a simple mission and it only worked on the last out of 5 attempts.

1 Like

For direct status update please email The only updates you will get here are the fixes and post-testing.

Hey @Adam_Carp, Do you have any updates?

Any word on a fix for this.
It’s making flying a full mission in one go virtually impossible for me.

Current device, OS and DroneDeploy versions?

I have:
DD v4.2.1
iOS 12.1.4
iPad Air 2 Wi-Fi + Cellular
P4P pro latest firmware

1 Like

Good, you haven’t upgraded to iOS 13 yet. I would hold off for just a little bit longer. I was experiencing the same issues stated before, but i don’t understanding how it is making DroneDeploy unusable. Could you walk us through it a little? The thread has been dead for a while so probably good to rehash if needed.

No problem.
For example- i did 4 flights today. First one worked fine, no issues.
Second one I got the “Pilot required- GPS error” message just after take off- when it had not yet reached mission height. (status of GPS within DD seemed to be fine- 10+ sats)
Returned to home- took off again and this time it worked ok.
3rd flight worked fine.
4th flight failed almost straight after take off. Tried again…completed about 1/8 of mission and got “pilot required - GPS error”, returned home.
Tried again and it continued mission fine (although when I got back to office I found it had missed almost a whole line- which I had to re-do)

Could it be I have a GPS module that is playing up? although the GPS status doesn’t seem to suggest this.

1 Like

That’s a little different than what we had been reporting. Ours was a deliberate switch from P-Mode to S-Mode to get out of autonomous flight and it would throw that notification. It wasn’t happening by itself. Seems like something else may be wrong.

Hello, I’m having the same problem reported, sometimes the drone goes to the first point of the mission and from there it appears the same message Pilot Required: GPS signal likely lost.
Other times he is executing the mission, stops and the message appears again.
This happens with both the Samsung S9 phone and an iPhone 6 plus.
I’ve been following the messages, my control is in the P position, I don’t change it.
I still don’t understand if it’s a DD problem or some configuration change that has to be made.
I use a Phantom 4 Pro.
Did you have any specific guidance?

That message is pretty buggy, but it does sound like you might possibly have some interference or disconnection. I have never seen it pop up unless I switched out of autonomous mode, P-mode. It’s probably worth an email to

Do you have obstacle avoidance on and is there a chance you were going into sunlight?


I Followed the threads that talk about this issue to this one so I guess I will chime in as well. I am getting this error “PILOT REQUIRED! GPS signal likely lost…” every time my mission is complete. I am flying a Mavic Pro
Nvidia shield tablet K1 - Android v 7.0
Drone Deploy Version Mobile-4.1.0-4.1.0

This error happens after every mission. I am not switching or touching anything. After the flight the drone starts its return to home, fly’s to the home location and the second it starts to descend the warning pops up. I am assuming it does this to alert the user that the drone is landing but it just seams strange. My drone comes down just fine and 5 out of the 6 flights it landed all on its own. the 6th it just came down to about 3 ’ and hovered until I gave throttle input and it landed. Just thought it was weird and was looking for some answers to see if this is just a standard message or something I need to do different to fix.