Inspire 2 issues

We have been flying with dronedeploy with all our drones for a long time. We have had many problems with our Inspire 2 lately. Do any of these problems sound familiar to you guys?

When we fly with the Inspire 2 (x7 all the lenses and also with the X5) (Ipad / Iphone), the Inspire 2 skips photos at random places. Also, the photos that are taken in are sometimes half green. DD gives no further error messages. I also noticed that the drone doesn’t fly straight during the flight, so never with the nose straight ahead. We have already tried different SD cards and with all our other drone we do not have these problems.

Does anyone have an idea how this can be fixed?

1 Like

As a new user i can only put 1 image in the first post so here is a sample of one of the picture that were taken during this flight:
DJI_0566

1 Like

NO, i don’t have such problem. No solution for you

1 Like

So you also fly with the Inspire 2 an does your aircraft remain straight (nose to the front) the entire flight?

What settings do you use and do you also fly with the Ipad/Iphone?

1 Like

I fly I2. The control program “crabs” the aircraft into the wind. It doesn’t affect map quality. I fly an x4s so can’t comment on other issue other than this; you’re moving a good deal of data so be sure you’re using fast micro sd cards.

1 Like

I also noticed this with windy situations. The strange thing is that the inspire 2 never flies stainght (always to the same side) not even wehem the wind comes from a different direction or when there is almost no wind.

Furthermore, I have performed a test with pix4d and here I do not encounter these problems at all, this is the exactly same setup and location:

I have now tried 4 different sd cards and the same problems arise for all of them. We have tried: Sandisk ulta Class 10, U1, A1 and Sandisk extreme U3

1 Like

This is a known problem with the X7 when taking timed photos (i.e 2s interval). It tend to happen when you take upwards of 200-300 photos, but it is rather random. On some occasions, I can capture upwards of 1000 images without issue and other times it will start after 200-300 images. I have brought this to DJI’s attention, but I need to send my camera back to them, which is a 2-3 month exercise at best which I can’t afford and I doubt will resolve the issue. This problem occurs with the X7 cameras of the other operators that I know of, but given that the X7 is not widely used this way, the problem is not well documented. Also, this is not specific to any app and occurs regardless of the type of sd card.

2 Likes