Image Location Data error

Image Location Data
0 images with valid geographical metadata found. A minimum of 10 images is required.

Get this error when trying to upload images in a Chrome Browser. Photos taken with Mavic Pro. Any thoughts?

One thought: did you calibrate the compass before taking off?

Ya know I don’t recall as I did this a few weeks ago. However, Pix4D was able to process the shoot.

I’m getting it also. I’m using Crome. I used a card reader to move images onto an iPad then uploaded to a cloud service for processing later. Any ideas?

Have you upgraded to 2.0.44?

So you’re drone took photos but it says we don’t detect the metadata when trying to upload? Can you please reach out to They will be able to tell you exactly what is wrong with your photos after you send a few samples.

I did upgrade to the latest version. When I tried to upload the images it said a minimum of 10 images are required. I then checked the metadata and can’t find any location data. I think it’s a problem with the way we moved the images to an iPad then to a cloud service. I later ran the mission again and it worked fine when I uploaded directly to DroneDeploy.


Ah yes, if you upload to a cloud service it’s possible it rips out or messes up the exif data on the photo file.