Ground-Level Photos from a Samsung Phone Not Showing/Uploading Successfully

I am trying to upload some ground-level photos that I had taken with my phone. They are jpg’s and it seems to upload but when completed none of the photos show on the map or in the photo reports. They all have locations (Longitude and Latitude) so I don’t know why it is having a problem. Any photo I upload from the drone works fine. Does anyone have any idea as to why this is happening and/or how I can upload these photos successfully? Thanks for any help you can provide.

2 Likes

Have you checked the coordinate range to make sure the drone and phone photos are in the same location? This can also happen when satellite reception gets limited and the coordinates on the phone start bouncing all over the place. Why not just handhold the drone?

Michael L.

Yeah, I checked. They are very close to what I expect.
image

I thought about that after I had an issue uploading but did not expect it to be an issue when I was in the field.
I don’t understand why it would care what camera I used; they are both common JPG files. The only difference is the resolution.
Do you know if there Is there a limitation on the file size that you can upload?
If there is why does it not return an error message?

Thanks for any help you can provide,
-Michael V.

I just tried resizing a photo (Using Microsoft Photos) to the same size as the drone photos and it worked but the tool to resize it also stripped the GPS data so it just placed the photo icon at the project origin.

Does anyone know a way to resize JPGs while retaining the GPS data?

Is there a way to request functionality such as automatic resizing if it exceeds the size limit?
Can we request that they eliminate or increase size restrictions?

Thanks
-Michael

Positioning includes vertical so I wonder if there system doesn’t like the change in altitude? Which phone exactly? We might be able to get someone to do a test…

You’re best course is to email support. @Jamespipe

Something else I just thought of? Are you flying with the same phone or do you have an iPhone/iPad?

It is the Samsung Galaxy S20 Ultra. I took the photos using the standard camera application before flying. I then used that phone for flying later. That should not make a difference. Altitude sounds like something DroneDeploy should have thought of when giving the option to upload ground images.

-Michael

Michael L.

Interestingly, I tried a GoPro photo that does have the altitude and it worked. You may be on to something there!

1 Like

The point was that if you used a different device like an iPad you could try taking pictures with this to rule the phone out. Have you looked at the EXIF data from the images on the phone? Make sure the GPS section is filled out correctly. It would be similar to the same entries as the drone. This and position information is easy to see in Geosetter. We had troubles integrating imagery from the Yuneec H520 and it ended up being the way the GPS information was written by Yuneec.

Yes, I did but using file explorer which is not very comprehensive.

Here is the screenshot of the geosetter location information from a drone photo
image

and here is the geosetter screenshot of the location information from a Samsung Phone photo
image

Samsung does not list the altitude information including the GPS map datum which if my understanding is correct is also related to the altitude adjusting for the ellipsoid shape of the earth.
The phone data does seem to be in order horizontally though.

Thanks again for your help
-Michael

That’s my guess. Th lack of altitude information seems like it would throw a fault into their system. @Jamespipe

Pretty much all GNSS devices work with WGS84 so they also use the WGS84 ellipsoid. When we survey we use the data collector to convert all of that into the ground information we are all seeking. Most US Surveyors use NAD83 and the GRS80 ellipsoid but we also use GEOIDs which is something that throws most people into a tailspin when you start converting datums.