Gimbal Error

I have had a few problems with Drone Deploy. I’ll go through step by step of what I did:

  1. The night before the flight I made 9 plans. Each plan had
    different altitudes and different overlaps of the same area. The area I
    was planning on doing was a simple 2 hecrare area just to see how it all
    turns out and to test how DD works in online and offline mode, and see
    how the app does with controlling my drone, etc. So the first problem,
    was after I made the plans I tried syncing them to my android phone,
    which is a Samsung s6. Only one synced and the rest gave me a
    confirmation saying they were synced but when I went back to the
    ‘Dashboard’ only the first one I synced had the green ‘Synced’ text next
    to it.

  2. So I decided the next day to just fly the one plan and see how it
    turns out anyways. I could still test out other things I wasn’t sure
    about… I had my drone ready to go and DD was running on my phone,
    which was connected to my controller. But for some reason I couldn’t
    bring up my one plan that I thought would have worked… the only plan
    that came up was the default plan that comes up centered on your current
    location. I was connected to WIFI, and yes I did hit ‘Offline Sync.’ So
    I went through the checklist to just fly the default plan directly on
    my position at 800ft…

  3. Everything went well with the checklist. First I had an error
    saying that I wasn’t in the right Flight Mode, which I corrected. After
    that the only error I had was that the test photo failed. So I took DDs
    advice and went into the DJI Go app and took a photo. After that it did
    work. So after all the issues I just wanted to see if it would take off
    and fly the route properly, which it did nicely! But…

  4. So after it landed, with some of my help, I got another error that
    pertained to the gimbal. I can’t remember exactly but I’m pretty sure
    DD told me to go into the DJI Go app and check the error properly. I
    ended up getting an error that said something like “Gimbal Overload
    Error.” And then DJI Go basically told me to take the gimbal off and to
    contact DJI.

I did not take the gimbal off. I took it to a friend of mine who has a lot more experience and he said everything seemed fine. But I thought I would report this and see on here as well to see if anyone on here, or DD, has any information that could shed some light on this issue. Any help would be appreciated