Flying in No-Fly/Restricted Flight Zone

DD What the heck? I thought we were done with this no-fly nonsense. I just tried to launch near an airport for which I am fully authorized and failed at the “Waypoint upload” flight pre-check due to “in no-fly zone”. I even disabled geo fencing in DJI but the 2 apps clearly aren’t talking. Spent 2 hours power-cycling and re-booting and re-loading and re-installing both DJI and DD and I just lost a day of productive work for client. When will this be fixed???

No fly zone support coming in a couple weeks now that we have DJI sdk support .

Just had the very same problem, using Phantom 3 advanced, have flowen successfully in the restricted area using drone deploy app with full permission and can fly there today using DJI go app but not since I upgraded dronedeploy software yesterday morning, hope the software is updated very soon, will we get some form of notification or do we keep our fingers crossed on the next software upgrade?

The previous versions of DD should have no different behavior regarding no fly zones. Next software update should improve it either way.

Having the same issues… Work for a large company, we have close ties with the FAA. Granted many COAs and waivers to fly because a lot of the areas we need to cover are in very tightly controlled airspace, up to and including Bravo. Good relationships with local towers, and with DJI. Once applying the DJI unlock, all red lights go away, and I’m able to fly no problem under the DJI Go app. Have tried multiple softwares, all gave me “your mission will cross a no fly zone” or something to that effect. Using an Ipad Air 2, I tried various methods of entering into the software, first leaving DJI Go open while entering alternate software, then closing, rebooting everything, starting over,etc. I did get to the point where DD would not tell me that there was a restricted area at all, in fact all pre-flight checks worked perfectly. However, when clicking the check mark, it appeared to lock up, aircraft did not respond, and a message box popped up at the bottom of the screen “unable to start the mission”. That seemed to be some sort of progress considering everything I had tried, but still no dice. Not sure if it has anything to do with the firmware update from yesterday or not. One of the other softwares I tried was actually DJI’s own GSP… believe it or not, the unlock didn’t register there either! Frustrating!

chasemgray, has the latest update 2.0.49 released July 7 fixed the above issue? Don’t want to make a trip all the way back to site just to find out it still doesn’t let me fly near airport.

We’re hoping the upcoming release has it, if not it will be in the one following it. We’ll know whether it will make it in the upcoming release later today.

Having updated DD twice and 1 update on the controller, although DJI Go app still allows me to fly the DD app is still restricting my flight

Updated software again yesterday where it specifically said it had dealt with the no fly zones. Needed to fly a field which is time critical to gather data, field is half in and half out of no fly zone. I moved the flying area out of the no-fly zone so that I could at least fly half the field and although it then passed all the checks when I pressed the tick button it kept pulsing at me and still would not let me fly.As more than half my farm is in a so-called no-fly zone (although I have all the permissions) this software isn’t much good to me. Such a great pity as it used to work flawlessly. Interestingly when I swapped back to the DJI go app the no fly zone circle appeared on the app for a second before then disappearing.

Which release notes did you see that mentioned no fly zones?

This is getting enabled for accounts today for users who have the latest iOS app. Android does not work yet due to issues on the DJI SDK.

If you’re within a no fly zone it should tell you and let you proceed if you’ve unlocked it.

Can you tell me how to unlock the no fly zone please, I have unlocked it in the DJI go app but still won’t let me fly in the drone deploy app.
There was a pop-up screen in the bottom right-hand corner with a picture of a young lady (sorry can’t remember name) where fixing the no fly zone was mentioned in her commentary.

I have unlocked a region near an airport on DJI for the next three days. Is DD ready for me to go try flying that field to see if it works?

What should happen is the checklist should prompt you to connect to your DJI account if it detects you are in a no fly zone.
This won’t work for restricted zones, only for authorization zones.

1 Like

Sounds good. I will give it a shot and give an update with my results.

As I hadn’t heard anything got on and used DJI GS pro and it worked flawlessly so proposing to dump dronedeploy very appointing

Latest app version should allow you to fly in no fly zone as I posted above.

Perhaps it should allow me to fly in a no-fly zone but I can confirm it doesn’t

I can fly my Mavic at home, but I cannot get a map to load so I can map it. I has to be due to these “Advisories”. I am glad I passed on paying for this service. Too much BS to deal with.

Hi @Slinger,

Thanks for swinging by the DroneDeploy Forum. I’m sorry to hear that you are encountering difficulties to create a map with DroneDeploy. Please note that in our Explorer (Free) plan you can use our flight app as much as you want and create up to 5 maps per month at no cost.

I invite you to take a look at our How to Process Datasets guide. It walks you through the uploading process so you can create successful maps with DroneDeploy.

Happy mapping!


I understand the No Fly issue, but yesterday I went to do my monthly mapping of UC Merced construction site, the same mapping I do each month. But this time it would not allow me to Map the East end of the construction site. So consequently I’m going to have a very unhappy client because that is where a lot of the new construction in progress.

This idea of deciding for us where we can and can not fly is total foolishness. If it continues I’ll go to a different mapping software. I work for Multivista we have used DD extensively for mapping, so please fix this asap.