Flight plan fine but "Waypoints too close" upon continuation

We are flying the following mission with a Mavic 2 Pro and an Android with the latest app. The preflight check goes just fine and it flies an entire battery. When we bring it home and swap batteries, we get an error during the resume flight check that the “waypoints are too close”. We tried three different ways. First was the top plan below, ended right when it started a new transect. We thought maybe the resume point was the issue, so we then did the same plan over, but ended it in the middle of a transect. Still no go. Then we made the direction have less turns (bottom picture), and still no luck. We have done similar flights at half a dozen other sites without this issue. Stinks to waste 3 batteries and not have it done.

I know that we can break this into multiple missions, but we shouldn’t have too. We have flown other missions that are just as large and complex without a problem.

Any help would be appreciated.

Was this an import from KML or free-handed? There is another thread on here with the same message occurring.

Michael, this was free-handed. We had previously imported .shp files, but none of them would work because the wpts were too close, so we went back and free-handed with looser turns. It’s just odd that it would fly the mission fine until it was time for a battery change.

I had searched for similar threads, but will search again to find the one you are referring to.

Here’s the other thread that just started. Definitely some similarities.