Fit-to-Full-Screen function for 2D Maps


#1

Can you please add a hot key that will fit the 2D, Plant Health or Elevation maps to the full screen of the DroneDeploy App?

Currently it is impossible to get the map to fill the screen regardless of the device used, +/- keys on map, mouse wheel or touch screen. This is because DroneDeploy has pre-determined fixed sizes for the 2D maps. Thus it ignores the magnitude of the zoom requested and just uses the direction of the zoom to snap up or down to the next pre-determined size.

If I could just hit something like Ctrl + F to have the map fill the first limiting dimension in X or Y, then I would be very happy.

And once fit, the App should behave as it does now when switching from 2D to Plant Health to Elevation, using the prior Map’s size for the next map.

I am using DroneDeploy on a PC running Windows 10. The iOS behavior is much better as tested by @Christina.

Regards,
Terry.
@Nipul, @chasemgray, @jeremy


#4

Hi @SolarBarn,

Thanks for sharing these suggestions but I do not have any updates at this time to share about whether or not these features will be implemented.

Cheers,
Christina


#6

Hi @SolarBarn,

Can you attach any screenshots of what you mean? It will be easier for me to understand the issue and what you are trying to achieve.

Thanks,
Christina


#8

Hi @SolarBarn,

I have no issues zooming in and out of maps with control with my MacBook Air.

Cheers,
Christina


#10

Hi Terry,

We use all sorts of devices and platforms here, as do many of our users, without issue.

Cheers,
Christina


#14

Hi @SolarBarn,

We appreciate your feedback, as these types of comments help build a better product. The zooming issue you mentioned has not been reproducible on our end, although I have heard of this happening.

Just to cover the basics, have you tried to adjust the mouse scroll speed in Windows?

To help you out, I have submitted this improvement to our product team. You’ve submitted this improvement in the right place which will allow other users to Like the idea. As other users Like the idea, it brings visibility to our product to help prioritize work on the roadmap.

Thank you,
@Nipul


#16

Hi @SolarBarn,

Your assumption could possibly be correct where we are controlling the increase/decrease in the zoom level. If we make this improvement on from our side, I will follow up with you here. Unfortunately, I do not have a timeline at the moment.

Please let us know if you have any further questions.

Thank you,
@Nipul


#18

Hi @SolarBarn,

When we push fixes to our staging environment, our QA tests these scenarios on virtual machines running multiple versions of Windows, as this part of our testing process.

I did test this on a Windows machine where my zoom was not jumpy. Though it can be hard to get the map to utilize 100% of the screen, it gets close. See screenshot below.
I don’t want to discount your concern and I will bring this up to our product team.

Thank you,
@nipul


#20

@Nipul,

The 2D maps cannot be fitted to full screen regardless of the device used:

  1. +/- keys on DroneDeploy 2D map
  2. Mouse roller wheel
  3. Touch screen
    The map snaps to preset sizes. No other map sizes are available.

So the heart of the matter is that DroneDeploy is ignoring the magnitude of the zoom requested by any device. It just uses the direction of zoom (up or down) to snap to its next pre-determined size.

Pretty disappointing. Such wonderful data. So hard to see.

Apparently works on iOs but not Windows 10.

Regards,
Terry.
@chasemgray, @zach1, @jeremy


#21

Hi @SolarBarn,

I completely understand your point. This is with the product team and once we get some traction on your concern, I can update you here.

Thank you for the feedback.

@Nipul


#22

@Nipul,

I discovered why you and others in Windows 10 are getting different results when trying to fit a 2D map to full screen. How well this works depends upon your display Resolution and the Scale and Layout setting in the Windows 10 Display settings page:

This is the best I can get on my 4K display with a 3840 x 2160 Resolution setting and the 300% recommended Scale and Layout setting:

but this can be improved markedly by using the 200% Scale and Layout setting:

So at present, I can either have a bigger looking map with text that is too big for all applications, or a smaller map with text that is just right.

Thus when your software developers consider this problem, they should be careful to test with different display Resolutions and Scale and Layout settings. It would be nice to see a contemplative implementation that works well across all combinations.

Now, while the result gets better by dinking with the Scale and Layout (at the expense of text size in all applications), what I really want is a true Fit function so the map just fills the screen as limited by X or Y which ever comes first.

I think most would admit that the maximum size map displayable with the recommended defaults for a 4K display is more than a little disappointing. DroneDeploy creates such wonderful data that I’m sure you want to display it in a way that shows off its greatness.

Regards,
Terry.


#23

@Nipul,

I made yet another discover concerning this issue.

The reason the 2D maps have fixed sizes is because the same DroneDeploy code that controls the map size for flying a mission is used to display the map results after a mission. When flying a mission there is not much benefit to playing with the exact map size. You just want to quickly get it to fit inside the screen boundaries so that you can fly the mission while seeing your drones progress over the whole fly zone. However once the 2D maps are complete, then there is a significant benefit to fitting them to the full screen size or any continuously zoomed size. Just like the 3D model - it can be continuously and controllably zoomed to any size. If this could be done with the 2D maps, then life would be wonderful. And again, a true Fit to Full Screen function would be good.

Regards,
Terry.
@chasemgray, @Christina, @zach1, @Jeremy, @JamesC


#24

The mapping libraries used on desktop and the mobile app are different. There are some limitations on desktop which cause this snapping you’re experiencing. On mobile it should be a smooth experience, but I understand the frustration with dekstop. This isn’t going to change for the next couple months at least. I do believe we’ll be moving the desktop maps over to something else sometime in the future but I’m not sure of any dates.


#25

@chasemgray,
No better on mobile app. Jumps just as awfully on new Note 8 phone or Tab S3. Sorry, but this is one of my least favorite things about DD. Love how it can see the 1/4"/ft. slope of my driveway from 300’ photos. Hate trying to view the results.

Do you get a different result? Is there smooth zooming on iOS devices?

Regards,
Terry.


#26

Hi @SolarBarn,

This is really good data that you’ve put together. While we do try our best to render the map in a usable format on a mobile device, we designed the map view to be best suited for a desktop screen.

Designing the map viewer to be compatible with every mobile device is difficult, so we optimize for devices most commonly used by consumers. I tested the map viewer (processed map) on my iPhone 6s and the zoom can be controlled precisely by using the two-finger motion to zoom in and out. It does not ‘jump’ for me.

As we innovate our product, we will take your research into consideration to create a better user experience when viewing maps on a mobile device.

Thank you,
@Nipul


#27

@Nipul,

My belief is that no Android device or Windows PC can smoothly zoom any of the 2D maps:
Map used to Plan a Mission and fly it, 2D Orthoscopic Map, Plant Health Map or Elevation Map.

On the other hand, I believe that all Android and Window PC can smoothly zoom the 3D model. This works on all my such devices.

So it may be easy for your developers to fix this issue for Android devices and Window PCs by looking at their code for the 3D map viewer.

I hope they can do this soon.

DD generates such wonderful data. But it is so hard to see it well on other than Apple products.

Regards,
Terry.


#28

Hi @SolarBarn,

We’ll definitely pass this data onto our product team, once we can prioritize this. We appreciate your passion for DroneDeploy!

Thank you,
@Nipul


#29

hmm. It’s possible that maybe you don’t have google maps enabled on your account. I’m checking now. If that’s the case we’ll enable it and later today you should be able to zoom to your map on your Android device.


#30

@chasemgray,

How does google map enable tie into zooming capability?

Oh the mysteries of the universe, will they never cease to amaze!

Regards,
Terry.


#31

It just doesn’t have the “snapping” behavior you’re talking about.