Firmware 1.04.010 Will not work currently!

we are working on a fix as we knew about this possibility. The new update breaks how we used the groundstation again apparently due to “safety concerns”

Yep. And I just found out I can’t go back to DD’s firmware 1.04.005. Just letting people know the firmware won’t go backward.

Will have a new version out tomorrow that should fix this. Testing now.

We have a version that works but DJI is really limiting us with the new restrictions on waypoints. We have a way around this and we are testing it now. Trying to put a fix out there that still allows missions at high altitudes longer than 6-7 minutes.

Sounds good chase. Can confirm the new firmware didnt pass Drone State check. Having strange issues with loading the DroneDeploy software as it goes into a no rotate version and never connects to the drone. If I close the software and reboot the controller it automatically launches DroneDeploy (I set it to launch on USB connection) and everything works fine (getting the app to lauch in the right landscape view and it finds the drone ok) Other than that it was working great up until the last firmware update. Will look forward to the next release.


Are we still grounded if we have the new firmware? I haven’t noticed an app update.

Yeah. Going to release a version, but we were trying to include a fix that didn’t limit users to 5000 meters total path length. We have a fix for that but might release a version that works with the new firmware first.

Thanks. How do you know the length of your flight paths? When my P3A makes a turn and heads the other direction, a green dot appears, but it always has the altitude by it. Is it supposed to be showing the path length instead of altitude?

We don’t show the path length. At a high altitude, such as 400 feet, that might put a max flight time of about 7-8 minutes from our tests.

We are considering releasing an APK on the forum for those that have upgraded to the newest firmware while we implement a better solution.
The current firmware seems to have the following restrictions:

  • Max length of 500m waypoints
  • Max length of 5000m for the entire mission (30-40 acres at 400 feet)
  • Some new errors I haven’t seen before limiting altitude. I saw these with missions around 390 feet
  • Requires us to set the waypoints while the aircraft is in the air. This causes us to sometimes takeoff and then fail to write waypoints due to many possible reasons and sometimes due to just a slightly bad signal.

We have a version that works for smaller maps that aren’t at super high altitudes. We would recommend that everyone stay on the firmware 1.04.006 or 1.04.005 for now since it works with the app and also should work with all of DJI Go’s newest features.

Hi chasemgray. I’m not sure to understand that you said there is a version working good for small maps? If it is true please where can I get it?
The firmware i have is the latest of dji…0010. Sorry about my English and thanks in advance

Thanks. For those looking for it, here is the URL for the firmware.

Chase: Do you have a best practice suggestion for how to go about downgrading from first?

Downgrading seems to be disabled. Same as before you can downgrade to 1.03 but it won’t let you then upgrade back to the SDK firmware.

We’ll have something for you very soon though so everyone should be able to fly this weekend.

when will there be an update that enables us to use the dronedeploy on the new firmware??
I will be happy to just use the APK that enables small maps.

I totally forgot to mention one way you can fly If you take off the drone to around 10-20 meters before starting the checklist it should all work. This is what we have been trying to get around as well as have more clear messaging for users who it might confuse.
I think this should work at least.

ok, thank you:) will try that tomorrow:)

Just to clarify … you are suggesting that we fly the drone manually in P mode, before launching the DD app?

Has to be switched into F before you run the checklist. It will warm you about that first.

Seems to almost work when i tried to downgrade to v1.3.20, launch the DD app, it passes all checklists, takes off, but stops 3-4 meters above the ground, the app then shows take-off error…
I tried to lift the drone 10-20 meters before doing the checklist. The app always show error regarding the f-mode.
Hope there will be an update soon :smile:

Mmmm I confirm for the last firmware not working… to activate waypoint on dji pilot app it need to get at least 20meter to launch a mission this why dd should work at 20 meter in flight… bad thing it’s not avaible to downgrade… is it possible to fake the api with an offset of 20 meter above the ground level when init a dd mission…?