Feedback on New Release ver 44 - P3P Android & Apple

I was very excited to see the new releases of DD today for both Android and Apple.

I wiped DD off both my Samsung tablet and Apple tablet and reinstalled from scratch. Verified that the version was 2.0.44.

Rushed out into the field to trial the new software with my Phantom 3 Professional.

Bird connects fine.
All systems test pass successfully.
Hit the fly button - bird takes of as expected.
…and never drops the camera to point straight down.
She started off on the route correctly and the camera started capturing but as it was pointing straight ahead I aborted the flight.
RTH works !
Another fail.

Before I have even powered on the bird the app says that the drone is connected.
Powered on bird. Waited. Waited. Waited.
20 mins later it still hasnt recognised that the bird is online.
Verified connectivity with controller to bird - all ok.
Another fail.

Disappointing results seeing as this BIG release was going to solve all the problems.

I will be trialling the new software with my P4 Professional later today and will feed back accordingly.
I can only hope that the P4 behaves better - because if it doesn’t I am doomed !

Thank you for this feedback and sorry to hear you’re having these issues. I’m sharing this with the team and will get back to you with more info soon.

Hi @syamaphantom whats your username? I’d like to see logs and investigate what went wrong. And when you connected the drone to apple device - did you try if DJI Go app worked with the drone? Wondering if cable could be a point of failure.

HI Manu,

Syamaphantom is my username. What logs ?

DJI GO app worked fine.


Thanks to chasemgray I have managed to connect to the P3P using my apple device.

Flight went off without a hitch and the camera pointed down as it should.

I will double check the Android flight to confirm that the camera definitely does not point down.