Feedback for Alternate Navigation Mode


This thread is for users to provide feedback about the alternate navigation mode feature we are slowly rolling out to initial testers. We haven’t given this to all of the beta testers yet but we hope to very soon.



1 Like

Still having the same issues as before.

DJI Inspire 1, firmware version
Samsung Galaxy Tab A, Android version 5.0.2.
DroneDeploy APK 1.2.1

I tried various combinations of the following:

  • flight modes A & F
  • initiate checklist on ground & in the air
  • flight altitudes of 200, 250, 300 ft
  • tried both alternative flight mode on & off

In all cases, I got full green on the checklist. In mostcases I would get the “Starting Mission” overlay when triggering takeoff in the app. If initiating mission from the ground, the drone would successfully take off to usual hover height and hold there, with landing gear up. However, it would consistently just hover there:


I waited up to ~5 minutes, but it would not leave the hover. When that wasn’t working, tried piloting the drone manually to the first waypoint. The checklist would stay open on the screen while flying those patterns, so I was not effectively able to see the drone’s altitude. Got very close to the waypoint, but it didn’t seem to be triggering it:

When the mission was clearly not initiating, I tried to fly along the planned flight path manually. Was kind of hoping that the system would be triggering imagery. It didn’t. I shot a few manually using the trigger on the controller, but that’s kind of awkward and it turns out that I forgot to turn the camera down, so I ended up with a few oblique images on the SD card.

I tried cancelling the takeoff with the big X in the bottom right corner. The “Cancelling takeoff” overlay would just stay open, would not close. Drone would just remain in hover:

One other thing I noticed is that several times, when I opened the menu on the left of the app, many instances of the drone would show at the bottom of the menu:

It got dark before I could try more options. Will get back at it at sunrise tomorrow.

I saw this in the logs and I’m not sure what went wrong. We weren’t able to open the ground station for some reason.

We are seeing a weird error I’ve never seen before.

One possibility – I just discovered that the controller was still at firmware
I had updated my previous set, but this new one wasn’t updated to Updated now – will let you know how it performs in the morning.

I would try that. We were seeing a weird groundstation error

I installed firmware 1.3 on the controller and also reupgraded the firmware on the craft itself (to And it works!

Flew four missions & will prepare a quick summary of each once processing is complete, but here’s some initial general feedback:

There are still a few issues with connection the DD when opening the app. I had the tablet toggled to my iPhone. That connection was up, but the app opening, finding drone, and then calculating initial plan generally takes a few minutes. On a number of occasions, I had to close the app & restart to get to the initial plan.

There is an issue after hover and before reaching full altitude. The drone very suddenly and what appears to be full speed, takes off at an angle for about 10m or so. I think it is generally towards the first waypoint, but I’m not sure. It then stops itself and starts climbing straight vertically to flight altitude again. See video. It was able to follow lines reasonably well. Good thing you are not testing in San Francisco!

There was wind, but I would estimate no more than 10-15km at most, almost dead at other times. Did not seem to cause any issues, stayed on the line fairly well despite wind.

The turns are back to angular turns that burn a lot of energy on imagery that may not be required. I’m sure it’s because of the way you are pushing instructions, but a rounded, banked turn would be nice. I noticed on some turns that the craft was banking more than required, actually overturning and then recorrecting as it found the next flight line. Flight speeds varied based on altitude (8 mph at100’ and 19 mph at 250’). Imagery looks good as a result.

Continue mission did not work. When first battery was empty, I brought it back using the home button in the app (NOT the button on the controller). I exchanged battery, fully closed the app, reopened it, hit “Older”, and then hit continue mission. The app went back to flying starting with the initial waypoint that was already flown. Used a workaround to capture the imagery anyway, but the Continue Mission process did not work with the new flight method like it did with the previous one. Will fly again tomorrow and try interrupting the flight using home button on the controller.

Flew several larger missions and two very small ones (small oil-well site at 100’ and 250’ altitude). No problems with the tighter turns.

I am concerned that there is no indicator for signal strength. Would not want to try flying further than the 1/2 mile unless we can see how the signal is. Does it return to home if it gets too weak? If you build that into the app, you might want to increase the size of the battery status indicator too. When flying long lines, it would be nice to abort at this end, rather than get the 30% warning halfway down a 1/2 mile run.

Noticed this issue with multiple instances of the drone in the menu again:

And a question: Is the app still pushing the end-of-line waypoints to the craft, or is it piloting the craft all the way and using the waypoints only internally within the app as a flight guide?

Hi Markus,

That video is terrifying! Thank goodness you were in a wide open space!

It looks as though it might be a function of continue missions, and the autopilot buffering commands. We’ve seen the drones store old commands which it then executes if they aren’t cleared out as soon as it goes into the autonomous mode. We do actively try to clear them out, but there’s a slight delay (1sec) - hence it bolting off in one direction and then stopping to do the correct thing. If you do see that again - does it look like it heads in the same direction as it would have if it were carrying on with the previous mission?

We’re working on a fix which will clear out that buffer sooner and prevent that from happening.

Roger that on the signal strength, battery indicator, and multiple drone instances.

Yes, it was headed in the direction of the first waypoint that it would have headed to.

I’ll make sure to stand back, but will give Continue Mission a try this morning with the flight being interrupted by controller, not app. I will make sure to be in the open. Let me know if there are any other experiments you want flown today.

One other thing … I don’t suppose there would be someone at the office today? Will be delivering an AgEagle to customer this week and would like to push the wifi hotspot functionality to his and my copilot.

@Maakusi Make sure to download version 1.2.2 which got sent to your email last night.

Yes, got it. Still too windy right now, but will get out once it dies down.


Today was cloudy and windy here, but I made 2 flights about a couple hours ago, in my condo. Just a little flight for testing and to make a report to you.


DJI Phantom 3 Adv - FW
RC 1.3.2
Moto X 2014 - Android version 5.1
DroneDeploy APK 1.2.2

In general, everything about the flight mission was alright, but I have something to share:

Like @Maakusi I have multiple instances of my P3Adv.

The checks are ok and when clicked em start, it hover at 1,20 m, and camera moves to down and start climbing, but in about 15 m, it hover again. Nothing like the vídeo above, it climbing in straight line up.

In the first mission I lost the connection with the aircraft (probably because the interference of buildings), and no reconnect even when the drone was in my sight.

And at last, the curves was a little bit off original course.

Tomorrow I will make more tests in large areas and other type of terrain.

Thanks for the opportunity of be a alpha tester.

Some prints:

@Roger_Olmos in our logs it doesn’t look like you had alternate navigation mode turned on. You need to enable this to get the new navigation mode to work. Did you do that before flying?

Ops, I forgot to turn on!
Tomorrow morning I will make more flights so I’ll do correctly.

I flew despite wind today. Winds were 25-30 km/h steady, with slight gusts above that. The Inspire managed to follow the lines reasonably well in alternate navigation mode. Far from being dead-on, but I expect it did the trick for getting the required overlap.

I initially tried a high-altitude flight and interrupted it to check to see if Continue Mission would now continue (using APK 1.2.2). Unfortunately, it still wanted to start at the initial waypoint again. And it also did that weird thing of takeoff again. It was again in the direction of the initial waypoint, but this time it was two short burts – fast spurt for about 5-10 metres, hover very briefly, and then again for 5 metres or so.

I flew another low-altitude flight (80’ AGL) at that point, because winds had picked up and I didn’t want to risk flying up high anymore. Again, it followed lines reasonably well, under the circumstances.

Thanks for the tests. Tomorrow I’ll be focusing on seeing if we can consistently reproduce the takeoff issue. Otherwise it seems everything else is good for a v1 release to more people.

Like Maakusi I have run a number of flight tests today in 25-30 km/h (whatever kilometers are!) winds. The hold points on take off and corners were most affected by the cross-winds, with it sometimes being blown 3 - 5 meters off track and then correcting. Once onto a leg it held position reasonably well.
I couldn’t get Continue Mission to work at all as none of the flight plans I flew today appeared in the list of available flights. I could see yesterdays and prior but none of the latest.
RTH worked as previously and as per DJI app.
Now, that take-off issue:
It appears that, like you suggested, there is some remnant of a previously-interrupted flight plan on the Inspire that is causing this. If I took off and then interrupted the mission via the app, via manual RTH or via override to P-mode then the next take off would be affected by a sudden move towards the first waypoint. This occurred 100% of the time I tested this scenario, although the amount of movement varied from 1/2 meter to 10 meters and it did appear to be at full speed. However, 100% of times I fully completed the previous mission OR if I loaded the DJI Pilot app after an interrupted mission, took off and made sure there were no set waypoints, then landed and returned to DD there was zero movement and DD would launch a mission vertically to operational height.
I’ve got a load of videos of these. You should see four or five logs of this and I can consistently cause and avoid it
I also had a couple of app crashes and Connecting to Inspire… now takes 1 - 2 minutes most times. Other than that, everything seemed as per non-alternate mode.

First flight with the 1.2.2. Took me a while to get started. (didn’t refresh the flightpath, got stuck during connection to the inspire …) but then takeoff and mission start was good. Pretty windy today and I experienced some drifting at the turning points. Was not able to finish the 11min calculated mission on one battery. The dashboard now tells me -239 images and the flight log is not showing up.

Flight Log not appearing in the Dashboard is a recurring issue that you’ll want to address ad well. Yesterday, my incomplete flight (“Attempt Continue”) has a flight log, while the mission actually completed (“Wellsite 80plus”) does not.

On a positive note, I tried flying a small oil wellsite at 80’ AGL with the new navigation and added lots of oblique imagery flown with DJI GO. It turned out quite nice:

Dear chasemgray

Would you please put me in newest beta tester which is v1.2.2 !
I am very very eager to check out and report.