Error: shape edges cannot cross

Hi Guys,

“ERROR: Shape Edges Cannot Cross” is making me cross!

Using the web App I can make a new flight plan only by clicking polygons in a counter clockwise direction. Clockwise clicking produces the error message above.

The second thing is that once the flight is planned I cannot move the nodes/points. I can add new ones but can’t move the old ones that appear to have a slightly different symbol - white dot with stronger black shadow. I can’t find the documentation that explains all this and what works and doesn’t work. If I want to change things I have to simply create a whole new flight plan from the start which is a real pain.


I’m using the latest version of the Google Chrome browser (Version 49.0.2623.110 m).



Hi Andrew,

Sorry to hear that you’re having issues! This shouldn’t be the case. Which OS are you running? This shouldn’t be happening on Chrome. Have you tried Firefox?

If you’re able to - grabbing a screen recording or screenshot of the issue with the javascript console open, and emailed that through to that would be hugely helpful!


I have the same issue as Andrew. It occurs when trying to set up a flight plan for my AgEagle using Chrome on a Panasonic Toughbook with a touch screen. The issue does not occur if I place my points using the touch screen, but DOES occur if I try to place points using my mouse or mousepad. I’m also having similar issues trying to annotate polygons onto my maps.

I’m having the same problem. Just downloaded the latest version of Firefox and is don’t work on there either. I’ve tried Chrome, IE, and now Firefox. Any other ideas?

sorry to hear this @jda- if you’re able to, please do send us a grabbing a screen recording or screenshot of the issue with the javascript console open to .