Dronedeploy Invalid Remote Controller Mode

Hello,

So yesterday I flew a ton of flights with DD without a problem using Matrice 200 V2 and X7 Camera. Today I go to fly and I can’t because it says “Invalid Remote Controller Mode”. I have literally tried everything from uninstalling the app, installing it back and it doesn’t work. Nothing has changed from yesterday to today and honestly it is really making me mad because I have a deadline this week to be having so many problems. I need to resolve this problem as soon as possible.

*All my firmware and everything is up to date. It was working flawless yesterday and today it doesnt want to work.

1 Like

Hello Dainel,

“Invalid remote controller mode” errors can occur when the DJI controller is not set to Position mode. Make sure the switch on the controller is set to ‘P’ mode and not ‘S’ or ‘A’ before launching the DroneDeploy app.

1 Like

Trust me I have made sure 100 times and still same thing… I can’t get it to work and the funny thing it worked flawlessly yesterday.

1 Like

Did you try opening the DJIgo app and making sure that it registers you as being in position mode before you open DroneDeploy? I have found that sometimes conflicts between the modes in each app create a problem, especially in DroneDeploy. You may need to have both apps open and make sure the mode in each is the same before you close out DJIgo and attempt to fly.

2 Likes