DroneDeploy app will not connect to Drone

Background: Bought a Mavic 2 Pro a few months ago to map some fields with. DroneDeploy was reccomended as a flight planning software, and I really liked it! I made my first mission, connected to the drone and everything worked flawlessly; once and only once.

It started with my android tablet and cable i was using. I connected to the drone, opened up DroneDeploy and went to fly another mission. I got the error “Mission has been saved, please connect to a drone to fly” I unplugged the cable, plugged it back in and got the confirmation message: “Drone Connected.” Yet when i pressed the button to fly the mission, i got the same error message: “Mission has been saved, please connect to a drone to fly.” I did this several more times until I switched out my own cable for the short cable that comes with the controller. This seemed to do the trick, and my drone flew its mission.

The next time I tried the same thing. This time the short cable did not work either. The DroneDeploy App would tell me that the drone is connected, and then give the same error “Mission has been saved, please connect to a drone to fly” whenever i went to launch the mission. I decided to try my android phone with the DroneDeploy app. It didn’t work right away, but after repeatedly unplugging and re plugging in the USB cable it eventually would connect. This went on for a few more missions. I would get the error, and unplug and replug the usb cable several times in different sequences trying to ascertain the magic combination. It would always eventually work, so i lived with it.

It has now stopped working entirely. The DroneDeploy App will tell me the drone is connected, but that I need to connect to a drone to fly.

Things I have tried:

  • Uninstalling and reinstalling the app
  • Restarting my phone, the controller, and the drone in every possible combination
  • Several different cables, unplugged and replugged in every combination possible, during every stage of startup possible.
  • Clearing the USB defaults
  • The procedure as described in this post: Cannot connect to DJI drone
  • The procedure as described in DroneDeploy’s troublshooting guide: https://support.dronedeploy.com/docs/android-connection-issue
  • Making sure all my firmware and devices were up to date
  • Getting a second Mavic 2 Pro and trying to fly with it
  • Trying the app on a second Android phone
  • Uninstalling every other flight app on my phone
  • Sacrificing a goat on the eve of the summer solstice

I’m at my wits end. I’ve tried different software to fly missions, and none of them work exactly the way I want them to. DroneDeploy was perfect, when it worked. I just want it to work again. :expressionless:

Things that do work:

  • Connecting to any other flight app I’ve tried
  • DJI GO 4

Does anyone have any fresh ideas on this problem?

1 Like

What device are you using?

My tablet is a Samsung Galaxy Tab S4, and my phone is a Samsung Galaxy Note 9.

1 Like

Can you try turning on USB debugging in settings? The tablet is officially supported, but the Note isn’t yet. I would email support and report back here if you don’t get a quick response.

I tried turning on USB debugging on the Tab S4 and going through the motions. I couldn’t find any change in behavior. However there are two potential clues I forgot to mention in the OP:

  • When plugging the controller into my devices, it will bring up the options of which app I would like to open when this device is plugged in. I select DroneDeploy, but DroneDeploy does not open when i do this. It makes no difference if i select “always” vs “just once.” Plugging in the controller will never automatically open the DroneDeploy app. In contrast, DJI GO 4 or Litchi will open when i select them, and then subsequently open automatically the next time i plug in the controller until the defaults are cleared.

  • When the Dronedeploy app is open and i unplug the controller, it will give me two messages. The first is “Drone Connected” and the second is “Drone Disconnected.”

I’ll drop a line to support and see what they think.

1 Like

I had an S3 and remember a similar behaviour. What happens when DroneDeploy is already open queued up to fly before you plug in? Does another app try to open?

Did the problem go away on your S3?

When DroneDeploy is already open and I plug in the controller it prompts me to select a program to open when the USB accessory is plugged in. If i select DroneDeploy, DroneDeploy does not open; same behavior as before.

Support got back to me with an automated message directing me to buy the software in order to receive support. Maybe i’m cynical, but this seems like a common and major issue, and I have just about zero confidence that giving DroneDeploy money will solve it. If the free demo doesn’t function, why would i ever risk paying for the full product? Sorry to rant.

One further clue:

  • I did some testing while inside my tin shed, and DroneDeploy would give me a message about the GPS not functioning until I moved the drone outside again. So it seems to be constantly communicating with the Drone…
1 Like

I’m pretty sure it’s the tablet’s inability to set a default program. There may be a workaround for that. I’ll look a little later when I have time.
I think I might have an S4 at the house.

I could see that being the case if it was just one device, but this behavior persists across three devices: Tab S4, Note 9, and a Galaxy S5 (Which isn’t mine, so i’ll admit I didn’t test it as rigorously as the other two.)

It’s a curious puzzle.

1 Like

Galaxy S5 phone? :expressionless: We know the Note isn’t supported yet, but it may be a good case to actually help support get it going. The S4 Tab is the one that stumps me. What version of Android is it running?

The Tab S4 is running Android 9.

I have some good news. I was doing some mapping yesterday with PIX4D Capture, and went to plug the controller back into the Tablet after changing locations. The options of which app to select came up, and I selected DroneDeploy just for kicks. Nothing happened of course, but when i manually opened the DroneDeploy app for some reason it worked. I am not going to pretend that I know why.

  • The “Drone Connected” message was present on the screen before any of the UI elements of DroneDeploy loaded. I can’t remember if this is normal behavior.
  • This has now worked two days in a row, with minimal unplugging/replugging of the USB cable needed to achieve connection.
  • I recently calibrated the compass on my drone. However I did this calibration several times over the course of my problems with DroneDeploy, so i’m not convinced this was a factor.
  • The Tab S4 downloaded a system update right before DroneDeploy started working. However I have not yet installed this update, so this probably isn’t a factor.
  • No updates to the Drone were done between the time of my issues and yesterday.
  • I am unsure if DroneDeploy released an update between the time of my issues and yesterday.
  • I have not yet tested it with the Note 9 or S5 phone to see if all devices are working.

All in all i’m left confused. I’m very happy this is working, but have no idea what caused the original issues, or what resolved them.

I’ve spent many hours on this problem, and so I think i’m just going to cross my fingers and hope this doesn’t happen again.
Thanks for your time and suggestions Michael.