DroneDeploy App Version 4.4 Bugs

Sh*t!

Flew yesterday and battery issue I’ve been struggling with for months seems to have improved. Massively.

New iPad Pro ‘20 arrived last week, but haven’t managed to find the time to apply the screen protector and set it up. That and find a suitable case.

I needed to carry out a mission yesterday at short notice so flew with the older Pro ‘17. Somehow, it flew 3x DD drone batteries and a fourth in Go4 and had 39% iPad battery left. I thought it odd and asked myself WTF? Was very confused, asking myself what did I do differently than last time. “I turned it off to travel to the site. That must be it. It couldn’t have been an update as I turned updates off.”

Just noticed somebody having problems with their Inspire and V4.4 here in the forum. I again asked WTF and raced to the App Store where sure enough, a new version had been released and my Pad had already auto-upgraded. Meaning I would likely have been on V4.4 when I flew yesterday. I thought I had previously turned all updates off after it caused me so many problems, but seems not.

Whereas the battery has definitely improved, it’s not perfect, but it’s certainly manageable. I would have been able to get a good 6x drone batteries out of it had I needed as opposed to the 8x I used to. Maybe a small amount of loss is due to a now one year old iPad battery.

There is still a bit of lag for the first few seconds of starting the mission (from the air), but other than that, worked okay. If I was to be critical, I would say that it is frustrating that the drone travels to the first waypoint of each battery at its snail-pace mission speed and not at its ‘whizz there quickly’ speed. Travelling to the first waypoint at 4m/s is not the most efficient speed to be travelling at when every mAh of battery is gold dust.

Now, what the hell do I do with the Pad ‘20? Keep quiet I think. An unnecessary expenditure like that in this climate will get me into a lot of trouble.

1 Like

There’s no doubt we use to get more battery, but my P4P RC doesn’t even last that long. I can usually get through a day of 6-7 batteries and that’s it.

For sure this has been mentioned before! I think the problems lies in the fact that the mission is a package of waypoints from Takeoff to RTH and the DJI SDK is not allowing separation of the travel to the first of from the last waypoint. I usually manually fly there, run the mission and RTH home or manually fly home. I like to fly because there is no telling what you are going to see on the way that you want to capture. If you plan your batteries right this can actually be more efficient.

I’ve been spoilt. :). Once the new Pro is up and running, I’m fully expecting to get my 8x batteries back.

I’ve been tempted to do that before and I’m sure I have, only I’m also convinced that when I have, it treats that ‘start mission position’ as home. I am certain when it’s got to the end of the battery or finished the mission, it flys back to that start mission point and it freaks me out “YOU’RE GOING THE WRONG WAY!!” Maybe not at the end of the battery, but certainly at the end of the mission. If I were to drop dead mid flight, I would like to think it wasn’t going to land where are started but rather, where I took off from.

I’m also certain that it didn’t used to fly to the first waypoint at the mission pace. It might have been some time ago, but I do remember the days where it used to whizz out to the first waypoint quickly and zoom back again. Something’s changed.

The other thing that I think may have gotten worse, is that when it finishes the ortho mission and wants to begin the perimeter route, rather than just start from the same point it’s at and then work it’s way around, it decides to use up 20% battery making its way over to the complete opposite side of the mission and start there. It used to do it occasionally and I recall DD acknowledging the bug a couple of years ago and looking to iron it out, but I now find that it it’s doing it most of the time, not just occasionally. Has anyone worked out a way of manipulating it? Forcing it to take a more efficient route?

Home should be whever you initially took off from until the unit is shutdown and turned on in a new location or if you manually set it. Did you change anything in DJI Go 4?

This is correct and looking back through posts I brought this up in Feb. of 2018.

@Andrew_Fraser, I know you haven’t been on the forums that far back, but have you heard an updates to the issue with the drone not being able to fly near full speed to the first and home from the last waypoints?

Try changing the direction of your flight. Looking at the estimated time move the slider slowly until you get the lowest duration. I have found that the AI has gotten better at setting it up, but I can still usually pick up 30 seconds to a minute by looking for the optimum. All the program does is align to the longest possible leg.

Thanks for facilitating the conversation @MichaelL

We expect to increase speed commuting to Plan start location in an upcoming 4.5 release.

Separately, we’ve identified further performance improvements that will help with battery consumption and will be released within the next month or so.

Thanks

2 Likes

No. Go4 has always had RTH set up to return to where it took off from. Have never changed it to anything other than and always performs as it should. It was a while ago I last tried it, but I am absolutely convinced beyond doubt, that when the the drone took its final image as it completed the mission, it tried to return back to where I initiated the mission, which was some way from where it took off from. Scared the life out of me as it was so unexpected and so haven’t tried it again for months. Years. Maybe not the battery swap outs, but definitely the end of mission. It returned to where the mission was initiated.

Christ. Was it really that long ago? I started using DD in July 2017 I think, and remember showing it off to my mates at the time. They’d watch it fying up and down slowly and were always astonished how quick the drone returned when it was to time to come home.

Yeah, tried that and it does make a difference, but when we’re dealing with the wind at altitude, we’re sort of tied to both flying perpendicular and along with it, if that makes sense. Only gives an option of flying in one direction therefore.

I will definitely try this when I fly again tomorrow. I wonder if the Go4 brains take back over when not in a mission and out of P-Mode and when DD takes over it thinks it is at home…

For sure it doesn’t seem like it was that long ago when it came up.

It would have to be some pretty hefty winds before I worry about that. Once it gets that windy I prefer not to map anyways. Sustained at 15mph is just fine, but when the gusts hit 25-30mph then I start asking myself if it is really necessary today. The Yuneec can go a little stronger, but sometimes you just can’t win. When you are building a subdivision called Crosswinds you know it’s going to be fun. :astonished:

James, one explanation is that it is easy to be comfortable in your workflow and not always notice every detail. There is the possibility that a gps lock had not occured yet when you lifted off but had happened when you initiated the mission. So for that mission, “home” was where you initiated, not where you lifted off. Ask me how I know this! :thinking: :innocent:

Hi Dave. That would make sense, but definitely didn’t happen.

Using a Mavic with the notorious DD focusing problems (that still exist BTW), I have to take off in Go4 first and then initiate the DD mission once set up in the air. Without exception, I take off having ticked the additional ‘Precision landing’ box when swiping to take-off. The only way this additional box appears, is if Home has been locked. Usually takes an extra few seconds to get sufficient lock on a dozen or so satellites.

Another reason I know GPS had been locked, was because to override it flying in the wrong direction, having completed the mission, I hit the RTH button on the RC and it came straight back.

I might try it again on my next mission. Just for the crack.

1 Like

That brings up a different point that it could be DroneDeploy itself that is resetting home due to the interaction with DJI Go 4. If you can system RTH and it comes back to you right? Maybe try flying to your first waypoint with DroneDeploy Manual Flight, take a nadir picture and restart DroneDeploy to start your mission?

For the last 2 months I am finding that the telemetric data along the bottom of the screen is freezing.
Battery,HD etc on top is fine as well as drone icon movement.
I have tried reloading the app - fine for first flight then freeze again.
I am using an iphone XR.
No problems with pix4dcapture or litchi using same mobile device

2 Likes

I too am having loss of telemetry. Mine is inconsistent and not isolated to any particular flight plan type. I was waiting to report that it was happening again until I had enough flight data to work with, but here @pauldrone is!

1 Like

Latest problem: in areas with no wifi connection(most places here) the saved missions do not appear!!

1 Like

If your device doesn’t have service could you try to get them to populate when you are at the office/home on WiFi? Or do they show up there and disappear?

Yes. They disappear out in the field.

1 Like

@Andrew_Fraser, any ideas? It doesn’t seem that his missions are truly caching to the device.

A new problem today, insofar that the mission tried to resume after the first battery change, but from the beginning of the mission.

The app recognised how much of the mission had been carried already and where to resume it from, but then insisted that it be started again when clicking ‘Continue Mission’. I tried a number times, wasting 30% of a battery, before giving up and starting a new mission.

All in all, the workaround probably added an hour onto the task and two batteries by the time I’d had to add the perimeter onto it separately, using another separate map.

1 Like

Having very similar problems. Working on iPad Mini 4, so older tech. I always check the bird with DJI between batteries. So closing DD and then reopening after check. Have many times where app just spins, as if waiting for a download. Even when I have projects set to be available offline. Stuck at that point. Can’t change devices to continue mission because mission data hasn’t syc’d with server. Just stuck out standing in the field.

How are you managing to use the larger display ipad with the controller. I want as much display area as possible but can’t juggle loose devices in my hands.

1 Like

10.2 just barely fits with the clamp fully extended. I’m not sure what version of DD you are on, but don’t miss the 4.6 and 4.7 threads.