Dronedeploy and DJI GO running together

I’m new to Dronedeploy.
I have done a few tests with Dronedeploy and I get several blurry photos.
I would like to set the shutter speed at 1/500. To do this I need DJI GO
Is it possible to run Dronedeploy and DJI GO at the same time ?

I have tried to first launch Dronedeploy : the drone is connected. I then launch DJI GO which does not recognize the drone.
If I launch only DJI GO the drone is connected normally.

I there a procedure to make them work together ?
Thanks for your help.

DJI Phantom 4 Advanced
Samsung Note 4
Android 6.0.1

I have yet to use DD but as I recall, you need to start with DJ GO, then switch to DD. FYI, I am using DJ GO 4.

Hi @dakota77,

Thanks for swinging by the DroneDeploy Forum. Are you seeing any error messages? If so, what do they say?

I also recommend taking a look at our Initial Setup for DJI Drones or Troubleshooting for DJI Drones support pages.

Keep me posted,

I have still the same issue : I would like to set the shutter speed at 1/500.
I first connect the drone with DJI GO.
I set AFC and shutter priority to 1/500s
Exit DJI GO and run Dronedeploy.
In the mission parameters I have set : “Set Exposure manually in DJI GO” and “Set focus manually in DJI GO”
I would prefer the option “set shutter speed manually in DJI GO” but this option is not there…

The result is that the first photo has been taken with shutter to 1/500s. But the next photos are taken with variable Shutter speeds : 1/800s, 1/2000s and of course are not good.

My question : how can I set the shutter speed to 1/500s for the the all Dronedeploy mission ?

HI @dakota77,

You can adjust your shutter speed settings in the DJI GO app and those settings will transfer over to the DroneDeploy app. Here’s a DJI guide on camera settings that you might find helpful.

Hope this helps!


Hi Stephanie,
Thanks for your reply.
I set the shutter speed settings in DJI GO
But the problem is that Dronedeploy seems to not take care of settings which have been set in DJI GO.
The resulting photos have different shutter speed settings.


Hi @dakota77,

Can you share some more info?

  1. What is the email address associated with your DroneDeploy account?
  2. What is the DroneDeploy app version installed on your Android device?

Thank you,

Thanks for your reply.
Dronedeploy version is 2.66.0

Hi @dakota77,

Can you update your DroneDeploy app via the Google Play Store to the latest version (2.67.0)? If the issue persists after the update, let me know.


Hello Christina,
Thanks for your reply
I have upgraded to version 2.67.0 but I can not test in flight now as we have bad weather here.

But I would like to know what I must exactly do :
I want that Dronedeploy uses the shutter speed of 1/500.
I set it into DJI GO and I set Autofocus on AFC.
Then I close DJI GO application and run Dronedeploy.
In the Dronedeploy interface is it necessary to select : “Set exposure Manually in DJI GO” ?
To avoid confusion it would be clearer to have an option : “Set shutter speed manually in DJI GO”.
Thanks for your time.

Hi @dakota77,

If you want the settings from your DJI Go app to apply to your DroneDeploy apps, you’ll need to have both ‘Set Exposure Manually in DJI Go’ and ‘Set Focus Manually in DJI Go’ toggled on. The app update should fix the issue you were experiencing with the settings not sticking, so please let me know if the issue persists after you’ve tested a flight on the latest app update.


I have upgraded to version 2.67 and have done 5 photo missions with Dronedeploy with different shutter speeds.
The shutter speeds defined in DJI Go are correctly used by Dronedeploy.
So it works fine now.
I have another question which will be posted in a new topic.

Thanks for your support

Great to hear the issue is resolved, @dakota77! I’ll mark this topic as closed.