Drone not taking off


I’ve just started to use the DroneDeploy App but am running into a few problems from the outset. I have a P3P (Firmware v1.9.60; RC v1.80; DJI App 3.1.0) with a Samsung S5 mounted on the RC. Everything is uptodate and I am clearing defaults when I switch between DJI Go and DD apps. I always used the first before testing a mission to calibrate the compass and check firmware/GPS signal etc.

When I plan a mission on DroneDeploy it tells me that there is a drone connected but once I have set up the mission and saved it, there is no aircraft symbol - just a save symbol. I thought this may be because I was running a test before I trekked into the field. However, once in the field the aircraft symbol did appear and once pressed it ran through all the pre-flight checks then…nothing. The drone sat there and the DD App ran the simulated flight. I should add that i used a mobile Wifi Dongle so that I could see the Google Earth map as a base to get my bearings and plan the mission.

Any help would be most welcome as I am losing time with my free trial.



Did you close the DJI go app before opening the DD app? I only have connection issues like that if DJI is still running in the background or when I open DD before turning the P3 on

Hi Joey,

Thanks for getting back to me. Although I had previously uninstalled defaults with DJI after my first calibration check prior to flying a mission and before running DD, the problem seemed to persist. However, I have since discovered that it is best not to touch the DJI app at all and trust that DD will do all the calibration checks, detect satellites, confirm connection to drone etc. I was being overly cautious when using the software for the first time! I tried this approach today with success. If the Tablet opens already plugged in to the RC and the drone turned on then it automatically went to DD and worked. Mission success.

There was a moment when nothing happended on my second flight but this appeared to be down to a cold battery. After warming it and rebooting everything everything worked fine.

I am now very pleased!



1 Like

My P3A did not start last week, all checks confirmed. Closed app & went back to DJI app, notification that craft was warming up - battery was too cold, put it under my arm for 10 minutes & then all was ok.

Hope this helps :slight_smile:

Hi Jean,

I had the same problem the other week. Stuck my battery down my jumper but have now invested in a gel pad which I can keep in my pocket with the battery until take off. It makes flying more comfortable!

Kind regards,



New user here with a Galaxy Tab E and a P4. I made certain the DJI app was off before trying to fly mission. Everything looked like it was going right through the pre-flight checks then no lift off after pressing “check”. The outside temp is 52 F . Did anyone notice their battery temps before manually warming them? Curious. High tomorrow is only 39 F so I doubt I’ll fly. Should the pre-flight checks even pass if the batteries are not within a certain known temperature limit? Maybe an additional check for the app next revision.


Hi Don,

I had the same problem on a very cold morning (air temp was -2.5 celsius!). I found it took a while to load DD, plan a mission and select waypoints, all the time the battery was getting colder as drone was on to allow connection. When I ran the checks it gave me a green tick but then no lift off. I just changed the battery on my P3 and ran the checks again. Hey presto immediate lift off.

I didn’t check battery temps before I flew but on the following morning I flew using DJI Go app in similar weather. Once everything was set up (Calibrated compass, GPS signal checked) and I swiped screen of tablet to take off…nothing. I got an alert saying battery too cold. I’ll monitor it for the future.

39 F seems pretty warm to me!

1 Like