Drone Deploy will not open on Ipad

When I am in the field or even at home, the DD app takes forever if it even opens up at all. I have blazing fast wifi at home. I use my cell to give me a hotspot. Sometimes it opens up, lately it just spins and spins.
I recently updated it in order to pull the logs off the ipad.
That seems to be when it got much worse. HOwever, prior to that is was pretty challenging to open up.

Even at home it will not open like it should.
I have uninstalled it and reinstalled it.
Still the problem persists.

Here is the info on my pad.
iPad 5th generation
Model MP2F2LL/A
Software Version 14.2


Same here 3 out of 10 times over the past two days with an 8th Gen iPad. I don’t know exactly what got it to go through because I was in a hurry to get the job done, but I got it to work once after rebooting the iPad and the second time after connecting it to my phone hotspot even though the iPad has service itself. I was in an area that had a pretty flaky signal.

Normally I have never had a problem. I have uninstalled and reinstalled, done with and without WiFi (hotspot). Even at home it still sometimes opens and sometimes does not. I mean after 5 minutes it still had not opened. I have tried with a newer Ipad, and it opened but still kind of spun around for a while. Wondering if anyone else out there is having problems.


Hey @DroneboyBill, @MichaelL, we’ve found the root case for this and have a fix targeted for 4.29.0. We hope to have it out next week at the time of this writing.


Hey @DD_Alex, that’s great to hear! Thanks to you and your team.

I just realized how much this has been affecting our field Supervisors… I have gotten 12 calls this week and talked to a few others in the field about how unusable it has been over the last month. It’s probably the worst for the field as they are in allot of areas with sketchy connectivity. Hard to get consistent use with things like this going on.

Yes I too have the same problem. Takes forever to load on my ipad.

1 Like

Hi, @DD_Alex!

DroneDeploy 4.29.0.

The project loading time in the complete absence of the Internet is 10-12 seconds (Wi-Fi is disabled, the SIM card of the mobile network operator is removed).

If the “Avialable Ofline” option was enabled, the project and the terrain map are loaded. If the “Avialable Ofline” option was not enabled, only the project is loaded.

It is not yet possible to check in operation, the outdoor air temperature during the day is -22 °F (- 31 ° C).

iPad Pro 10.5 2017

Apple iOS 14.2

DJIGo4 Version 4.3.40

Best Regards, Sergey

1 Like

Any update on this issue? The app is virtually useless on the ipad (6th gen) IOS 14.2

If/when it actually opens it takes 15 minutes to type out my email to log in. What is going on?

Edit to clarify - its useless when connected to WiFi. Turned off wifi, entered my email/password, reconnected wifi, could finally login but only to watch the “Refreshing Dashboard” wheel spin for 5 minutes. Please update!

1 Like

What version of DroneDeploy? And what drone?

Ours have been much better as of late, but we experience similar issues and have made it part of the workflow that the app gets opened before anything else in the operation. We are running an iPad Mini 5 and an 8th Gen 10.2, but I have a 6th Gen as well and it is on par with the Mini 5. We have also made it protocol that WiFi is always off in the field, but we have service on the tablets themselves.

Another thing that has helped a little is changing the view of the project list from thumbnails to a list. There’s nothing we can do about the Quick Access and I would be willing to bet that running geolocation to sort that list has a good bit to do with the lag.

Login is a whole other issue and I don’t know exactly what it is trying to do there. On ours it typically only happens when there has been an update, but as it happens I had to login on both devices today and I didn’t keep an eye on the version so I don’t know if it was actually an update or not. They are currently on v4.29. Despite that just the normal app opening does stall.

@MichaelL DD should give you kickbacks for as much trouble shooting and support as you do on here. Appreciate the help, again!

DD version 4.29.0, Mavic 2 Pro

The issue seems to be directly related to Wifi. When Wifi is on/connected, the app opens and freezes 7 out of 10 times. If I let it sit long enough it will let me enter my user/password but each character takes about a minute to show up, then I can type the next. Turn Wifi off, app opens, i can enter my user password, then go back and turn Wifi on, back to DD and hit login. This is pretty much the only way it works if prompted to login.

We did stop cell service on the drone iPads 6 months ago or so, will definitely reconsider that but IMO DD needs to fix the WiFi issue, which pretty clearly was not fixed with the 4.29 update as mentioned above.

When you say change project view, you mean revert back to the old interface? We actually prefer the old list type interface over the new thumbnail version. Would like to see the thumbnail update removed to be quite honest, its not helpful.

Thanks again for the help!

1 Like

Haha, they take good care of us!

Even with data on the iPad the WiFi seems to cause part of the problems. I think it may have something to do with the fact that there are two sources fighting each other and the iPad defaults to WiFi whenever possible so it is constantly searching for a source to connect to. It seems that when everything is loaded that it doesn’t matter so much, but that initial opening suffers.

Totally agree. It was even worse than it is now back when v4 was released and they made some headway around v4.25, but it seems to have gone backwards a bit.

No, in the new interface there is a view option underneath the Quick Access bar on the right. It will put you back to list. Problem is that it doesn’t seem to default to it all the time and I haven’t figured out why. @Anjanette_Hill @Jamespipe @Andrew_Fraser

It still has small thumbnails, but they load faster.

1 Like

Could be. The odd thing is we have cellular data turned off so the only source should be WiFi.

Also going to check with our IT folks on the on-site wifi. Haven’t been able to repeat the issue in my office this morning. Even when logged out of the app, close out, log back in while on WiFi it works fine.

The only thing that I can think of is yesterday was the first I logged in since before the holidays, maybe the time between logins plays a role.

1 Like

That was going to be my next suggestion, good thinking!

This too. Not all WiFi networks are the same. Some things work on my home WiFi that struggle in the office… and then you have the whole WiFi from a Hotspot in the field.

Typically I have never had an issue. I have uninstalled and reinstalled, finished with and without WiFi (area of interest). Indeed, even at home it still some of the time opens and some of the time doesn’t. I mean following 5 minutes it actually had not opened. I have attempted with a more current Ipad, and it opened yet sort of spun around for some time. Contemplating whether any other person out there is having issues.

1 Like

Hi @William4170 , welcome! What devices and software versions are you running?

Not sure it is the answer but it seems now that on the Ipad, I have that, if the version is out of date, ie needs updated then the App will many times not open or not allow you to login. Even with the auto update turned on it seems I have to go to the App store and force DD to update to get it to work. I only use the Ipad for flying our drones and am an android user for everything outside of that so my knowledge base is limited when it comes to the Apple products and functions.

1 Like

I have had this problem ever since v4 was released.

Occasionally I have trouble logging in on my iPad and previously, I have been able to reboot the iPad once in the field and the app would then allow me to log in. Automatic app updates is deactivated, although interestingly, it does still log me out occasionally.

Yesterday however, I had to restart 3 times before it would allow me to log in. I did wonder if the time had finally come where I would now be FORCED to update the app to proceed, and had it not worked on the third or fourth attempt, I would have done it. Grudgingly. Thank God it eventually worked however. Still on V4.4.2.

Using an iPad Pro 11 2020 Cellular with latest available OS (v14.4), albeit was using WiFi at the time of logging in

Logging a user out the app is a bug (programming error) unique to DD. It’s nothing new and has been there for years. By contrast, DJI GO/ GO 4, Litchi and Map Pilot never log you out unless you log yourself out or delete and reinstall the app. It’s probably part of DD’s buggy server query loop that is the root of many of it’s problems that the DD engineers can never seem to tame. Sorry for my frankness, but it is what it is.

1 Like