Drone Deploy only loaded 1 of 14 uploaded images using Inspire 1 X5

Hi Guys

I tried Drone Deploy for the first time today. Im using a Inspire 1 Pro with the X5 camera. Everything worked as planned on the test flight, apart from the images not automatically downloading to DD. Therefore I uploaded the images manually on DD; but for some reason when I tried to view the Ortho Map on DD after it had processed, it only showed 1 image of the 14 images it showed to have loaded. As a newbie Im sure Im doing something wrong but can anyone help?

Flight Number 1454627044

Did your map end up stitching? If so, it could just be a bug with how we show how many images uploaded.

It looks like the map ended up stitching fine. I think we do know about the issue with the incorrect photo count sometimes. Should be fixed soon.

Thanks for the feedback.

Quick question. Using the X3 & X5 there is a slight amount of fisheye effect from the lens; certainly the X3. Is it worth tuning these pictures through say Lightroom software to remove the fisheye effect before uploading them? Would that improve the clarity at all and accuracy of results or does the software automatically remove the lens Profile Corrections?


I’m not sure if the amount of fisheye in those cameras would cause an issue. You can certainly try it and upload a set to see if it improves things.