Drone Deploy on Ipad Mini 2 issues

I have drone deploy on an Ipad Mini 2 with wifi. However I have used Pix4d capture app for the past 2 years instead. About 6 months ago I tried using Drone Deploy to only be met with connectivity issues. I have a Phantom 3 Advanced.
Also I noticed none of the icons displayed on my screen. So I deleted the app and stuck with Pix4d.
Fast forward to today and I find the same issues.
When I create a map on drone deploy, it syncs with my ipad no problem, I have the option to use the map offline, so i did that.
But when Im in the app, there is still no icon in the bottom right hand side buttons. Even out in the field the take off button never displays the icon of the plane, Its just a blue button, and above that a white one.

Today i set the drone up, waited for it to connect, then hit the bottom right hand side button.
The drone took off and flew the mission.Wow I thought, its working!
However, i noticed there was no video feed screen in the top right. And upon getting the drones SD card into my laptop, there were no pictures taken…That was aggravating.
I returned to the field, tried to connect to my P3A and nothing.

So i got fed up and used my Pix4D app instead.
I think im done with drone deploy. To many bugs, always some issue on screen, with something NOT displaying - ie the buttons icons.

6 months since the last time attempted to use it and its still in the same condition as when I left it?!
Thats too bad, was looking forward to trying something different.

Hi Macenroe82,

I am very sorry to hear about your experience. For me to better help you, could you the items below:

  1. Verify the iOS version that you are using on your iPad Mini 2.
  2. Verify you are using the latest version of the DroneDeploy app.

A common reason why a drone does not take any pictures can be related to the SD card. Please follow the directions below and let us know if this helps:

  1. Format SD card in DJI app.
  2. Take a test photo in DJI app (do not delete it leave it there).
  3. Close DJI app & open DD then run the pre-flight check and fly.

Hello Nipul,
Thank you for the reply.
And sorry for my very late reply.

I was thinking of giving DD a try again today.
I will follow the steps you outlined and let you now