Drone Deploy lost drone

Doing my first ever flight with Drone Deploy. did a small area (1 battery, 185 pics) for test. Flew the perimeter first to check that range was not affected, max range was 600m. Landed drone, replaced with 100% battery and launched DD. started well with first leg completed without problem. second leg lost reception. was not worried as I thought it would continue. After a few minutes got worried and switched to DJI also no signal. Switched back to DD and hit “home”. received message that drone was connected and it was coming home. Drone did not return home. Switched back to DJI but no contact to drone. Drone did not return.
We searched for a few hours but it is dense forest and we didnt really know where to look. A surveyor said he saw the drone hover over him for a few minutes, before heading off to the north, and not returning. Home position was to the south of his location. I am pretty sure they will eventually find it as they are handcutting the forest there over the next couple of weeks.
It was a Mavic Air. I have years of experience on drones and about 10hours on the Mavic. never had a problem with return home or reception at 600m before. Looking forward to any assistance anyone can offer.

1 Like


Thank you for reaching out on the forum to let us know about this situation. We take these situations incredibly seriously, as our success depends on yours. A missing drone is never a pleasant experience and I want you to ensure you that we will provide our best support in order to assist you.

Historically, all flyways and crashes that our team has investigated have been due to DJI hardware or SDK bugs or issues. We are happy to help try to pinpoint what went wrong by sending the logs to our flight engineering team. With that information, we’ll be able to direct you to the proper DJI channels for as smooth of an experience with them as possible.

I would also be more than happy to hop on a phone call to gain more insight and information on your missing drone. In the meantime, could write into support@dronedeploy.com? If you could, please email us the the flight logs. Being able to view the DroneDeploy flight logs will allow me to further analyze your fly away and will probably be able to help us find the last recorded location of the drone.

In order to find the flight logs you will need to connect the mobile device you used to your computer and find them within your DroneDeploy files. To do this please follow the instructions listed on our Gathering Flight Logs support documentation. Look under Accessing logs directly off the mobile device.

Thank you and please do reach in the meantime with any questions and I will be more than happy to further assist. Looking forward to speaking with you.

I’ve had two similar experiences in which both drones were wrecked. I have a thread about it as well.


Similar issue where it did not return to home when it lost signal both times.

1 Like

I’ve had a similar experience using DD where the Drone P4 pro V2 was on return to home and lost connection.
Found the last known location by retrieving the flight log off mobile device. Eventually found the drone in dense forest luckily and deduced the reason was an automated landing because of low battery power. Final conclusion is to not trust DD power management unless conditions are perfect. Any kind of breeze can change power consumption markedly and you need to consider that foremost when setting the parameters for a flight plan or managing in flight.

1 Like

Hi ! Had the same experience a few months ago in a Mavic air as well. Thankfully It happened on an early corn field so I was able to find the drone using its last gps location on the dji app. Its pretty straightforward, have u tried it yet ?

1 Like

So even if the DD app indicates there is power it might actually be very low?

That’s scary.

Just throwing it out there, but a lost connection could happen from hardware failure as well. The only two drones I have crashed in the last two years were both hardware (1 battery / 1 GPS) failures. If you don’t find the drone and run the logs then how do you know it was DroneDeploy’s fault. I got into a bad spot last week where I thought I had a good vantage point and at one extent I lost it for about 30 seconds. Green screen and no DroneDeploy feedback. The drone continued on it’s waypoints until the connection restored.

Does it matter who’s fault it is though? Just that you’re out two drones. It would be in everyone’s (DD, customer and DJI) interest to resolve these issues.

In order to resolve issues you have to look at it from different directions. This is obviously not the first time this has come up so I would vouch for them that they have not been able to find any causes in their systems. This is obviously the place that people come when it happens and in my experience is that it’s usually because they think it is DroneDeploy’s fault.

The “it lost connection” and “couldn’t find it” is a pretty good indicator that there either wasn’t an observer or it was out of VLOS. Obviously there was no visual control.

Most likely some of these incidents that involved the drone “landing” in place on the way home are due to “smart RTH”. It is critical that operators completely understand what “smart RTH” means, and what can go wrong while using it. (It is on by default). It is much safer to monitor the battery closely and do not push it. It would be great if DD displayed the lowest cell voltage in addition to the % (@Adam_Carp :slightly_smiling_face:) . It is available in the sdk because Litchi will display it as an option.

1 Like

I just finished mapping 1000 ha with my mavic 2 pro and DJI Groundstation. I’ve tried both the pix4d and dronedeploy flight software with varying amounts of success. Groundstation just works every time. I wont be going back.

1 Like

I had exactly the same problem! The drone was max 300m away from me, second battery went in, feed stopped, app crashed, DJI app just said the drone was at point of take off which it wasn’t because I was at point of takeoff… on an open field. My drone never returned! £900 down the drain and not a whisper from DroneDeploy!