Drone Deploy destroyed my new P4 pro on its first mission!

I just purchased my P4 pro with obstacle avoidance technology…
With the DJI app it worked perfectly!
I did a couple of test flights and then I planned a mission and commenced to fly using Drone Deploy.
It took off and commenced to fly towards its first waypoint - all good.
Then we noticed both visually and by Drone Deploy app that it was hovering near a tree.
Great the obstacle avoidance appeared to be working.
Pressed the red button on the Drone Deploy app to bring it home…
Drone Deploy then decides to land the P4 there into the tree!!!
Thank you Drone Deploy for destroying my drone.
I haven’t been able to recover the drone as it is in an inaccessible area.

I guess I should be using something a little more reliable and dependable than Drone Deploy.
One lives and learns but to loose a $3k drone on its first job flight is a bit much to handle right now…

Drone Deploy support came back to me and blamed “hardware fault” - what nonsense!

Surely Drone Deploy should be learning from issues to perfect its software!

To make matters worse Drone Deploy took no flight log data whilst it decided destroyed my drone.

The red “return to home” button on Drone Deploy should be renamed ‘press to destroy my drone’.

I know I’m not an employee of DD but this is still very sad to hear. Something similar happened to me during my first “actual” test with DD- alas I knew there is no fighting something like this. I sadly lost a Phantom 3 in a battle with a 40 foot cedar.

Also from a developer standpoint, work on a project like this would never be possible if they themselves took liability for everything that happens while using it.

I recommend when testing any new software OR hardware that you test it in a grassy area where a crash and recovery is possible with minimal damage.

What a load off nonsense.

Fancy you putting this guide up after Drone Deploy destroyed my drone.

… and yet now Drone Deploy blames me, blames DJI and blames…

Surely you guys need to get your act together and issue decent instructions on how Drone Deploy actually works before people use your app?

Thanks Brody

The sad part about is that I conducted various test flights including a test flight at the site using DJI app.
Everything was fine.
It wasn’t till I flew using DD that I had to say goodbye to my P4p drone.

DD needs to better communicate that its app/software is in the very early stage of development, that it apparently totally relies on DJI app for flying and that every flying and camera parameter within DJI app must be checked every time before closing the DJI app and firring up the DD app.

It is in reality a totally dodgy app that should not be released to the public in the form that it currently is…

1 Like

Hi whistleboy

Similar questions from me but no more - enough is enough.

Thanks to Drone Deploy my P4p flew off never to be seen again.

Drone Deploy is just nonsensical and support is no help blaming DJI for everything.
Their tutorials, webinars and other “documentation” is way below standard and totally lacking logical run through any process.

“Long winded and inconclusive discussions” - this is very mild compared to my conclusion on Drone Deploy

The way I see it is too many people have their hands in the pot. If you have different people making each separate part it leaves a lot of room for error.

Nine times out of ten if something goes wrong I turn everything off (including the drone, controller, and all software loaded on the iPad) and this is due to the fact that you never know if the hardware on the controller is buggy, or if the update you did on the controller a day ago isnt communicating with the new update on the DJI software or the DroneDeploy software.

Until DJI starts communicating with the 3rd party developers better, and the 3rd parties start being more open as to what’s not working and what is currently in the works instead of brushing their issues under the rug so that they don’t lose customers, the entire system will stay broken.

We are, in a nutshell, their test dummies for all this new technology.

Hi @Daniel777,

I am sorry to hear about the incident with your P4P. DroneDeploy doesn’t take something like this lightly and we will help you gather any information needed. I have replied to your email in response to some of the comments and questions you had.
We also recommend referring to the DroneDeploy Pilot Policy which describes how DroneDeploy works with the DJI SDK.

Please let us know if you have any questions
Thank you,
Nipul

that’s great advice Nipul!!!

After Drone Deploy flew my drone to destruction I now get your advice to “refer to Drone Deploy Pilot Policy”.

I’m sure that is going to help me heaps!

The questions I have have been emailed direct to Support who had the gall to tell me that the issue was a hardware fault! May I suggest that your issue at Drone Deploy is the illogical set out of the numerous advises you offer without a basic summary of how Drone Deploy works.

The email you sent me gives advice that is contrary that that provided by Zach in support.
You guys really need to get your story straight before offering suggestions on how your software works.
Or is it that you don’t really know and are just making up stories as you go along.

I have asked for management at Drone Deploy to contact me however it appears that Drone Deploy is not really that interested in what they did to my drone…

If Drone Deploy in their first initiation advice to anyone using their software advised the user that Drone Deploy does not control anything then perhaps the user may make a well considered decision whether to risk using your dodgy software in the first place.

Hi @Daniel777

Nipul is actually management.

Looking st your described behavior I can guess what happened. Like you said the obstacle avoidance kicked in and stopped the mission. If you click return to home in the app or the RC the drone autopilot takes control, not dronedeploy. If you are within a certain radius (20m) of your home point the drone will simply land. This is the behavior DJI has programmed into its drones autopilots as you can see in this post: https://forum.dji.com/thread-15059-1-1.html

Sorry to hear about this.
Chase

Thank you @chasemgray for providing those details.

Hi @Daniel777,

I apologize for the frustration. At DroneDeploy we try our best to educate our customers on how the technology works between DroneDeploy and DJI. We know that crashing a drone is anything but a satisfying situation.
I am happy to have a call to help you or discuss any questions you may have.

Thank you,
Nipul Roy
Manager of Customer Support

Thanks Chase.

The drone I was flying was a P4p that I used to have but no longer…
I am slowly gleaning information from all sources and slowly learning what may have happened.

It is very frustrating from both DJI and even more so from DD with the lack of clear concise instructions on how their systems function.

From what I can gather DD does no flying at all, even though their various webinars, instructions and the app itself clearly give the impression that it does. I can only guess that DD try to justify their app plan fees by giving the impression that their app flies the drone as well. If the DD app does no flying then why is there a launch button on the DD app. If it was rationally presented then the launch button should initiate the DJI app for flying purposes as apparently that is what it does.

Why does DD not clearly state from the outset that all flight parameters are set within the DJI before any flight can even be contemplated from the DD app? At the very least the DD app checklist that pops up after pressing the launch/flight button should take you to the DJI app for setting flight parameters before returning to the DD app for the flight plan screen… or some variation on that theme. It is simply very poor programming with illogical implementation by the DD software developers.

My issue is that the DD apparently utilised the DJI return to home parameters which had a return to home fly height of 30 metres whereas the DD fly height in the flight plan were at 78 metres. How illogical a process is that?

I had specifically set the Fly height in DD to 78 metres to avoid the obvious trees and yet DD app hands over control to DJI app which by default had a return to home fly height of 30 metres.

That was the reason for the loss of the drone.

Then more stupidity, this time from DJI, kicked in.
Upon realizing that DD had intentionally crashed my drone by handing over to DJI flight with flight parameters that were at conflict with DD flight parameters I closed down the DD app and opened up the DJI app.
The camera vision was streaming back to the controller.
It showed an upside down view.
No GPS signal, as apparently the GPS sensor is at the top of the drone.
Therefore no location ability whatsoever.
The battery eventually died.
Why does DJI not power down the camera function in this situation and fire up a location high pitched siren?
Why does DJI controller not have a location function working off the wireless radio connection between the drone and controller?

Anyway more stupidity, this time from DD, become apparent.
DDapp flight record only recorded the take off point so no way to work out where my drone was from that…
And, if as DD states, that DD hands over all flight functions to DJI app then why is there absolutely no record within the DJI app of the DD initiated flight - no photo images (understandable as it was still to take its first photo of the mission) but no record of the flight at all. I suspect that DD is covering up something that they do not want us to know about…

You see I had taken all sensible precautions before that first DD flight.
At the site I conducted a test flight within DJI control, took off and landed to check the drone functionality and to check the camera settings as instructed in the DD instructions - that part DD got right - DD clearly advises that camera functions are set up in the DJI app. Everything worked perfectly… That flight record is recorded in my DJI controller/app.

Then over to DD… no flight record no nothing.
DD conveniently refers to “hardware failure” in order to cover up the illogical DD documentation and DD software functionality.

And now Nipul from DD is offering to discuss questions that I may have!

Really the only question I have is -

why does DD produce and promote such illogical and poorly written software (along with illogical and poorly written documentation).

Sorry to hear about your incident.

I think though you are unfairly blaming DroneDeploy for pilot error. The information Chase mentions is also very clearly documented in your P4P manual that came with the drone.

The DroneDeploy app, similar to the DJI Go 4 app, is provided for free as a way to help users fly their drone in a way that will work the best with DroneDeploy’s map processing software. The charges for DroneDeploy are mostly for the processing of maps, storage of the resulting assets, and access to the UI which allows you to analyze, export, and share the results.

I put together a diagram of how DJI Go 4 waypoint mode and DroneDeploy (or any other app providing waypoint functionality) works with the DJI SDK. The key point is the DJI Go 4 app is also not doing anything while the autopilot is flying. There is software on the drone itself which is the thing that is managing the flight of the drone.

That’s an interesting concept “P4p manual that came with the drone” - sorry no such thing.

Sorry to read about your loss Daniel.
I’m trying to get my head around what happened here but you haven’t given a lot of details.could you give us some more info such as:

Was the P4 heading toward the first waypoint or was it off course?
What altitude was it at when it hovered at the tree?
How far away from the first waypoint did it stop?
What height was this tree?
What altitude was the mission set to?
How far away from you was it when you initiated the RTH?
Was the DJI app running in the background or did you force close it?

Mark G.

There should be instructions that explain the RTH behavior as @real_c3 mentioned. Shown in the unboxing pictures:

Thanks Mark G

Yes the P4p package comes with some basic docs including Quick Start Guide v1 and Disclaimer and Safety Guidelines v1.2 2017.05 which is probably an incorrect name printed on the front of what could be called User Manual??

The issue is that all 3 of us who studied the documents, webinars and other DD info did not understand that DD hands over total control to DJI during flight. DD needs to revisit its information processes to make that obvious right at the start of the process. For some reason DD has effectively hidden that aspect.

My understanding is that “fly height” is relative to the launch position level and not “altitude” which has a specific meaning related to sea level.

Responding to your questions…

  1. P4p heading towards first waypoint on course.
    I had attempted to set up a different flight plan but when I selected a different way point to start off on (a waypoint that was closer to the launch site) then DD appeared to remove the flight plan before that waypoint. Didn’t see any info on that functionality. What happens in DD when one starts at waypoint 10. Does it fly from 10 - end and then go to 1 - 9???

  2. It hovered at flight plan fly height 78 metres (not altitude)

  3. 200 metres from first waypoint

  4. The tree top was probably at fly height 70 metres.

  5. The flight plan was set to fly height 78 metres.

  6. The RTH initiation was at the tree which was about 600 metres from launch site and in visible range although in inaccessible terrain.

  7. app?
    When I first purchased the P4p I used my Samsung android phone. It worked on both DJI app and DD app although the small screen size limited its usefulness.
    On advice from the retailer I then purchased a Samsung S2 tablet. It would not run either DJi nor DD successfully.
    We were able to re-initialise the USB in developer tools and get either the DJI or the DD app going but it proved to be a huge waste of time and effort.
    We then purchased a 2016 model iPad pro which successfully ran both DJI and DD apps.
    This is the first time I have used any apple product and after operating various PCs for the past 32 years, I find apple to be quite strange to use.
    As stated in earlier post, I carried out due diligence by flying the P4p under DJI app control at the launch site to ensure all flight and camera functionality.
    I then started up the DD app and launched the flight as planned.

Another interesting side issue is that DJI Customer Care in requesting flight records (which do not exist in the DJI app for the DD flight) requested that I carry out a certain mobile device to PC procedure.
They supplied me with a set of instructions (in Chinglish as they do).
Those instructions involved installing iTunes to my PC and connecting my iPad to my PC with the apple to USB cable supplied with my iPad.
It all seemed very straighforward although at no stage was my remote device (iPad) visible on my PC other than to see it as a photo storage device. There was no ability to access the DJI app and flight records as instructed by DJI.
The next thing that iTunes did was commence installing apple operating system upgrade v11 to my iPad.
And in typical apple fashion that download of about 3 gb files succeeded, and then during installation failed.
I replied to the prompt to revert my iPad back to previous state.
That process failed and the process concluded with apple turning my iPad back to a factory reset state.
Fantastic!

Yet another headache to add to the others!

I think there is a misunderstanding about what is flying the drone when you are using an automated mode. If you’re using DJI Go 4 and start any smart flight modes (https://www.dji.com/intelligent-flight-modes), the DJI Go 4 app provides some parameters to the drone autopilot and then the autopilot is what is actually flying.
So when you say that DD lets DJI take control during the flight, it’s not any different than any other flight mode aside from manual control where you are using the remote control to give commands.

Due to the autopilot having control of the drone, I feel more secure than if an app by a 3rd party was trying to fly and control my drone. The apps provide the instructions, but the drone autopilot written by DJI manages the flying and any failsafes such as return to home on low battery.