Drone Deploy and Class C Airpsace

Anyone flying DroneDeploy in Class C Airspace with a Phantom 4. I have done this previously, but not for awhile… Anyway I have FAA clearance to fly, Geo license uploaded and updated aircraft…ready to go… When I move to the Flight Checklist to get going and fly the flight plant…the flight path goes blank and the drone arises to the appropriate elevation as sits there not moving as there is no flight plan any longer…
I flew this yesterday out of airport area…all worked perfectly…it has to do with Dronedeploy and the geofencing I believe…Any ideas???


I always have to take off in DJI Go to go through the unlocking process and then start the DroneDeploy mission.

I have no trouble with the unlock in the class the airspace and using the drone device software to update my licensing for the geofencing. The problem is when I go back to the drone deploy software and pull up the flight plan everything looks good and the second I push the pre-check flight list all of the flight path lines disappear. I use this yesterday in two other test flights not in any controlled airspace and had absolutely non-issue in the drone performed as expected with the drone deploy software

The frustrating issue is that I have the approval I’m able to start the drone without a problem because I do have the geofencing license but the path disappears so the drone goes up to altitude and stops since it doesn’t have that flight path any information any longer in the flight plan.
Have you ever seen something like this happen before?

I have never seen a flight plan disappear. Just to make sure we are on the same page… I,

  1. Open DroneDeploy
  2. Set everything up
  3. Start the drone and RC
  4. Open DJI Go
  5. Connect the RC to the device
  6. Unlock
  7. Take off
  8. Switch to DroneDeploy and start the mission

Usually once I have unlocked on the site I don’t have to do it again for battery swaps, but it has happened. One in particular that I have reported before was because there was a small piece of a more restricted area in the corner of my map. I figured out that I had to unlock while in that area to fly the whole map. Not your scenario, but just an fyi…

Little different process.but it has worked for me…
DJIGO4 open up and install geofencing license into aircraft.
Disconnect DJIGO4
Connect Drone deploy
Pull up flight plan map…all looks good INCLUDING seeing drone flight plan path
Locate preflight checklist button
Press preflight checklist …green flight path lines disappear from screen and only the blue perimeter lines show
Goes through normal preflight checklist, all green
See button to start flight
Flight path continues to not be present on the screen

Larry Bush
(787) 248-8169 mobile

Have seen something similar in B and D airspace in the past with a P4P, even after going using DJI GO4 to apply the unlock. Now when in B, D (or C and E) will apply unlock code do a quick flight with GO4, record short video, take a quick photo or two. Then land, power down aircraft, swap batteries to start next mission fresh, also power off controller and shutdown GO4 app. Restart aircraft, controller and launch DD, all should be good. Note, by taking a photo with GO4 makes sure that there is at least one photo and appropriate structure on the microsd for DD (solves a different problem). Also by doing a quick GO4 flight, its a good chance to fly around area where you will be using DD to see if any surprises or changes, perhaps a crane in a new location and at a different altitude etc so you can make adjustments.

Thank you…good suggestions…

Lawrence P. Bush, CPA

McCarthy Improvement Company – Puerto Rico LLC

(787) 248-8169 Celular | (787) 791-8827 Office

595 Avenida Jóse A. Tony Santana, Carolina, Puerto Rico, 00979

“This message and accompanying documents are covered by the Electronic Communications Privacy Act, 18 U.S.C. sections 2510-2521, and contain information intended for the specified individual(s) only. This information is confidential. If you are not the intended recipient or an agent responsible for delivering it to the intended recipient, you are hereby notified that you have received this document in error and that any review, dissemination, copying, or the taking of any action based on the contents of this information is strictly prohibited. If you have received this communication in error, please notify us immediately by e-mail, and delete the original message.

Hi Larry, Quick and easy way to solve the issue is to reduce your altitude by a few feet from your DJI designated unlocking code. Try 10ft then 20 ft etc. The problem is the packets are communicating to 3 apps (let’s call them that for the moment) all at the same time. The convergence confuses DD and as such the drone will just freeze in midair. If you need to be at a specific altitude (some airports are real conscience of this) then send the unlock details with a few feet to spare if they’ll allow you. Worked for me!

1 Like

That is exactly what I did do…only issue I had was at completion of the mapping the drone wanted to return at a higher altitude from that programmed .,.so was hanging in the air…I ended up using the home button and it did return…
Thanks for your help…

1 Like

So you’re saying that the drone was elevating to an altitude higher than what was set in DJI Go? Does this happen with both the DroneDeploy interface RTH and the button? That’s not good… I usually take control of the drone when bringing it home, but sometimes if it is far enough away I let it do some of the work. It never goes above the altitude programmed in DJI Go.