Drone Deploy 3.8.0 Flight Planning Not Working on IOS after update from 3.7

#1

I updated my Ipad to DD 3.8 and found that the Auto Flight Modes and other Precesion House modes do not work at all. You can click the button but the map will not update and you can not plan. My Iphone X was using DD 3.7 and working fine. I updated it to 3.8 and now it too will not allow for flight planning. Now I am stuck using my PC to plan my flights while this problem is going on. Any solutions? I talked to Adam at support.

0 Likes

#2

Welcome @Sam_De_Long. Are you talking about @Adam_Carp? Did he say anything back?

0 Likes

#3

He sent me a message before sign off but I tired it today and it still does not work

0 Likes

#4

Bugger, mine too. Seems my iPad auto-updated - was on 3.7.0 a couple of days ago and working fine. Hope this gets sorted very quickly. Supposed to be flying in 2-3 days and no idea how to downgrade or if it’s even possible. Only have iOS for DD and no idea how to use it really.

0 Likes

#5

It seems like GCP’s are not working right now either…

0 Likes

#6

Hi James, It’s too late in this case. But for future reference…

Turn off auto updates (obvious)
Before updating the app, make a backup of your iPad to your pc via the iTunes app.

Then, if you update and the app has issues, you simply restore the backup and you have the old version.

Android is easier with this kind of thing. But as we all know, ios devices seem to function better with dji gear.

1 Like

#7

Hi Dave.

Thanks for this. I actually thought the updates were turned off, only that seem to be the case.

Android I know back to front in terms of apks and the ability to install them manually, but iOS I know nothing. I have just about got to grips with the operating system on a day to day basis but in terms of side loading, not a clue.

You’ve just reminded me however. I only received my iPad back from Apple’s repair centre a couple of weeks ago and so do as it happens have a system backup of it dated a month old. I’d rather not backdate it by a month but if I have to in order to fly the mission this week then so be it. Cheers.

0 Likes

#8

Great. At least that will reduce the stress related to that upcoming mission. :+1:

0 Likes

#9

I just did two GCP missions Friday and another 3 this morning. I’ll update once I tag them.

0 Likes

#10

Hi guys! If you can please email support@dronedeploy.com with these issue reports, we’ll investigate them all. It sounds like we may have bug here - we’d like to get it fixed ASAP. Thank you.

0 Likes

#11

Found today that if I select ‘Crosshatch’ on the desktop before I leave the office, it does still appear as a Crosshatch on the iPad. Only if I try to create a crosshatch through the app does it fail. Fingers crossed tomorrow the missionary stored as a crosshatch flys as one. And best hope I don’t need to make any tweaks whilst out in the field.

1 Like

#12

As it happens after connecting the drone to the app, the planned route changed and so it did require the the configuration to be amended. I was thankfully able to make the adjustments in the app without a problem so it seems the only problem the app has with regards to the Auto Flight Modes is that the buttons themselves don’t work.

The only setting I can see that is not accessible without clicking ‘Crosshatch’ again is the angle the gimbal is set at. Annoyingly, if there the gimbal angle needs to be displayed (for checking) within either the app or on the desktop, you have to select Crosshatch again which then that resets all of the Advanced settings previously set - although in the app right now it just reverts to Ortho.

0 Likes

#13

All 3 of my missions tagged properly and I am in process of doing two more now.

0 Likes