DJI Phantom 3 Advanced Stops Flight and Hovers

Here is an issue I have run into now 3 times using two different Android platforms (phone and tablet running the same version). The drone will connect up fine, it will go through it’s preflight checklist and claim all way points have uploaded. I will send the drone on it’s mission and within the first 3-4 points it will simply stop at the end of a line on a way point and hover, or fly the mission and hover on the last way point without coming home. I will have to manually on the controller tell the drone to come home. The flight otherwise is fine the camera is triggering correctly, and all systems seem to operating fine when I run the drone in DJI GO and look at diagnostics. Here is the funky part, after I land the drone and reset, generally the next flight is just fine. Anyone ahving issues like this or know what the issue could be???

Had same issue while on client site last month. Have run several test flights since then (including today) and had the same issue with each. Tried two different android platforms and have uninstalled and reinstalled the app. DJI GO works fine and have no issues with another mapping app. I’m using P3Pro.

I have seen this issue with a few people but it hasn’t been very consistent. I’m curious if you are flying in an area where there might be a lot of radio noise. This could come from heavy equipment or high powered antennas. When the drone stops and hovers it is going into a failsafe mode. Most likely due to loss of connection between the remote control. Have you noticed that it is site specific? I would also recommend choosing a takeoff location that does not have any large metal objects near it. Re-enforced concrete with rebar underneath it can sometimes throw of the compass during take off which can cause issues.

Thanks for the replies. perry it sounds like we have the same issue or very close. Zack1 I’d say you were onto something, but I generally fly in very rurral areas over clear-cuts and timberland (I work for a timber company). The last time it happened I was over two miles away from any cell tower or radio interference source I could think of other than trees. I have in the past flown over our mill facilities as well as construction sites and those generally work OK, I may need to reposition the drone for the compass, but generally it works just fine. That having been said radio interference could be the issue, but in the past once I have sent the drone even if I loose signal it will still fly the mission and return with good results, in these instances it just stops tilts the camera up like its done and hovers in place…

My client site is in a rural area and I’m headed back there later this week. I’ll try it again with a different takeoff point and see if that helps and will report back.

Went back to my client site and tried again with same result. P3P launches, flies a few waypoints, then stops at a waypoint and hovers. There is a power plant next to this facility that could be causing radio interference. Also happened with another mapping app, so has to be related to some type of interference

Humm, well, if that’s the case I’m a bit disappointed by the Phantom 3’s reception. I still can’t understand why it would just stop, even when I have lost reception (never have ever lost RC) in the past it would still fly the pattern and return. Maybe a fail-safe was added in the last version of the app???

This has always been an issue reported by some users in some areas. It’s disappointed. We’ve spoken to DJI about it and they think it may be an issue or a failsafe in their flight controller. Normally the drone will continue to fly when it loses a connection. We aren’t 100% what causes the hovering and then returning to home yet.

Same problem here, many times. Over and over

I was in Tanzania, in the middle of some rural area. In some locations there was not even cellphone network. No concrete for miles. Mission uploaded succesfully, all preflight checks passed smoothly. In some cases my phantom 4 would reach the first waypoints and stop there hoovering. Some other times, it would reach altitude, start moving to the first waypoint, but stop and hover before reaching it.

Nobody seem to have a clue.
I really appreciate the support thus far. Very nice community and quick responses. Perhaps is my fault and i and don’t realize it, but i am not doing anything different from the first successful missions i had. I hope somebody out there can help, This thing is making me think to give it up as i cant’ use the drone for work anymore.


We’ve been sending logs regularly to DJI for users that have this issue so they can debug the issue within the flight controller firmware. If any of you have logs loaded from the drone body via USB from a DroneDeploy flight that stopped mid-mission and hovered it would be helpful.