DJI Mavic Pro, overlap not working on captured images

Hi, just tested out DroneDeploy on Android for my Mavic Pro. Was my first attempt at doing mapping. I’m in a trial account to test it out.

I visited a small area in wooded park land, to do a test map capture. I setup the mission, setup altitude of 200 feet (max legally in Canada is 300, was giving myself some buffer). And I’d read that increasing overlap is good, so I increased sidelap and frontlap to 80%.

I set camera to “auto” settings

I connected the drone, and flew the mission. It took off, and began flying waypoints. I could see the video feed “blanking” out (normal for it taking a photo). So I knew it was capturing images (even though the image counter in the app was not counting up, which was troubling). It seemed to fly a reasonable flight path, and then tried to return to home.

I say tried, because it was WAY off the home point (does DroneDeploy not support the “precision RTH” feature on the newer drones? It was off by at least 5M from home point. Almost landed in nearby trees. I quickly took manual control, and landed it safely.

When I got home, and uploaded the images, the quality of the map was aweful. It was missing at least half the mapped area, and what it did have was pretty bad (3D was completely useless, 2D was “ok” quality in a few places, but bad elsewhere).

Upon inspecting the images, I noticed that the images don’t appear to have any overlap at all (some have VERY small overlap, like 5% at most).

Neither the frequency of images (frontlap) or the sidelap from parallel course lines, appear to be set properly to capture enough ground.

I assume that DroneDeploy app is aware of:

  • Camera on drone, and it’s FOV
  • Elevation I’ve chosen in the app
  • Basic trig to calculate approximate ground coverage
  • Use this to calculate distance between passes, and shutter frequency?

Also I noticed that I set max flight speed to be 25MPh, drone should be capable (ideal conditions) of 35MPh. But in actual flight I noticed it never made it over 10-12 Mph, (which you would think would increase image quality, etc?)

It was about a 9 Acre map, and it finished in the expected time (which is odd if it was flying slower than planned)

Anyway, lots of odd discrepencies from the flight, but mainly the lack of real overlap seems to have destroyed the usability of the dataset.

I’m travelling to visit family members, and I’d like to do a survey of their property for them, I won’t be back for probably a couple months. So I’d like to capture the data while I’m there this weekend. Anything anyone can do to help me correctly capture the data would be greatly appreciated.

I know flying higher means more land covered by FOV, but in my mind that should make no difference, the app should be able to calculate the flight path based on FOV and altitude, to have coverage no matter what altitude I’m at… (and I don’t want to just risk it this weekend, and fly higher, only to find out it “over compensated” and still didn’t capture any overlap).

Thanks!

Hi Paul,

Quick question: did you calibrate the compass before you took off? Sometimes when users have and issue with RTH, it’s because the home point wasn’t established to begin. As far as the speed, the flight is automated so it will fly at the speed it needs to depending on your settings. Typically, DroneDeploy recommends shooting in Manual vs. Auto Mode, there is a great post about that here: https://blog.dronedeploy.com/improving-the-image-quality-of-your-drone-maps-499b26e62494

If this still isn’t helpful, please let me know. Thank you!

Hi Kara, thanks for the reply.

The primary issue is that the picture overlap isn’t working. IE: the pictures are too far apart. From analyzing the actual positions of the shots, it appears it’s the frontlap that’s not working. The paths side to side look fine, but it’s taking pictures so infrequently there is nearly no overlap, and as a result, on next pass, the pics don’t line up either, so I never get any obvious overlap. It’s almost like it’s missing at least every other picture. From what I can remember on the flight, it was taking a pic every 3-5 seconds.

SD Card was formatted on mavic, and takes pics just fine in DJI Go 4, and Lichi app, as well as 4K video. It’s a UHS U3 V30 microsd so more than fast enough.

Does your app currently have issues with the mavic? I’m just wondering what I can do to troubleshoot this issue. It appeared to be taking good photos all through flight, wasn’t until I got home that I realized it was not taking them with enough overlap.

I’ll certainly try shooting in manual camera mode. I’m sure that may help with exposure/etc, but that should have nothing to do with frontlap being wrong.

Again front-lap and side-lap were set to 80%. Should have been heavy overlap. Yet in reality several of the pics had either zero overlap, or only 5% overlap front to back, because of the frequency of photos being taken. The actual distance between each pass appeared to be good, but seems to be an issue with picture taking frequency.

As for the RTH issue, the compass was calibrated. When I use DJI Go 4 app immediately after, it returned to within half an inch of where it took off from exactly. The smart RTH function worked fine, but in DroneDeploy, it seems to be all over the place when it does RTH.

That’s a minor issue though, again my primary issue is that I need to know how to reliably capture a dense enough dataset for good reconstruction on-site.

Thanks!

Quick update, here is an image of the flightpath. The blue dots are actual pics taken, red dots are where pics likely should have been taken to get right overlap. (only guessing, but based on spacing makes sense).

You can see from this example what I mean that sidelap appears to work, but frontlap is not working right. As a result, because many images end up staggered, there is practically no overlap in most of them.

image

Any suggestions/help?

I had this exact issue about a month ago with a Phantom 4 Pro. I have regular flights that capture around 200 images per flight - and then after an update of DD it only captured 53 images. Checking the flightpath the front lap images were spaced far apart and were normally really close together. I had not altered the front lap setting between the flights so I can only assume the latest DD update broke it.

I am planning on doing some testing to try and get the frontlap images back to normal.

Would love to see what you find on this. And interested to hear feedback from Drone Deploy on it. Seems like it’s not only me seeing this problem, and it’s a major issue. Makes the dataset captured completely useless. I’ve been unable to get out to a safe flying location to test this again since the affected flight. I’m hoping it’s corrected before I travel this weekend, as I am travelling, and will be doing a survey while I’m gone (and won’t be back to that location for another couple months).

Hoping I can get a good capture while I’m there.

Folks, allow me to help out a bit. I fly 3 Mavic Pro’s using DD and I also fly two P4’s and two P3’s and I can tell you that this is not an issue that I have found to be related to the DD software at all. In fact, I would venture to guess that with a few tweaks on your drone, MAVIC PRO is a bit harder in this area, you should be fine.

First thing I would do is make a tighter flight plan. Depending on your height for example, you may not be getting the overlap that you were looking for. I can also tell you that my flight plans never have that much gap between the paths of flight. I will get to one of my flight plans and send it to you to show you what I am talking about

Also, (and perhaps I missed it) but could you post the exact specs of your flight plan. All details including height, distance, overall terrain area, etc…I would like to see if there is something there that I may be able to help with.

How can it not be related to the software ?

Before the upgrade the flights were perfect with excellent overlap. After the upgrade the overlap has gaps.

Nothing changed in the flight plan - so it can only be the upgrade that affected it.

Hi Paul, did SkyCloneLabs answer help? I can notify support about your issue but as he said, it might have something to do with the Mavic specifically.

We can double check if we’re seeing any issues with the number of images captured here at the office. I don’t believe we’ve been seeing this and I don’t think that anything that should change this has been released. I would check with a different SD card as step 1 to make sure it’s not related to that possibly.

Hey, so I’m pretty convinced this is software, I attempted another flight tonight, smaller area. 200 feet altitude, 80% frontlap, and 80% sidelap. Also set the camera to manual as well.

Behaved the same way. Sidelap was fine, frontlap (frequency of photos is way too slow).

So I cranked sidelap up some to 85% and frontlap to 95%, tried again. This time it just didn’t take any photos… I tried the manual shutter button while it was flying, and that triggered a photo fine, left it for several seconds, no photo… manual again… Just fine, etc…

So I tried Pix4D, and did the same mission (same location, same overlap settings, same altitude, etc). And it was flawless… Flew the mission without issue, took photos with much higher frequency, and landed RTH accurately even…

I’m convinced this is not an issue with the drone setup, as I flew both missions on the same battery, back to back. In addition the behavior of the frontlap simply not taking photos at right frequency (when looking at my map image earlier, it’s a clear issue, the software should be able to calculate accurate timing to get at least “similar” spacing on front/sidelap and it’s clearly not.)

Anyway, I’d prefer to use Drone Deploy to be honest. As I also prefer to sync my logs to AirData and dronedeploy supports that. I also am not a fan of how Pix4D has the separate control app to handle interfacing with the drone. However I can’t argue with the results, their app is working flawlessly on this drone, and Drone Deploy has been nothing but trouble so far…

Definitely willing to give it a chance, but SkyCloneLabs suggestion of “Do a tighter pattern” doesn’t seem to be helping (and I’m already flying a tight pattern in my opinion). Default in DroneDeploy is what, 70% overlap? I already had it cranked to 80%, and tried 85%. At much higher we’re seeing like half an hour to do an 8-9 acre survey, which is getting rediculous. It should just be taking photos more frequently… (not to mention the one flight where it didn’t take any photos).

This SD card is pretty high-end, it’s a V30 SD card (ie: guaranteed for 30MB/s min (which is 240Mb/s) and it records 4K video perfectly fine without issue. I formatted the SD on the drone prior to each flight as well.

Open to further troubleshooting and suggestions?

Paul,

I am confident that it is not the DD software only because I if the software were to blame then I believe it would affect all of us who fly MPros. I do have a few questions:

  1. How does your Mavic down when flying orbital patterns using DD and taking pictures?
  2. What firmware version do you have on the Mavic right now? Did you do the most recent update as of a few weeks ago?
  3. Have you downgraded the firmware on the Mavic too see if that helps?
  4. Did you do the reset and calibration on the Mavic (just an idea)
  5. What setting do you have as default on the Mavic for your camera and what setting did choose on DD’s software for camera (auto or manual)

Since I handle remote drone configurations, I would be willing to log in remotely and see if I can assist. My three MPros fly real well and do the pics very well but that does not say that I have not camera issues with the Mavic Pro. Their Gimbal and Camera setup have been the largest complaint so far on their forum.

Also, what are you flying again wth the Mavic? Are you using IOS or Android? If you are using Android and need IOS let me know and I will send you an iPhone to borrow and see if that helps.

Either way, I am here to assist if you would like. no issues…just trying to help.

Sya,

What I am using to deduce this is the idea that not all P4’s (like mine) are having the same issues you are having. Now, I am simply coming up with the notion that if you are having an issue with the software and I am not, and we fly the same drone, then the software may not be to blame. However, I know there are many other factors.

A few questions I have:

  1. What Micro SD are you using (brand, size, and write speed)
  2. What is your altitude of your flight (just curious)
  3. What OS are you running again? Have you tried both?
  4. What browser are you using? The reason I ask this is because I have had a few issues with different browsers recently…For example, Safari was worthless, and Chrome was recommended. Funny thing was that Chrome failed and I ended up using FireFox to get the job done.
  5. Have you used Google Earth and imported to DD to see if the pics are ok?
  6. The question as above but using Litchi and importing to DD.

I have a good inventory of parts, drones, and OS devices so I can help you if you would like. I do it for free so please do not think that there is any hidden agenda. I am just trying to assist and will be more than happy to help you.

Quick question: what class SD card are you using? Usually a Class 10 is ideal.

We’re trying to reproduce this to see if we can find an issue.

Paul, can you try creating a brand new account and logging in with that account and flying? I want to make sure there isn’t some setting or plugin messing things up.

Thanks Sky - I will be doing some testing tomorrow on a flight that I know has worked in the past with no issues.

I plan to use an Android device, Iphone and Ipad mini in my testing (3 flights in total).
I have a class 10 Micro SD card.
I have upgraded my P4Pro to the latest firmare.
I have downloaded the latest version of Drone Deploy.

My flight is at an altitude of 138m and covers 47 hectares, runs for 9 minutes and has a side / front overlap of 60% which historically had photos with no gap. I can prove this by restitching some of my older flights to prove that it was ok.

I’ll be in touch once the flights are completed.

Comparison - flight on 0403 - all ok
image

Same flight on 1703
image

Nothing changed on the flight plan so I have no explanation as to the reduction in photos.

Thanks for all the additional info.

First let me repeat any info from previous posts in a single central post (since many of you are asking for specific parameters, etc), and make sure I didn’t miss any:

First general info:

  • All flights done on Mavic Pro Firmware v01.03.0600 released April 11th
  • All flights done with Android Device (Nexus 6P Running Android 7.1.2)
  • I’ve done many flights with DJI Go 4 successfully, no issues there, drone behaves beautifully on Android device
  • Drone Deploy app was latest version before flight #1, and there was an update on the android app before Flight 2, and I did install that update to Drone Deploy before that flight.
  • I’m using a Kingston Digital 64GB microSDXC UHS-I Speed Class 3 card (U3 / V30 speed, benchmarked at nearly the advertised 90MB/s read speed, and 80MB/s write speed, this is far superior to the “standard class 10” listed commonly.) It shoots burst mode photos VERY fast, in full res, and can shoot 4K without any issues. The SD model choice is definitely not the cause of the issue.
  • SD Card was formatted (by the mavic) before each flight using the DJI Go 4 app.
  • For the record this is not a complaint about the mavic specifically. That’s just the drone I fly. It’s specifically an issue I’m only experiencing with the DroneDeploy app, when used on my mavic. The camera/gimbal, all work great. Drone performs like a champ, etc.

First flight (the one that prompted me to post this thread): Flight covered 9 Acres, was setup with 80% frontlap, and 80% sidelap, at 200 foot altitude. With “max speed” set to 25Mph (though it never made it this fast during the capture). And camera settings set to Auto. This one seemed to work, sidelap (course) seemed correct, but frontlap (frequency of shots) seemed to be about half (or less) than what it should be. As indicated in the image of my flight path I posted. This seems to correlate with the recent example posted by syamaphantom (thanks for a second example!). RTH was aweful as well, on RTH it was far from the home point, almost landed in some trees, had to manually take control with mode switch, and land safely.

Then the second flight attempt, done on reduced area, reduced to 3 Acres (just to get test done quick), still 200 feet altitude, increased Sidelap to 85% and frontlap to 95%. Speed the same, And I changed the camera to “Manual”. Before flight I opened up the DJI Go4 app, flew up to 200 feet, setup camera, verified by taking a bunch of rapid pics in succession. Worked fine, so I landed, and switched to Drone Deploy app, loaded new mission and took off. This time it took no pics… I waited several seconds, it didn’t take any. So out of curiosity, I pressed the camera shutter button on the RC, and it took a pic. Thought “maybe that would kickstart it” but it didn’t, several more secs go by with nothing. So took several pics rapidly using the shutter button manually (at the frequency I thought seemed reasonable) and they worked fine. But the app didn’t “auto-take” any pics. RTH was still bad, again WAY off, had to manually land (at least this time I was prepared for it).

Third flight, I recreated the same flight plan in Pix4D, 3 Acre area, 200 feet altitude, 80% sidelap and 80% frontlap. And similar speed limit. Also set to manual camera settings. Launched the mission with their app, and it took off and immediately began flying the course, and taking frequent photos (more along the lines of what I would expect, with the 80% overlap settings, a given feature was in at least 3-4 photos in each direction). It finished, and as a nice bonus it’s RTH actually landed successfully in the right spot, without requiring manual intervention.

Some other notes:

  • I’ve flown several missions, never had an issue with it recording photos or video, also never had any real issues on Android other than the well known “force quit other apps before switching” issue. Which I’m well aware of, and did every time here. If you don’t do this, it simply will not connect.
  • I’ve use Lichi a bunch too, and was able to do successful orbit missions, and pano shots with Lichi automating picture taking without any issues at all on same drone, same card.

I’m not saying that the software doesn’t work at all, that’s clearly not the case, many others are using it very successfully. However I am actually an experienced software developer, and computer engineer. I’m well aware of the fact that wierd bugs can creep into a system as a result of a combination of unexpected conditions/circumstances/variables. So I suspect this is what’s going on, perhaps it’s the combo of the Android version of the app, with the latest Mavic firmware, causing the problem? Perhaps it’s something wonky on my account? etc. Anyway, that’s why I’m looking into suggestions, and hopefully helping DD debug their software. BUT I can say that through process of elimination, out of 2 mapping apps tried (DD, and Pix4D) and 2 other control apps tried. (4 apps total) ALL 3 of the other apps had zero issues, capture photos just fine, and ONLY DD appears affected. This leads me to believe that while the issue may not be 100% the software, it at least involves some bug in the software, which is being brought to the surface by other factors.

This is re-enforced by the fact that the HUD display doesn’t even show the images being captured on the mavic (which other users have reported as a specific issue to the mavic) and the fact that it appears unstable (sometimes it simply won’t capture photos). I have no doubt it may be “more” stable on Apple, but that isn’t a testament that the app is fine, it’s simply a validation that the android version of the app needs further work for improved stability. If you only want to support Apple, don’t bother releasing an Android version. I’m a pure Android user, I have no intention of using an apple device. I’m well aware of the quirks, and I’m also well aware of how to work around 99% of them, so it doesn’t bother me. If the result is that I have to use another app which is proving more stable on Android, I’m happy to do that. But I’d like to try to figure the problem out (as it’s in my nature) and I hopefully can help DD in the process to improve their app.

As for the suggestions in the last several posts:

  • Don’t intend to downgrade the firmware to test. Again other apps work great for this same task, only DD app is affected. Well aware that 0500 and 0550 version firmwares had major issues with API apps, and 0600 corrected them.
  • I have reset calibration on both IMU and Compass to test. This was done about 1 week prior to the first flight, and after the suggestion to re-calibrate, I did it before the second flight.
  • Camera settings in Go4 App are set to manual, with manual wb, and exposure. I set it up in Go4 ahead of time, verified it was good, then exited (And force quit) go4 app and launched DD, in the flight plan, it’s setup to NOT use automatic settings.
  • Thank you for the offer for the iphone to test, that’s extremely generous. However as I said I’m a pretty purist Android user, and I’d rather “figure out the root cause” with Android, rather than just resign myself to using apple as it’s more stable (just my nature lol)
  • chasemgray: I will try to create a new account, and attempt another mission this weekend if I get time. Will let you know how that goes. That said this is a fresh account, with no extra plugins enabled, or fancy settings changed. It’s pretty much “out of the box”. Either way, I agree, something could be corrupt, so I’ll test that and let you know.

I think the pics in most recent post by Syamaphantom are pretty clear, same flight, same app, same drone, same location, one has frequent photos, one does not. That’s pretty blatant indicator of some underlying problem (even if it’s an obscure bug that’s only triggering on 1% of users or something due to uncommon combination of factors)

Thanks again for all your suggestions/feedback :slight_smile: hopefully we can dig to the bottom of this.

I have done two test flights today - one using an android tablet and one using an iOS tablet.

Drone has been updated to latest firmware.
Drone Deploy software was uninstalled, and reinstalled from App Store / Play store so is the latest version.

Drone used Phantom 4 Pro.

Flight plans were of exactly the same area.
Height 193m
Overlap front and side 60%

Pix4d software was used to stitch the photos together.

Android result
image

iOS result
image

This is consistent with my last flights some 4 weeks ago.

Drone Deploy on both platforms has minor quirks but I do like the camera display and the drone statistics being displayed. I feel comfortable with the software when the flights are in progress but the differences in results is a concern.

It also seems to me that in the last 6 months, upgrades are released which tend to fix one thing but break others. Example - my Apple flights worked fine until an upgrade some 4 week ago.

End result : I will stick with Drone Deploy and do my flights on the Android device until the iOS software is rectified.

If there is further information I can supply that might assist with troubleshooting please let me know.

We had a similar issue with DD:
Flights in January (p4p) with 70% side and front overlap showed some 630 images. Flights of the same area end of March after updates resulted in only 245 images which turned out to be useless …