DD & Zenmuse X5: Focus issues

Dear all,

Being a user of a competing application for some time I am now planning on moving to DD, as the former recently released some problematic updates.

I am operating an Inspire 1 V2.0 and a Zenmuse X5, combined with the stock DJI MFT 15mm lens. My previous application used to produce focusing issues at first and I have read about users on this forum running into similar problems using Dronedeploy. I used to (at least partially) circumvent this through setting focus to MF (on the lens) and to infinity (in the Go App). Furthermore, I turned Autofocus OFF in the actual mission planning application.

I am wondering how the X5 focusing issues and plausible solutions have progressed regarding Dronedeploy. I just came across this forum post where DD developers stated to be working on the issue. Has it already been fixed? And if not, how does one go about to find a workaround? Will setting the lens to MF and infinity work with DD as well? What about the (auto) camera settings in the DD app, should these be turned on or off? Is there a way to turn autofocus off, if such a feature is present at all? Should I define any other parameters, either in the Go App (i.e. Aperture fix/ auto?) or DD?

Thanks in advance!

The focus for the X5 with the default 15mm lens should focus properly. Let us know if not


Thanks for the swift reply!

So, you are saying I can keep all settings (in both the GO and DD app), such as Auto camera settings and AF, as well as physical AF switch on the camera, turned on and the result should be fine?

Regarding flight speed. Does DD automatically define a maximum flight speed once the drone is connected and the X5 signalled, or should I take complete care of that myself?

assuming the lens calibration has been done? I’ve had this issue as well. (Matrice100 with X5)

Fresh back from flights Thursday and this morning, the focus issue is back on my X5 (Inspire 1 Pro). I had some issues last year, that I thought I had resolved by the following procedure: Set the lens to infinity in Go, switch to manual on the lens, then leave auto settings in DD which was working fine… until this week.

I tried various things in the field this morning (and several flights!), I had the laptop so I could easily check after until it was right. The only way I could do this, was to manually fly the mission myself in Go, using the trace on the map as a guide to where I had been. Hardly scientific but I had the camera on every 2s, so I think I probably got more images than I need.

Can DD do a guide on this? Has lens calibration sorted for other people? Any other considerations such as flight speed, shutter speed etc.?


Update: Another mission this morning, some very interesting points came up. So, the one the other day I flew from a 30m high rock. Today I used DJI GS Pro app (more on that later). There were tall trees in the survey area, the rest of it was basically kinda flat. So when I flew over the trees, I found I had to tap to focus in the GS app to get the ground back in focus, something you can’t do in the DD app unless you have set up the controller buttons to do this. I thought previously that at 60m, it wouldn’t really matter what the terrain was like because it would all be focused to infinity. Thoughts on this appreciated, generally my feeling is that high structures, trees, terrain relief etc. are affecting the focus. Some images (immediately after trees) are out of focus, when I tapped the screen they went back to focus.

The DJI GS Pro app: This has generally been very good (first time today). Lots of parameters to set up in the app, which seems to me to be a good option for capturing data for later processing in DD. The in-flight display gives you more info (basically like the DJI Go app) and detail on battery life etc. What was excellent was being able to display the camera view in full screen (and tap to focus as mentioned), this makes a big difference. When the mapping part has finished, the full screen display makes it way easier when ‘switching to guns’ to manually capture your oblique stuff.

For anyone on the X5/Inspire 1 Pro or having focus issues I would strongly recommend trying this app, and even if you’re not it’s a good app anyway! I think I will use this going forward for all missions and process in DD. For info. I also did a lens calibration yesterday and all firmware was up to date previously.

Did you also set the physical switch on the X5 itself to MF? Also, why would you keep Auto Camera settings on in DD if you are planning to override these automatic settings? I reckon keeping these settings set to auto may be part of the problem.

I did some benchmarking earlier last week, using both DD, DJI GS Pro and Map Pilot. I found considerable differences regarding forward- and sideward overlap (particularly how these compared to the values set), but surprisingly hardly any differences in focus/ sharpness. I found that all images were relatively sharp, regardless of the application. I follow the same procedure as you did, but turning Auto settings off and the physical MF/AF switch to MF.

I must admit that the terrain in my case was relatively flat. There were some changes in elevation but no trees or other objects that could get the focus off. Likewise, I am not entirely able to state how DD performance in regard to the other applications with respect to image focus. This follows from me experiencing sincere focussing issues with Map Pilot in the past, but not seeing any of these issues this time. Hence I reckon this may partially follow from the terrain, and not necessarily from one application performing better than the other.

Although I like GS Pro a lot (it’s interface is almost 1:1 comparable to DD), I do find the forced 1 image/ 5 second interval problematic. Following from our maximum flight altitude of 50m AGL, we are only limited to 3m/s when adhering to a 65/65 overlap. Using DD we can accomplish anywhere up to 5-6m/s. This does increase the area one can capture on a single battery by A LOT.

Yes I set the switch to MF, but left auto on. This was working pretty well. The reason for this was to avoid having to manually set the exposure/shutter settings which tend to be different in the air to on the ground.

For now I’ll stick to GS Pro. I take your point on the 5s issue, I tried to set the photo per distance but it’s not compatible with the inspire 1. I also tried the hover at photo point (takes a lot longer) but could not really gain any discernible difference (by eye) and the ground control result was very good in any case even without doing that.

I set the switch to MF, set camera settings in Go at Auto and then turned Auto in DroneDeploy off. Images then seemed fine over a couple of 2 minute testflights. Not entirely happy with the sharpness of the images yet, but they were similarly sharp/unsharp as they were using MME/GS Pro on the same day. Hence I reckon that was not the cause of DD.

Hi All,

As some time had passed i re-iterate initial question of this thread

Has it already been fixed? And if not, how does one go about to find a workaround? Will setting the lens to MF and infinity work with DD as well? What about the (auto) camera settings in the DD app, should these be turned on or off? Is there a way to turn autofocus off, if such a feature is present at all? Should I define any other parameters, either in the Go App (i.e. Aperture fix/ auto?) or DD?

To refine the question
Is the possibility to use autofocus fo X5 (DJI GO) and automatic setup in DD available ?


I’ll chime in with the same problems as others have mentioned.
I’ve been using DD and Go app without issue since Sept. 16. However since last month I’ve had the focus problems. I’ve not changed anything in my operating procedure, only performed the routine updates.

Can you give me more specific information about this? eshorvath @trmvc.com

Hello @Eshorvath @Peregrine

Have you updated to the latest version of the DroneDeploy application? I am curious if you are still receiving this error despite running the latest version of the app and firmware.


I flew with an X5 yesterday and the focus still did not work.

@MBlacklin What device were you connected with and also what drone were you using? I would make sure you have updated to our latest DroneDeploy version. I would also check to make sure your manual focus settings were not on during flight.


Connected with an iPad Pro (10"), and using an Inspire 1. Pretty sure I was on the latest version of the app, as it hasn’t updated for a while (no update pushed out?).

Do you mean manual focus settings within Go?

I’ve had exact same problem with Zenmuse x5 / Inspire 1 pro for 2 years already! It’s why I don’t use DD except for certain thermal mapping applications where focus is not an issue. Although I don’t have the log handy to share, here is my experience: I would Set DD to manual, set DJI app to infinity focus, then fly the mission. The first few photos taken by DD are great and sharp. Then, according to the flight logs, DD automatically switches back to AUTO focus mid-mission without asking permission. If you download the spreadsheet from your flight logs, you’ll see there’s a column for Manual/Auto all the way at the end of the list and and for the first few intervals the log records “Manual” then it changes to “Auto” for the remainder of the flight. Hoping DD has an explanation for this??

Hi @dronexsolutions,

Hope you are doing well. I’m sorry to hear that you have been having issues flying with our mobile app and your X5 camera. If you are flying with an iOS device and you are still experiencing issues with focus, we can enable a new feature on your account that will automatically calibrate the camera focus once the drone reaches the flight altitude. Just make sure to turn off the “Set Focus Manually in DJI Go app” option within DroneDeploy. let me know if you want to use this feature, if so, can you please reach out to us using your DroneDeploy username?

Hi @MBlacklin,

As you are using an iOS device, I went ahead and enabled the focus calibration feature on your account. Please uninstall and re-install your app to clear any possible conflict and give it a go.

Happy flying!


Oh darn - I had a mission to fly today, but only just saw your message. My images are still appearing slightly out of focus (though not as bad as previously) so I wonder if it is something with how I have my lens calibrated. I will uninstall & reinstall the app and try it again on the next flight. Thanks!

I have been having the focus problem with an Inspire 1 Pro and an X5 camera for multiple months now. Does anyone have a solid fix for this issue? Does the lens itself physically need to be set into the manual focus mode. I have flown a great deal of maps or attempted to at least and gotten garbage data as a result of the focus issues. I first noticed the problem in summer of 2017. I have two Inspire 1 Pros and was swapping gimbals and camera lenses around and could never isolate the problem. It seemed as if the issues happened when I did a firmware update but based on the previous posts I think it is something else. Any help would be greatly appreciated.