DD problems

I have problems since I installed DroneDeploy version 2.0.54 on my Ipad mini. All is well until the flight begins:

  • The upper right window where the image is seen looks black
  • The figure that makes the route by the lines of flight stays stuck sometimes
  • Does not capture all images
  • DD closes

What I can do? Does anyone else have the same problems?


I would suggest uninstalling and reinstalling the app.
Also turn the iPad off and back on periodically during the week to clear out possible conflicts.

You are not alone Jandro.
I have been having the exact same problems for the last 3 months. DD has kept up a regular email correspondence, basically just suggesting what Gary does here, still no successful flights.
I know it is a DD problem because Pix4D Capture works fine. Just hoping one of these constant updates gets us back to the early days when it worked.

I dream of those early days where flights were flawless…

Had some similar issues on my iPad mini. Was flying on some 94+ degree days and the mini would overheat and shut off the apps. Improvised some shade and put mini in front of AC car vent between flts.

Which Mini? My Mini 2 crashed with advanced apps like DD and Autopilot. I got an Air 2 and all crashing problems went away. I just got a Mini 4 and expect no trouble from that. I’ll report back if I do. I’m a regular DD user.

Hello guys the same problem here. It was a cold day but after a few hectares the app on iOS start to close during the mission. IPad mini 2. I did turn off the tablet a few times but the problem continued.
On Android the flights were better but pictures look more red than they should be. @chasemgray