DD connects Phantom 4 but does not move it to start a flight plan


#1

Since I have updated the firmware for Phantom 4 aircraft and Remote Controller, I have had an issue that DD does not move Phantom 4 to start a flight plan. I had no problem in flying the aircraft using DJI Go App and the Obstacle Avoidance worked well.

DD connected Phantom 4 well and successfully started a flight plan by lifting the aircraft about 5 feet above the ground. But that was all; it didn’t move the aircraft. The aircraft kept hovering the home.

I switched the app to PrecisionFlight but it didn’t move it either; successful until hovering over the home position.

I tried to start the flight plan after turning off the Obstacle Avoidance in DD but it didn’t go through either.

Did anyone experience it before or do you know how to resolve this issue? Thanks!


#2

@yowich Are you quitting DJI Go before opening up DD?

I would recommend slightly moving locations. Both Precision and DD seeing a hover - sounds like EM interference (such as power lines) or a GPS/compass issue.

I would also recommend uninstalling and reinstalling both apps to check for updates.


#3

Thanks for the comments!

Yes, I am quitting DJI Go and turning RC off and on again before choosing DD as an temporary opener for USB port. But DD wouldn’t automatically open and I had to click on it to run it.

I have tried it at two different places: one with power lines, the other without them and where it has been successful to launch P4 with DD before.

That was what I wrote before I went out to test it again after resetting my tablet to the factory settings and installing DJI Go 4 and DD. Now it works! DD and P4 do it great!

Thank you very much!


#4

Wooot! You’re very welcome! Have good one. Cheers.


#5

Nice! Glad it worked out.


#6

I have hovering problem all the time. Manually take off to altitude of about 20 ft. Then start DD