DD app will not initiate flight because it says altitude is too high

I am flying a P3A controlling with Android Google Nexus 5.

Within DD, my max altitude is set at 400 feet since I’m flying in the U.S. I have previously noticed that if I attempt to set a flight altitude above 385 ft, the app will tell me that the altitude is too high. I decided that the 15 ft margin below U.S. max altitude was just a safety cushion.

I got the latest DD app version installed on my phone last night and flew a couple missions today. I attempted fly the mission at 385 ft and got the altitude block warning. I dropped down incrementally and was finally able to fly below 365 ft. I couldn’t find anything in the 370+ range that would pass the altitude check. I tried changing my DD account Max Altitude to 500 ft to see if I could get any higher but that did not change any of the results.

Just to be certain that there wasn’t a conflict somewhere being generated from the DJI side, I closed out the DD app and initiated the DJI GO app. It allowed normal flight control and I was able to go up to a full 400 ft indicated altitude when the app notified me I was at maximum allowed.

I want to fly as high as legal and safe to make getting the acres covered as efficiently as possible. Please advise if the problem is on my settings or is within the app.

1 Like

Hi Brent_Rendel,

Are you using the most current firmware on your Phantom 3 Advanced? Should be v1.10.90.

Yes, I’m using the current firmware and have been running it for awhile. The change in max altitude happened with the latest DD app version.

And I I mentioned, the DD app has never allowed me to fly to 400 ft. Always had to set my altitude 385 or lower.

And the only app running on the device when I get the problem is DD.

1 Like

Hi Brent_Rendel,

Could you private message me your user account email address? We want to check your logs, as this will allow us to better help you.
Also, if you have any screenshots alerting you of the high altitude, please send me way.

Thank you,

I had the same problem in Oklahoma last week on 2 shoots at 400’ ad had do go below 385 to make it work. Also had problems with screen saying something to the effect of “drone pictures finished and uploading.” I wanted to do a screen shot but it was in the middle of a mission of 500 acres on the 2nd battery and didn’t want it to mess anything up. It still spoke “starting pictures, etc” but the screen did not show a map or where the UAS was. I had to go by hearing to acquire the drone and track it that way as I initially thought it was on a fly away. Couldn’t even do a Return as nothing on screen except “drone pictures finished and uploading.” I could have switched mode and returned it but once I acquired it flying I knew it was possibly taking the pictures (and later revealed on scan disk the pictures were taken). This happened each time I landed and changed batteries and relaunched. It did a good job of going to the previous spot of where the previous flight stopped and returned. Very frustrating! I had also downloaded the mission for off the grid use but when I would start the DJI Go app you have to turn off the DD app and when I got ready to fly after starting up the DJI and then turning it off to start up the DD app it would again reload and take 5+ minutes. GOT TO BE A BETTER WAY TO DO THIS WHEN YOU ARE OUT IN NO WHERE LAND!

1 Like

Hi jdavisDavionLLC,

Thank you for reporting this issue. I have answered your questions inline:

  1. Unable to reach 400ft altitude.
    Our dev team is actively troubleshooting this issue. Once the root cause has been identified, we will push a fix to the app store.

  2. Upon a battery swap, the DroneDeploy app on your iPhone becomes unresponsive and is stuck on the screen that reads “drone pictures finished and uploading”.
    To verify your concern, did the mission complete and were your maps successfully uploaded? (Answering question #3a&b will help me with this concern)

  3. Offline map use - DD app takes 5+ minutes to load, if the DJI app is also started.
    For me to better help you here, I have a few questions:
    a. What kind of iPhone are you using?
    b. How many apps do you have running in the background?
    The DJI and DroneDeploy can utilize a lot of RAM on your mobile device where older mobiles devices or having too many applications running in the back ground can impact your experience. Having only the necessary apps open can improve your experience.

Same thing happened to me a couple of months ago when I tried to set my altitude in DD to 400, I had to lower it, I don’t remember what I lower it to but it wouldn’t let me set it to 400’

1 Like

I’m experiencing the same issues “Altitude is too high” To date, I have reinstalled the DD app X2 along with the DJI App, firmware update, increasing altitude settings in DJI, etc, etc, etc… I’m only able to fly around 350 feet.

This is very frustrating!!!


Hi @rmoore,

Our product team is actively looking into this issue. We will update you as soon as we are able to release an update.

Thank you for your patience.

Any word on the app update?

1 Like

This should be fixed in the latest version. Does it still happen for you?

I found I encountered the same problem with DD app. I could fly my drone with DJI go 4 app within regulated (60 meter) altitude limit, but when I wanted to launch it with DD all, it showed “aircraft altitude too high” message which blocked my drone to take off.
I then found the ground altitude (200m) is higher than regulated altitude limit (60m). Is this the problem causing this issue? Any method to legally launch my drone?


The ground altitude is not an issue. Did you try 50m for your mission height? Does that work? If so try 55m. I have seen this problem in the past and got mostly around it by setting my mission height a little under the limit set in DJI go 4.