Connection Issues & Photos Stop Mid-flight

Hi, I’ve ran a few test runs recently and have had mixed results on the latest IOS version. I ran a map today and had issues getting my P3P to connect before flight. I had to turn on/off the controller, Phantom, and kill the app before I was able to get it to show drone connected.

I ran the flight and while it appeared to fly the plan correctly, during the flight I had no visible connection on the app (showed the correct waypoint shifting, but intermittent video signal from camera and telemetry data). The P3P flew the lines correctly and when I pulled the data from the drone it only took 24 pictures of the ~160 it should have.

Two versions of the app ago worked perfectly - solid connection and video, but the last two releases have not worked well in my opinion. I’ve not changed anything except updated the DD app.


Hi @airwee, sorry to hear that you are experiencing this issue. Can you please send us an email at and include the version of the App that you are currently using as well as, your droneplay username so that we can look into this for you.

Experienced a similar issue with photos stopping mid-flight due to a connection loss. I flew a test flight earlier that same day where everything worked perfectly. Later in the afternoon I flew over an expanded area and lost connection towards the edge of my survey route. The app reconnected with my DJI Phantom 3 Standard approximately 10 seconds later and it continued to fly the rest of the planned route without issue. When I uploaded my photos it only captured up until the point where I briefly lost connection. Was a solution found for @Jerther? I’m using the most up to date app and firmware as of this post.