Connecting DJI Phantom 3 Standard to DroneDeploy app

All compatible drones (P3 Advanced and Pro/P4/Inspire 1) use a cable to connect the smart phone to the controller, which the DroneDeploy app picks up on in order to connect to the Drone. The DJI Phantom 3 Standard however connects to the controller and aircraft via wifi, therefore I am unable to get the app to recognise that my Drone is connected. DroneDeploy advises that the P3 Standard is compatible. Any ideas as to how I can wirelessly connect to the DropeDeploy app?

Standard connects in a similar way, just use wifi like you do with DJI go

Thanks chasemgray, however when I loaded the app I couldn’t find the option to connect via wifi. Any idea where this is located within the app?

The process would be to make sure DJI Go is closed, open dronedeploy, go to android settings, switch Wifi to the phantom wifi, then go back to dronedeploy, wait for it to connect.

I have had a good look through the app, account settings etc. But I am still unable to find the android settings. Apologies but where do I look to find these settings? Are they only available when the drone is switched on? I have even tried starting a new plan and the option is not available that I can see…

Sorry,
I mean you must open the system settings on your android device.

I have connected my android to the drone wifi and DroneDeploy initially recognises the connection, but then it states that the USB is connected and is waiting for the drone. Then when I save the plan it says ‘connect a drone to fly’. So I am still unable to get he connection in order to fly the drone via DroneDeploy. Everything works perfectly via DJI Go. Any other ideas? Thanks

Hey there. The connection to the Phantom 3 Standard is a bit complicated. I normally have to restart the app several times before it makes a stable connection and authorizes me to fly. Sometimes it works at the same time with DJI go app. This combination makes me feel safe because in any moment I can return to the original app and take control. Try starting the controller and the drone, opening the app and then connecting to the wifi. If it gives you the “drone connected” message, you can open DJI go at the same time without losing signal. Remember to allow multiple flight mode in DJI go app and switch the controller to proper position.

@Caio_Petri
Thanks for the tips. I have finally managed to get connected. I had to complete two firmware updates and two DD app updates. I now however have the issue of the DD app not taking pictures throughout the entire mission. Today I got half way through and the Gimbal returned to its starting position, the drone continued on the planned mission route, the mission completed but I only have half the photos.

Ever come across this before?

Thanks.

My gimbal always turn front when de drone is taking off and landing, but I had no issues during my missions related to this. It also keeps taking photos while taking off and landing. Isn’t there any problem with your SD card?

@Caio_Petri
I have just formatted the sd card via the DJI go app. I will hopefully get out on my next mission at the weekend and will be able to see if this fixes the issue. I will let you know.
Thanks.

michja, i am having the same problem. did you solve this? if yes, could you tell me how?

thank you.

I’m having the same problem on my Phantom 4 Pro with a USB cable on my Android Nexus 5 phone. I have made sure no apps are running, power up the controller, then the aircraft and then open the app. It gives me the option choose DJI GO or DroneDeploy. I choose DroneDeploy, select a flightplan and get nothing but crickets and " ‘connect a drone to fly’.

My Nvidia Shield will arrive this week and I’ll see if I get a different result.

p.s. sorry for the threadjack, but it seems like a potentially related issue since we’re both getting the same error message.

Did you ever get this working correctly?

I have been flying with drone deploy app for over a week now but i haven’t encountered my current problem until yesterday. I am using phantom 3 standard. It says that my remote controller is in the wrong mode. I have tried switching to all of the mode but none work. Uninstalling the DD app then reinstalling it did not solve the problem. Updating the firmware of the P3 made it worse as the message “Drone Connected” does not appear(this was the case for one of the mobile units Im using which is Oppo CPH1609 though my Samsung J2 still displays the message after the firmware update). I thought that fully charging both the remote controller and the battery would do the trick but it didn’t. Any suggestions on what should I do?

Edit: Multiple Flight Mode is on
Edit: DJI Go can connect with the drone

1 Like

Nfgarcia coloca os botões de baixo todos pra esquerda

Ao tentar fazer o check list, vem ocorrendo esse erro no DD, alguém pode me ajudar pra resolver isso!
Tenho um Iphone11
Drone Phantom 3 Pro

O mesmo funciona no Android normal!