Clas_s G Airspace near Airport. DD won't fly. What is the procedure?

I tried to fly a mission yesterday in Class G airspace near an airport. (Yes it was safe. I’m not looking for an analysis of my safety assessment) I was using an Inspire 1 Pro, with an iPad Pro. Drone Deploy would not let me take off. I went through the unlock process in DJI Go, took off briefly then landed. Closed Go. Opened DD. DD gave me a message that it was unable to upload the mission. I’ve experience this before with DD near airports. I ended up flying the mission manually using GO which gets the job done but is less than ideal.

I was able to fly other missions yesterday away from the airport using the same equipment with no trouble so I’m fairly confident this was an issue with proximity to the airport even thought DD doesn’t specifically say so in the error message.

What is DD’s unlock procedure for such a situation?

PS - I had to edit the title of my post because the forum identified the last three letters of Clas_s as a censored word and wouldn’t let me create the topic

Hi @brianpgreen,

Thanks for swinging by the DroneDeploy forum. My teammate @zach1 will be sharing and requesting some info regarding your issue in a private message.


Exact same issue on my Inspire 1 Pro. DJI allows you to unlock the authorization zones either at the time with wifi or in advance on the desktop computer, but DD doesn’t recognize the DJI authorization (Pix 4d Capture and MapPilot do). Have been waiting since June for a fix, ever since an embarassing no-go in front of a paying client. This is a new bug by the way, since April or so, when DJI introduced the authorization zone policy and DD hasn’t caught up yet.

Hi @dronexsolutions,

I noted that in another post, my teammate @chasemgray suggested updating our app to the latest version. We are sincerely trying to help you and figure out the root of the issue, but if you are unwilling to work with us, it will be difficult to assist you.

As mentioned before, we’re a community that intends to learn and grow together.


Christina my app is always up to date. (in fact, this bug was the result of an update!) I update before every flight. DJI drone pilots can go to to see in advance which areas will be off limits and plan accordingly just in case.

Hi @dronexsolutions,

I’ve sent you a private message requesting the email address associated with your DroneDeploy account. Please get back to me as soon as you can.


Hi all,

That is a well know third part app limitation.
DJIs APK does not allow NFZ opening at this time and according to their last updates and comms, shouldn’t be before a long time. Even if you “open” with Go before, as soon as you switch to any third app, NFZ is closed again.
Even GS Pro DJI App doesn’t manage NFZs … just for laugh !

@cousin we do have the ability to unlock and fly within no fly zones. This was disabled for most users on DD due to some bugs the the DJI SDK but if you need it enabled we can enable on iOS. Hopefully soon we’ll also be able to enable it on Android. It’s possible with the latest DJI SDK release we can re-enable this for everyone by default.

@chasemgray I am still having issues using DD in an unlocked NFZ. The area I need to fly is next to an airport. I have all permissions to fly in the area and can successfully conduct the flight with DJI Go. The DD checklist is completed successfully but then the mission fails to upload. Could you please help me unlock the no fly zone in my DD account? I’m using iOS and the latest version of DD. Resolving this issue is urgent to the success of my company as I’m scheduled to fly the site for a county project this week. Thank you.

If you reach out the the support team at they can enable this for you.

1 Like

@chasemgray Great, thank you!

@dronexsolutions Have you tried flying with Pix4dCapture or MapPilot in an unlocked NFZ? Some have said these apps recognize the DJI authorization and others say they also don’t work with the Inspire 1 series. I’m considering testing these apps for collecting my imagery if I can’t get this issue resolved with DD. I have several other projects coming up soon in authorization zones so I need to figure something out.

Since January, DD seems to recognize the DJI go exemption (in most other areas, I still have the same problem with the one particular area mentioned above). Here’s what I have to do to make it work: I went in advance to DJI website and requested an exemption for that area. Close everything. Have internet connection. Open DJI Go, take-off manually just hover a few metres in the air, and a warning pops up saying permission etc. etc., while aircraft is hovering I give my permission. Then I land the drone. Then, close DJI and open DD, and start flight. Curious if others noticed same thing?
The interface between DJI and DD is at best of times flawed, and at worst of times a risk to public safety. (Ever summoned the drone home early from mapping flight using in-app RTH button? Every 1 in 20 times or so, it drops straight down from wherever the user stops it instead of RTH !! yikes!!)

Has the NFZ issue between DD and the DJI SDK been resolved yet? Five months ago I could not fly DD missions in an unlocked DJI NFZ. I was using the Inspire 1. I ended up having to fly the mission manually using Pix4dCapture “free flight mode.” I now have to repeat the same mission in the same unlocked NFZ. It would be great to be able to use DD waypoints instead of having to manually fly the 100+ acre site. I’m going to be flying the site with a P4P instead of the Inspire 1. Does that change anything? Thanks.

@Wcp850 Hello thanks for reaching out.

Unfortunately the DJI No Fly Zone feature has not been resolved yet. We are still experiencing issues with users trying to fly in No Fly Zones. This is a known Issue that DJI acknowledges and we have no control in influencing the DJI SDK to enable waypoints in No Fly Zones. Thanks for being patience and we hope to see this issue resolved soon.