Can't get Mavic 2 Pro to display image


This is what I did step by step, what am I missing?

Planned flight, get into DJI GO4, everything fine (imagem sensors, etc), close DJI GO, open Drone Deploy, check list goes fine, take off perfect but I can’t get Drone Deploy to show what the drone camera is seeing.
It just shows a black screen, I tried switch between map view and drone view and the same, maps (with the planned flight and drone position) shows fine on iPhone but I can’t see what the drone camera is taking.
The mission was completed properly, the photos where taken but no liveview.

Redid the mission with my old Mavic Pro 1 and I can get image and map working fine.
Seems there some communication issues between MP2 and DD.

I can’t find any info about this issue, anybody with similar problems?.


Sorry, just found a thread with this know issue.
I’ll try the “unplugging the controller from your device and plugging it back in” trick tomorrow.


I get the same issue with my iPhone 8 and the Mavic 2 Pro. Unplugging works, but it’s pain doing this every single time I go out to fly.

1 Like

I’m having the same exact issue. Unplugging and replugging cables doesn’t work, restarting doesn’t work, deleting the app and reinstalling doesn’t work. None of these suggested fixes work at all.

1 Like

I got it to work. Then when I switch out batteries, it’s black again.

I get the same issue with Ipad air. Not tried to unpluging

The unplug / plug trick works on iPhone X and iPhone Xs Max at least.
It’s annoying but it works.