Can't continue mission

I’m can’t seem to resume a mission. It’s an intermittent issue, but once a mission can’t be resumed once, I can’t successfully resume it again, no matter what I try.

The mission is a crosshatch 3d mission, with roughly 1700 images over 2 acres. The most recent time I tried it, I started with a low battery, it flew a few passes, correctly landed, I swapped the battery, and it resumed without a problem. It then landed again when the battery got low, and refused to continue.

When t refuses to continue, it goes like this:

  • It goes through the preflight check, then I click the Start flight button.
  • I see an “Image capture started” message, and then a “Drone initializing” message.
  • Eventually the “Drone initializing” message disappears, and at same time, the flight plan paths on the map disappear.
  • The drone propellors never spin, and it stays in this state indefinitely.

The only thing I’ve found that works is to reset the mission.

I’ve tried closing, killing, and reopening the app, power cycling the controller and the drone, and taking off first and then continuing the mission.

I’m using a Mavic 2 Zoom running firmware 1.00.0510, and DroneDeploy 4.4.2 on an iPhone running iOS 13.3.1.

I’m out of things to try. Any ideas?

1 Like