Cannot start mission - error executing command code -1008


#1

Hi guys,
Just signed up for the free trial of DroneDeploy and headed out to make my first map. Had some issues at first due to outdated firmware but upgraded to the latest on controller and aircraft and everything seemed to be working great. I planned a flight, put my controller into F mode, tapped fly on my flight plan, then tapped the pulsing blue check mark. Got a message saying “(i) cannot start mission”. Tapped it again, thinking it was a fluke, got a message saying “Error executing command (code -1008)”.

Some info:
Phantom 3 Adv
Latest firmware for controller & aircraft
Latest version of drone deploy on iPhone 6

Things I’ve tried:
Complete power cycle, even restarted iPhone
Different batteries
Using range extender
Turning off Geo System in DJI app
Downloading flight plan for offline use
Searched DroneDeploy forums for similar issues, found one with same code -1008. The post said the problem was related to weak signal/bad communication. I have a solid signal with all bars for connection, as well as 14 satellites.
Although I have referred to the DJI GO app occasionally throughout this process, I have avoided having both DJI and DroneDeploy apps running at the same time.


#2

Hi @jpiii,

Thank you for your inquiry. This is a common issue that we have seen with the P3A. This a drone firmware issue introduced during one of DJI’s updates. We have seen users overcome the issue by restarting and trying again several times. We do have plans to phase this model drone out in the near future.

Let us know what your results are.

Thank you,
Nipul


#3

I had the same problem. After I had the 1008 error I just turned of the Phantom and then turned it back on. After that everything worked fine. I did not restart the phone or controller.
Give it a try.

Roman


#4

Hi Roman,
I tried power cycling just the aircraft like you said and it worked great! Apparently cycling the controller as well was where I went wrong. Thanks for the tip!


#5