Canceling Automatic Return To Home


It would be nice if I could manually override the automatic return to home function.

The drone was 1,5 km away from me and returned home with 20% battery. So I had to wait for the drone, replace the battery and fly back for the remaining 15 photos (approx 2% battery time). So I lost 10 minutes, and 10-15% of a new battery.

If I could chose, most of the times I would rather let the drone finish making the photos and land it manually - and walk/drive to collect the drone. I’m an agricultural user, sometimes I can pick it up anywhere, sometimes only 1 landing spot available.

I won’t sue you if I miscalculate and the drone doesn’t make it back. It’s my responsibility, but I should have the opportunity to choose.

Also you HAVE to let me control the landing. If you miss just by 50 cm (poor GPS), you will topple the drone, land it in crops, puddles…
Right now it forces down the drone, you can only slow it down a bit, but it will touch down no matter what I do.
Last time it landed sideways (it was uneven surface) it cost me 100 bucks and 3 weeks service time. I wanted to land it elsewhere but it landed - despite me pushing buttons and yelling furiously.

So in summary: automatisms are good, but please let the user decide when and where to land.



That’s some bad luck getting the battery that low with so few images left! Unfortunately when you do let it get that low it’s DJI that is force-landing. What are your Low and Critical battery settings in DJI?

If you switch to atti mode and it is still landing it’s not DroneDeploy. Consistently running batteries below 25% is really bad for them and you will increase the chances that they will start swelling prematurely. Also when returning that low it can become a problem if there is a headwind and the drone will force itself down before ever making it to the home position because it does not have enough power to fight.

Have found with P4P DD tends to land fast so will often put some inputs in to help it flare a bit without having to go into Atti mode. Now and then DD will request, suggest operator input on landing and can usually do without having to go into Atti mode. However if you do go into Atti mode (e.g. high winds, cancel mission, etc.) make sure you get out of Atti mode after landing and before next DD flight/mission. DD may launch the aircraft and fly the mission, however may not capture images and other things as expected.

I usually only have to do it when I am done with the queued missions and am ready to fly manually or RTH. Flip to Atti and back to P has always worked for me and it will not restart a mission that is already running until you reboot the drone and/or DroneDeploy. If you want it to restart the mission after mid-flight manuals then you have to pause it.

I had this same issue the other day with the return to home function. I have no way to override and gain manual control once it is in the RTH function. Even when I switched to the manual screen on DroneDeploy I was not able to lower the craft or gain any kind of control. The only control I did have was how fast it descended from the sky.

Atti-Flip didn’t work for you?

Switching over to Sport mode did take back control. So if I am flying and something in the air becomes an obstacle such as another aircraft switching to Sport mode on the remote took me out of the automation.

1 Like